Subject: [jose] ES6-compatible JSON Number Canonicalizer in Java

From: Anders Rundgren <[email-masked]>
Date: Thu, 29 Oct 2015 22:55:07 +0100

I have only spent some 10 hours on this code so I can't guarantee that it is perfect:
https://github.com/cyberphone/openkeystore/blob/master/es6-numbers/src/com/example/es6numbers/Test.java

Result:
http://webpki.org/ietf/es6numbertest.html

Anders

---

From: Mike Jones <[email-masked]>
Date: Thu, 29 Oct 2015 22:01:42 +0000

You're missing the point.  It's not whether you can write custom code that will always do the same thing.  I'm sure you can.  It's whether the vast majority of deployed JSON serializers will also do exactly the same thing.  It's that latter that would need to be true in order for it to be a reasonable basis for a successful standard.

-----Original Message-----
From: jose [mailto:[email-masked]] On Behalf Of Anders Rundgren
Sent: Thursday, October 29, 2015 2:55 PM
To: [email-masked]
Subject: [jose] ES6-compatible JSON Number Canonicalizer in Java

Result:

Anders

_______________________________________________
jose mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jose

---

From: Anders Rundgren <[email-masked]>
Date: Thu, 29 Oct 2015 23:11:10 +0100

On 2015-10-29 23:01, Mike Jones wrote:
> You're missing the point.  It's not whether you can write custom code that
 > will always do the same thing.  I'm sure you can.

I hope so, math isn't really my forte :-)

> It's whether the vast majority of deployed JSON serializers will also do
 > exactly the same thing.

They surely don't since they never had a reason to do that.

> It's that latter that would need to be true in order for it to be a
 > reasonable basis for a successful standard.

JavaScript and the Web are (IMHO) big enough to drive this thing alone,
the rest will join the party if/when they feel there is a need.

Anders