Subject: [jose] Exotic use of JWE "iv" header

From: Vladimir Dzhuvinov <[email-masked]>
Date: Wed, 21 Oct 2015 08:31:11 +0300

Last night I saw a ticket from a developer who was trying to set the IV
for the JWE content encryption by passing the value through the "iv"
header parameter.

My understanding is that this is not standard behavior, but still, is
this is a sensible method to allow developers to set the IV? (if set by
the developer the "iv" header parameter is to be removed before the JWE
is created). This method of course will have problems when AES/GCM key
wrap is used, as then there will be no way to set two nonces via the
"iv" header.

https://bitbucket.org/connect2id/nimbus-jose-jwt/issues/158/jwe-iv-remains-in-jwe-header

Vladimir

---

From: "Matt Miller (mamille2)" <[email-masked]>
Date: Wed, 21 Oct 2015 13:57:25 +0000

> https://bitbucket.org/connect2id/nimbus-jose-jwt/issues/158/jwe-iv-remains-in-jwe-header

I understand the desire to do this, and there are *some* legitimate reasons for a developer to provide the IV (although just about all of them are with regards to consistent testing outcomes).

Personally, I'd make it hard to do, but maybe not impossible.  I think using the header is a terrible idea; like you say, it overloads its meaning and that will cause problems.

--
- m&m

Matt Miller <[email-masked]>
Cisco Systems, Inc.

---

From: "Jim Schaad" <[email-masked]>
Date: Wed, 21 Oct 2015 10:49:59 -0700

I can see a value of allowing for the ability to set an IV for the GCM case
if the uniqueness of the GCM key IV is being kept by the application rather
than the crypto system.   I am not sure that this is the way that I would go
about doing this for JOSE.  However this is the way it would be done for
COSE so it might not be a completely bad thing to support.

Jim

> -----Original Message-----
> From: jose [mailto:[email-masked]] On Behalf Of Vladimir Dzhuvinov
> Sent: Tuesday, October 20, 2015 10:31 PM
> To: [email-masked]
> Subject: [jose] Exotic use of JWE "iv" header
> 
for the
> JWE content encryption by passing the value through the "iv"
> header parameter.
> 
> My understanding is that this is not standard behavior, but still, is this
is a
> sensible method to allow developers to set the IV? (if set by the
developer the
> "iv" header parameter is to be removed before the JWE is created). This
method
> of course will have problems when AES/GCM key wrap is used, as then there
will
> be no way to set two nonces via the "iv" header.
> 
>
https://bitbucket.org/connect2id/nimbus-jose-jwt/issues/158/jwe-iv-remains-
> in-jwe-header
> 
> Vladimir
> 
> 
> 
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose