Subject: [jose] Does JWS signature relate with JWS payload?

From: Beth Lee <[email-masked]>
Date: Thu, 22 Feb 2018 11:35:41 +0900

Hi. I'm Jin.

I have curious about JWS signatrue in JWT.

I already read the JWT spec inforation from
https://www.rfc-editor.org/rfc/rfc7515.txt
But I'm still confusted about JWS signatrue contains or relate with JWS
Payload value or not.

I knew that JWT contained with 3 part. (JOSE Header, JWS Payload, JWS
Signatrue)

When I read the spec information.
I understood that JWS signature value doesn't contain the JWS payload value.

Am I right? Then how can I check data integrity based on JSW signature ?
(I guess I'm not right.)

I really want to solve my question but I can't reache the answers.

So please give me some advice.

Best regards,
Jin

---

From: n-sakimura <[email-masked]>
Date: Fri, 23 Feb 2018 06:02:58 +0000

Hi

JWS Signature is the signature only. It does not repeat the payload.

Best,

Nat Sakimura

From: jose [mailto:[email-masked]] On Behalf Of Beth Lee
Sent: Thursday, February 22, 2018 11:36 AM
To: [email-masked]
Subject: [jose] Does JWS signature relate with JWS payload?

Hi. I'm Jin.

I already read the JWT spec inforation from https://www.rfc-editor.org/rfc/rfc7515.txt
But I'm still confusted about JWS signatrue contains or relate with JWS Payload value or not.

I knew that JWT contained with 3 part. (JOSE Header, JWS Payload, JWS Signatrue)

Best regards,
Jin

---

From: Beth Lee <[email-masked]>
Date: Fri, 23 Feb 2018 18:14:03 +0900

Thank you so much for answering my question.

Finally, I can solve my question.

Thank you again.

Best regards,
Jin.

2018-02-23 15:02 GMT+09:00 n-sakimura <[email-masked]>:

> *From:* jose [mailto:[email-masked]] *On Behalf Of *Beth Lee
> *Sent:* Thursday, February 22, 2018 11:36 AM
> *To:* [email-masked]
> *Subject:* [jose] Does JWS signature relate with JWS payload?
>
>
>
> Hi. I'm Jin.
>
>
>