Subject: [jose] JOSE and PKCS11

From: "Stefan Berger" <[email-masked]>
Date: Thu, 1 Nov 2018 22:32:27 +0000

I was wondering whether the integration of JOSE with PKCS11 was not considered for some reason or it was an omission. One could describe private keys of hardware devices using the PKCS 11 URI scheme (https://tools.ietf.org/html/rfc7512)  and reflect those in the JWE recipients header, for example, to use such a device for key unwrapping. It may be as easy as adding pkcs11 field(s) to the JOSE parameters (https://www.iana.org/assignments/jose/jose.xhtml)

Regards,
Stefan

---

From: Nathaniel McCallum <[email-masked]>
Date: Thu, 1 Nov 2018 19:07:55 -0400

https://tools.ietf.org/html/draft-mccallum-jose-pkcs11-jwk-00

I plan to update this in the upcoming months and publish it as an
independent draft. Likewise, we are implementing it here:

https://github.com/latchset/jose

Your contributions are welcome!

On Thu, Nov 1, 2018, 6:32 PM Stefan Berger <[email-masked] wrote:

> I was wondering whether the integration of JOSE with PKCS11 was not
> considered for some reason or it was an omission. One could describe
> private keys of hardware devices using the PKCS 11 URI scheme (
> https://tools.ietf.org/html/rfc7512)  and reflect those in the JWE
> recipients header, for example, to use such a device for key unwrapping. It
> may be as easy as adding pkcs11 field(s) to the JOSE parameters (
> https://www.iana.org/assignments/jose/jose.xhtml)
>
> Regards,
>    Stefan
>
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose
>

---

From: "Stefan Berger" <[email-masked]>
Date: Thu, 1 Nov 2018 19:06:03 -0500

> https://tools.ietf.org/html/draft-mccallum-jose-pkcs11-jwk-00

Ah, didn't know about it.

> Your contributions are welcome!

:-) I wished... But I may need it in a different language with less pkcs
stuff in place as it seems )-: https://github.com/square/go-jose/tree/v2

> recipients header, for example, to use such a device for key
> unwrapping. It may be as easy as adding pkcs11 field(s) to the JOSE
> parameters (https://www.iana.org/assignments/jose/jose.xhtml)
>
> Regards,
>    Stefan
>
> INVALID URI REMOVED
> u=https-3A__www.ietf.org_mailman_listinfo_jose&d=DwICAg&c=jf_iaSHvJObTbx-
>
siA1ZOg&r=1v27re_HJcPTJPkwTHXQYpTrbS_E7w3vBoyF3b2lE60&m=fwh9lQdx7kzAri5bGGDtLW6I138IRWSED_2pORvlFx4&s=JrLX5G13EPoinNwTbGVxqCbTThkhRzvoPNoGVJyv67w&e=