Subject: [jose] [Editorial Errata Reported] RFC7515 (5810)

From: RFC Errata System <[email-masked]>
Date: Tue, 13 Aug 2019 15:19:52 -0700 (PDT)

The following errata report has been submitted for RFC7515,
"JSON Web Signature (JWS)".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5810

--------------------------------------
Type: Editorial
Reported by: Avinash Kumar Singh <[email-masked]>

Section: 1

Original Text
-------------
 Cryptographic algorithms and identifiers for use with this
   specification are described in the separate JSON Web Algorithms (JWA)
   [JWA] specification and an IANA registry defined by that
   specification.  Related encryption capabilities are described in the
   separate JSON Web Encryption (JWE) [JWE] specification.

Corrected Text
--------------

Notes
-----
The Hyperlink used for JWA and JWE is not working and pointing to the same RFC 7515.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7515 (draft-ietf-jose-json-web-signature-41)
--------------------------------------
Title               : JSON Web Signature (JWS)
Publication Date    : May 2015
Author(s)           : M. Jones, J. Bradley, N. Sakimura
Category            : PROPOSED STANDARD
Source              : Javascript Object Signing and Encryption
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Jim Schaad <[email-masked]>
Date: Tue, 13 Aug 2019 20:48:14 -0700

This goes as a won't fix or delete because it is not a real errata.

The errata has been reported against the html-ized version of the RFC and not against the RFC proper.  How links work for the HTML-ized version is to link first to the reference and then you can go from there to the other document.

-----Original Message-----
From: RFC Errata System <[email-masked]> 
Sent: Tuesday, August 13, 2019 3:20 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Editorial Errata Reported] RFC7515 (5810)

The following errata report has been submitted for RFC7515, "JSON Web Signature (JWS)".

Section: 1

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please use "Reply All" to discuss whether it should be verified or rejected. When a decision is reached, the verifying party can log in to change the status and edit the report, if necessary.

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 14 Aug 2019 23:08:57 -0500

My recollection is that the RFC Editor will usually delete these, yes.

-Ben

On Tue, Aug 13, 2019 at 08:48:14PM -0700, Jim Schaad wrote:
> _______________________________________________
> jose mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jose