Subject: [jose] JWS/CT - Dropping the ISE track?

From: Anders Rundgren <[email-masked]>
Date: Sun, 12 Dec 2021 08:41:51 +0100

Hi List,

As you may recall, there were opposition against publishing the JSON Canonicalization Scheme as an IETF RFC.  Therefore it ended up as RFC 8785 using the ISE track.

Now the authors are facing the same situation with a follow-up specification, JWS/CT: https://www.ietf.org/archive/id/draft-jordan-jws-ct-06.html

We have been requested to insert a warning sign [*] in the "Abstract" which seems like a rather unusual way of structuring a specification.  This text is then to be repeated 3 times more.  The argument is that nobody reads the "Status of This Memo" which may be true.

Regardless of what you think about this particular work item, I believe the time has come for the IETF to take a FIRM POSITION on how to deal with ISE publications.

My proposal is that the IETF either dumps the ISE track altogether or publish such documents under another brand, like ISE-nnnn to avoid the possible confusion between genuine IETF standards and ISE RFCs.

What do you think?  I have no particular preferences except that all ISE documents should be treated equal.  That some ISE publications like RFC 8785 may end-up as de-facto standards is probably what many authors had in mind from the very beginning.

Sincerely,
Anders Rundgren

*] This informational specification has been produced outside the IETF,
   is not an IETF standard, and does not have IETF consensus.

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 12 Dec 2021 14:31:10 +0100

>   is not an IETF standard, and does not have IETF consensus.

This is a true statement, so I don’t know how you could be opposed.

What is still not true is the “clear text” in the title.
I thought we had discussed this; I’m certainly not going to engage in any repeat discussion.
Keeping this term in the title smacks like intent to deceive.

Grüße, Carsten

---

From: Anders Rundgren <[email-masked]>
Date: Mon, 13 Dec 2021 05:47:51 +0100

As I wrote the issue here is how to deal with ISE documents, now, and in the future.  JWS/CT is a recent example highlighting a problem that the IETF may need to address.

Forcing authors to decorate their documents with plenty of "red flags", including in the abstract, is one possibility, albeit not particularly attractive.  Another solution is scrapping the ISE concept altogether.

thanx,
Anders

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 13 Dec 2021 06:36:56 +0100

> As I wrote the issue here is how to deal with ISE documents, now, and in the future.  JWS/CT is a recent example highlighting a problem that the IETF may need to address.

The Independent Stream works great for what it is supposed to do.
The fact that you do not seem to like the conditions for publishing there doesn’t mean there is an “issue” that invalidates the whole stream.

Please note that the Independent Stream is, as the name kind of reveals, independent of the IETF.
The JOSE mailing list of the IETF is certainly not the place to bring up any desire to change it.

Grüße, Carsten