Subject: [Jwt-reg-review] Request to register claim: "at_use_nbr"

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Mon, 27 May 2019 03:36:08 +0000

Dear,
On behalf of ETSI NFV ISG, I would like to submit the following registration request for the “JSON Web Token” registry:

  *   Claim Name: “at_use_nbr”
  *   Claim Description: Number of API requests for which the access token can be used.
  *   Change Controller: ETSI ([email-masked]<mailto:[email-masked]>)
  *   Specification Document(s): Clause 5.5<https://openid.net/specs/openid-connect-core-1_0.html#StandardClaims> of the present ETSI GS NFV-SEC 022<https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060> (https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip)
Please, note that once the specification is approved, the pointer to the specification will be updated.

Best regards.

-----------------------------------------------------------------------------------------------------------------
Miguel Angel Reina Ortega – Testing Expert
Centre for Testing and Interoperability (CTI)
ETSI ● www.etsi.org<http://www.etsi.org/> ● [email-masked]<mailto:[email-masked]>
Phone: +33 (0)4 92 94 43 49 ● Mobile: +33 (0)6 76 73 60 99

This email may contain confidential information and is intended for
the use of the addressee only. Any unauthorized use may be unlawful.
If you receive this email by mistake, please advise the sender
immediately by using the reply facility in your email software.
Thank you for your co-operation.

---

From: Brian Campbell <[email-masked]>
Date: Wed, 29 May 2019 11:02:05 -0600

In general I think that the “at_use_nbr” claim can be registered given how
it is described in the NFV_SEC022v0-1-0-cb.docx file inside the zip file at
the
https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip
link provided.

However, there are also links there to
https://openid.net/specs/openid-connect-core-1_0.html#StandardClaims and
https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060
which are confusing and/or don't seem right.

Also the NFV_SEC022v0-1-0-cb.docx document also still has "scope" in the
JSON Web Token Claims registry which needs to be removed. Because
ultimately I think IANA works off of the specification document itself.

On Sun, May 26, 2019 at 9:36 PM Miguel Angel Reina Ortega <
[email-masked]> wrote:

> Dear,
>
> On behalf of ETSI NFV ISG, I would like to submit the following
> registration request for the “JSON Web Token” registry:
>
>    - Claim Name: “at_use_nbr”
>    - Claim Description: Number of API requests for which the access token
>    can be used.
>    - Change Controller: ETSI ([email-masked])
>    - Specification Document(s): Clause 5.5
>    <https://openid.net/specs/openid-connect-core-1_0.html#StandardClaims>
>    of the present ETSI GS NFV-SEC 022
>    <https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060>
>    (
>    https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip
>    )
>
> *Miguel Angel Reina Ortega **–* Testing Expert
>
> *ETSI* ● www.etsi.org ● [email-masked]
> <[email-masked]>*
>
> _______________________________________________
> Jwt-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jwt-reg-review
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._