Subject: Re: [Jwt-reg-review] Request to register claim: "at_use_nbr"

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Thu, 6 Jun 2019 09:58:38 +0000

Dear Brian,

Thanks for the comments. The “scope” claim will be removed from there.

On the other hand, I don’t see any of those links you mention, just the following: http://openid.net/specs/openid-connect-core-1_0.html#IDToken. which seems correct to me.

Best regards.

From: Brian Campbell <[email-masked]>
Sent: 29 May 2019 19:02
To: Miguel Angel Reina Ortega <[email-masked]>
Cc: [email-masked]; PNNS <[email-masked]>
Subject: Re: [Jwt-reg-review] Request to register claim: "at_use_nbr"

In general I think that the “at_use_nbr” claim can be registered given how it is described in the NFV_SEC022v0-1-0-cb.docx file inside the zip file at the https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip link provided.

However, there are also links there to https://openid.net/specs/openid-connect-core-1_0.html#StandardClaims and https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060 which are confusing and/or don't seem right.

Also the NFV_SEC022v0-1-0-cb.docx document also still has "scope" in the JSON Web Token Claims registry which needs to be removed. Because ultimately I think IANA works off of the specification document itself.

On Sun, May 26, 2019 at 9:36 PM Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>> wrote:
Dear,
On behalf of ETSI NFV ISG, I would like to submit the following registration request for the “JSON Web Token” registry:

  *   Claim Name: “at_use_nbr”
  *   Claim Description: Number of API requests for which the access token can be used.
  *   Change Controller: ETSI ([email-masked]<mailto:[email-masked]>)
  *   Specification Document(s): Clause 5.5<https://openid.net/specs/openid-connect-core-1_0.html#StandardClaims> of the present ETSI GS NFV-SEC 022<https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060> (https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip)
Please, note that once the specification is approved, the pointer to the specification will be updated.

Best regards.

-----------------------------------------------------------------------------------------------------------------
Miguel Angel Reina Ortega – Testing Expert
Centre for Testing and Interoperability (CTI)
ETSI ● www.etsi.org<http://www.etsi.org/> ● [email-masked]<mailto:[email-masked]>
Phone: +33 (0)4 92 94 43 49 ● Mobile: +33 (0)6 76 73 60 99

This email may contain confidential information and is intended for
the use of the addressee only. Any unauthorized use may be unlawful.
If you receive this email by mistake, please advise the sender
immediately by using the reply facility in your email software.
Thank you for your co-operation.

_______________________________________________
Jwt-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jwt-reg-review

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited.  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

---

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Mon, 17 Jun 2019 13:20:35 +0000

Dear Brian,

I still don’t see the requested claim appearing on the registry. Is there anything that needs to be done on my side?

Thanks in advance.

Best regards.

From: Miguel Angel Reina Ortega
Sent: 06 June 2019 11:59
To: Brian Campbell <[email-masked]>
Cc: [email-masked]; PNNS <[email-masked]>
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Brian,

Best regards.

From: Brian Campbell <[email-masked]<mailto:[email-masked]>>
Sent: 29 May 2019 19:02
To: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; PNNS <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Best regards.

---

From: Mike Jones <[email-masked]>
Date: Tue, 18 Jun 2019 10:30:04 +0000

I just tried opening the docs inside the .zip file https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip to review the request and there were problems opening both of them.  Is this still the correct doc link?

                                           -- Mike

From: Jwt-reg-review <[email-masked]> On Behalf Of Miguel Angel Reina Ortega
Sent: Monday, June 17, 2019 6:21 AM
To: Brian Campbell <[email-masked]>
Cc: PNNS <[email-masked]>; [email-masked]
Subject: Re: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Brian,

Thanks in advance.

Best regards.

From: Miguel Angel Reina Ortega
Sent: 06 June 2019 11:59
To: Brian Campbell <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; PNNS <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Brian,

On the other hand, I don’t see any of those links you mention, just the following: http://openid.net/specs/openid-connect-core-1_0.html#IDToken<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23IDToken&data=02%7C01%7CMichael.Jones%40microsoft.com%7C117b5d7fa0a74e43628608d6f3269b05%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636963744489158368&sdata=iV%2BVep69GMjlccLP%2BeBHgP5ccup5v%2BBv19nxjxqT7ys%3D&reserved=0>. which seems correct to me.

Best regards.

In general I think that the “at_use_nbr” claim can be registered given how it is described in the NFV_SEC022v0-1-0-cb.docx file inside the zip file at the https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C117b5d7fa0a74e43628608d6f3269b05%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636963744489158368&sdata=OxiFVAz8tEMPiuXJuP7NGP5eViDIXtvCYiOiSM3vwTc%3D&reserved=0> link provided.

However, there are also links there to https://openid.net/specs/openid-connect-core-1_0.html#StandardClaims<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C117b5d7fa0a74e43628608d6f3269b05%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636963744489168378&sdata=rkdtD0ROF5FDv%2FJPzp4u3%2FOQQReqwe0ZHTApOsOpIMY%3D&reserved=0> and https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C117b5d7fa0a74e43628608d6f3269b05%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636963744489168378&sdata=cw24KGV4xkPtSMJRWE2ArrYH%2BFSycuZ3lkfVDDl1BCc%3D&reserved=0> which are confusing and/or don't seem right.

  *   Specification Document(s): Clause 5.5<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C117b5d7fa0a74e43628608d6f3269b05%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636963744489178387&sdata=9%2Fy%2FSKs7TJYLmfUQgE7H%2BMK9G1p%2Fu0qWeJg6bQnNN6c%3D&reserved=0> of the present ETSI GS NFV-SEC 022<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C117b5d7fa0a74e43628608d6f3269b05%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636963744489178387&sdata=XEsYxG0MJx8yWKnU4HCfabwa4t11i7HoCpQzhQq%2BNCc%3D&reserved=0> (https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C117b5d7fa0a74e43628608d6f3269b05%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636963744489188392&sdata=dELZ0uXS89HAeu2go5ogOqERu8n%2BMC8kfgvu5%2BWKQuA%3D&reserved=0>)

Best regards.

ETSI ● www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C117b5d7fa0a74e43628608d6f3269b05%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636963744489198397&sdata=lKldrk7WxSDXYBwvrcU7yyRHyfsm0d7YPhkRtAj1YSo%3D&reserved=0> ● [email-masked]<mailto:[email-masked]>

_______________________________________________
Jwt-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jwt-reg-review<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjwt-reg-review&data=02%7C01%7CMichael.Jones%40microsoft.com%7C117b5d7fa0a74e43628608d6f3269b05%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636963744489198397&sdata=aMj1EWMEjkYfN5%2BoUUV16L5au4ad%2BiCqYnVkQlZ8sLk%3D&reserved=0>

---

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Tue, 18 Jun 2019 11:53:32 +0000

Dear Mike,

Yes, it is still the correct doc link. I did not have any problem opening any of the documents.

Should I send it attached to an email for you?

Best regards.

From: Mike Jones <[email-masked]>
Sent: 18 June 2019 12:30
To: Miguel Angel Reina Ortega <[email-masked]>; Brian Campbell <[email-masked]>
Cc: PNNS <[email-masked]>; [email-masked]
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

                                           -- Mike

From: Jwt-reg-review <[email-masked]<mailto:[email-masked]>> On Behalf Of Miguel Angel Reina Ortega
Sent: Monday, June 17, 2019 6:21 AM
To: Brian Campbell <[email-masked]<mailto:[email-masked]>>
Cc: PNNS <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Brian,

Thanks in advance.

Best regards.

Dear Brian,

Best regards.

Best regards.

---

From: Mike Jones <[email-masked]>
Date: Tue, 18 Jun 2019 13:12:42 +0000

Rather than sending it to me, it would be better to place the normative doc at a permanent URL from which it can be directly opened.  The IANA registration will need to refer to this URL anyway.  Any of docx, pdf, or txt formats should be fine.

                                                       -- Mike

From: Miguel Angel Reina Ortega <[email-masked]>
Sent: Tuesday, June 18, 2019 2:54 PM
To: Mike Jones <[email-masked]>; Brian Campbell <[email-masked]>
Cc: PNNS <[email-masked]>; [email-masked]
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Mike,

Best regards.

ETSI ● www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163104705&sdata=kcQ5Nn9pNxIC%2FF8sHhP34116CtRla%2Bq284FSBHVqvDc%3D&reserved=0> ● [email-masked]<mailto:[email-masked]>

From: Mike Jones <[email-masked]<mailto:[email-masked]>>
Sent: 18 June 2019 12:30
To: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>; Brian Campbell <[email-masked]<mailto:[email-masked]>>
Cc: PNNS <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

I just tried opening the docs inside the .zip file https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163104705&sdata=tRgOMS%2F0SQ24UtuxD4PZO9fuYS2DZ0qKqeJHdbbPAHE%3D&reserved=0> to review the request and there were problems opening both of them.  Is this still the correct doc link?

                                           -- Mike

Dear Brian,

Thanks in advance.

Best regards.

Dear Brian,

On the other hand, I don’t see any of those links you mention, just the following: http://openid.net/specs/openid-connect-core-1_0.html#IDToken<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23IDToken&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163114701&sdata=G1SHeIkW2QzRPG4gyWhNNMW15vrb1VC0533fT0AVQ5k%3D&reserved=0>. which seems correct to me.

Best regards.

In general I think that the “at_use_nbr” claim can be registered given how it is described in the NFV_SEC022v0-1-0-cb.docx file inside the zip file at the https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163114701&sdata=QYgBmqU5nYE9URouJxpKhBulAy%2B0hOUUDOgryQCO0V8%3D&reserved=0> link provided.

However, there are also links there to https://openid.net/specs/openid-connect-core-1_0.html#StandardClaims<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163124693&sdata=bkLUsWbrPqh7Ua6zzXG%2BJpiT946oZIgP8pvWGiAIHmY%3D&reserved=0> and https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163124693&sdata=%2F9ae3ZOXG0CVxP6ziIneKWDanYrPiDNYjcUnzVfSstI%3D&reserved=0> which are confusing and/or don't seem right.

  *   Specification Document(s): Clause 5.5<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163134687&sdata=ULwF4H6TeAtTCuAj%2Br6n9D0eorzTyRgTa50GHNAPZxs%3D&reserved=0> of the present ETSI GS NFV-SEC 022<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163134687&sdata=1QU0NOBbhwwn%2BJSCofs4uNCcHpIVr0bj0Dh1y7lpJLM%3D&reserved=0> (https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163144683&sdata=slUSoTnNlxy6IvkHqImGws47%2FR%2BYSXiuNHrS2h3K%2BkA%3D&reserved=0>)

Best regards.

ETSI ● www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163144683&sdata=L%2FD%2BO3hdKcggGr32EFiewT9ZXa9I2XgKVn4ZtK8njo8%3D&reserved=0> ● [email-masked]<mailto:[email-masked]>

_______________________________________________
Jwt-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jwt-reg-review<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjwt-reg-review&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163154673&sdata=5fKpMwKMDx5lKy60oPas9%2Fyk6s2c0gcMeb7osyEV%2BoA%3D&reserved=0>

---

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Tue, 18 Jun 2019 14:48:41 +0000

Dear Mike,

Then, that’s the right link to use until it gets published. And it will be published once different claims are registered. So, discussing with Brian, it was agreed to use that temporary link so that you can review the specification (which actually is on hold before publication until claims are registered) and then update the registry with the final link.

I hope that’s still ok.

Best regards.

Sent: 18 June 2019 15:13

                                                       -- Mike

From: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 18, 2019 2:54 PM
To: Mike Jones <[email-masked]<mailto:[email-masked]>>; Brian Campbell <[email-masked]<mailto:[email-masked]>>
Cc: PNNS <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Mike,

Best regards.

                                           -- Mike

Dear Brian,

Thanks in advance.

Best regards.

Dear Brian,

Best regards.

Best regards.