Subject: Re: [Jwt-reg-review] Request to register claim: "at_use_nbr"

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Thu, 18 Jul 2019 08:10:59 +0000

Dear Mike,

I have not heard from you since our last exchange a month ago. It seems also that it has not been registered yet, at least I cannot see it in the registry.

Is there any pending question/modification required for the registration?

Best regards.

-----------------------------------------------------------------------------------------------------------------
Miguel Angel Reina Ortega – Testing Expert
Centre for Testing and Interoperability (CTI)
ETSI ● www.etsi.org<http://www.etsi.org/> ● [email-masked]<mailto:[email-masked]>
Phone: +33 (0)4 92 94 43 49 ● Mobile: +33 (0)6 76 73 60 99

This email may contain confidential information and is intended for
the use of the addressee only. Any unauthorized use may be unlawful.
If you receive this email by mistake, please advise the sender
immediately by using the reply facility in your email software.
Thank you for your co-operation.

From: Miguel Angel Reina Ortega
Sent: 18 June 2019 16:49
To: 'Mike Jones' <[email-masked]>; 'Brian Campbell' <[email-masked]>
Cc: PNNS <[email-masked]>; [email-masked]' <[email-masked]>
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Mike,

Then, that’s the right link to use until it gets published. And it will be published once different claims are registered. So, discussing with Brian, it was agreed to use that temporary link so that you can review the specification (which actually is on hold before publication until claims are registered) and then update the registry with the final link.

I hope that’s still ok.

Best regards.

-----------------------------------------------------------------------------------------------------------------
Miguel Angel Reina Ortega – Testing Expert
Centre for Testing and Interoperability (CTI)
ETSI ● www.etsi.org<http://www.etsi.org/> ● [email-masked]<mailto:[email-masked]>
Phone: +33 (0)4 92 94 43 49 ● Mobile: +33 (0)6 76 73 60 99

This email may contain confidential information and is intended for
the use of the addressee only. Any unauthorized use may be unlawful.
If you receive this email by mistake, please advise the sender
immediately by using the reply facility in your email software.
Thank you for your co-operation.

From: Mike Jones <[email-masked]<mailto:[email-masked]>>
Sent: 18 June 2019 15:13
To: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>; Brian Campbell <[email-masked]<mailto:[email-masked]>>
Cc: PNNS <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Rather than sending it to me, it would be better to place the normative doc at a permanent URL from which it can be directly opened.  The IANA registration will need to refer to this URL anyway.  Any of docx, pdf, or txt formats should be fine.

                                                       -- Mike

From: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 18, 2019 2:54 PM
To: Mike Jones <[email-masked]<mailto:[email-masked]>>; Brian Campbell <[email-masked]<mailto:[email-masked]>>
Cc: PNNS <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Mike,

Yes, it is still the correct doc link. I did not have any problem opening any of the documents.

Should I send it attached to an email for you?

Best regards.

-----------------------------------------------------------------------------------------------------------------
Miguel Angel Reina Ortega – Testing Expert
Centre for Testing and Interoperability (CTI)
ETSI ● www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163104705&sdata=kcQ5Nn9pNxIC%2FF8sHhP34116CtRla%2Bq284FSBHVqvDc%3D&reserved=0> ● [email-masked]<mailto:[email-masked]>
Phone: +33 (0)4 92 94 43 49 ● Mobile: +33 (0)6 76 73 60 99

This email may contain confidential information and is intended for
the use of the addressee only. Any unauthorized use may be unlawful.
If you receive this email by mistake, please advise the sender
immediately by using the reply facility in your email software.
Thank you for your co-operation.

From: Mike Jones <[email-masked]<mailto:[email-masked]>>
Sent: 18 June 2019 12:30
To: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>; Brian Campbell <[email-masked]<mailto:[email-masked]>>
Cc: PNNS <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

I just tried opening the docs inside the .zip file https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163104705&sdata=tRgOMS%2F0SQ24UtuxD4PZO9fuYS2DZ0qKqeJHdbbPAHE%3D&reserved=0> to review the request and there were problems opening both of them.  Is this still the correct doc link?

                                           -- Mike

From: Jwt-reg-review <[email-masked]<mailto:[email-masked]>> On Behalf Of Miguel Angel Reina Ortega
Sent: Monday, June 17, 2019 6:21 AM
To: Brian Campbell <[email-masked]<mailto:[email-masked]>>
Cc: PNNS <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Brian,

I still don’t see the requested claim appearing on the registry. Is there anything that needs to be done on my side?

Thanks in advance.

Best regards.

From: Miguel Angel Reina Ortega
Sent: 06 June 2019 11:59
To: Brian Campbell <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; PNNS <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Brian,

Thanks for the comments. The “scope” claim will be removed from there.

On the other hand, I don’t see any of those links you mention, just the following: http://openid.net/specs/openid-connect-core-1_0.html#IDToken<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23IDToken&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163114701&sdata=G1SHeIkW2QzRPG4gyWhNNMW15vrb1VC0533fT0AVQ5k%3D&reserved=0>. which seems correct to me.

Best regards.

From: Brian Campbell <[email-masked]<mailto:[email-masked]>>
Sent: 29 May 2019 19:02
To: Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; PNNS <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Jwt-reg-review] Request to register claim: "at_use_nbr"

In general I think that the “at_use_nbr” claim can be registered given how it is described in the NFV_SEC022v0-1-0-cb.docx file inside the zip file at the https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163114701&sdata=QYgBmqU5nYE9URouJxpKhBulAy%2B0hOUUDOgryQCO0V8%3D&reserved=0> link provided.

However, there are also links there to https://openid.net/specs/openid-connect-core-1_0.html#StandardClaims<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163124693&sdata=bkLUsWbrPqh7Ua6zzXG%2BJpiT946oZIgP8pvWGiAIHmY%3D&reserved=0> and https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163124693&sdata=%2F9ae3ZOXG0CVxP6ziIneKWDanYrPiDNYjcUnzVfSstI%3D&reserved=0> which are confusing and/or don't seem right.

Also the NFV_SEC022v0-1-0-cb.docx document also still has "scope" in the JSON Web Token Claims registry which needs to be removed. Because ultimately I think IANA works off of the specification document itself.

On Sun, May 26, 2019 at 9:36 PM Miguel Angel Reina Ortega <[email-masked]<mailto:[email-masked]>> wrote:
Dear,
On behalf of ETSI NFV ISG, I would like to submit the following registration request for the “JSON Web Token” registry:

  *   Claim Name: “at_use_nbr”
  *   Claim Description: Number of API requests for which the access token can be used.
  *   Change Controller: ETSI ([email-masked]<mailto:[email-masked]>)
  *   Specification Document(s): Clause 5.5<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163134687&sdata=ULwF4H6TeAtTCuAj%2Br6n9D0eorzTyRgTa50GHNAPZxs%3D&reserved=0> of the present ETSI GS NFV-SEC 022<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163134687&sdata=1QU0NOBbhwwn%2BJSCofs4uNCcHpIVr0bj0Dh1y7lpJLM%3D&reserved=0> (https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163144683&sdata=slUSoTnNlxy6IvkHqImGws47%2FR%2BYSXiuNHrS2h3K%2BkA%3D&reserved=0>)
Please, note that once the specification is approved, the pointer to the specification will be updated.

Best regards.

-----------------------------------------------------------------------------------------------------------------
Miguel Angel Reina Ortega – Testing Expert
Centre for Testing and Interoperability (CTI)
ETSI ● www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163144683&sdata=L%2FD%2BO3hdKcggGr32EFiewT9ZXa9I2XgKVn4ZtK8njo8%3D&reserved=0> ● [email-masked]<mailto:[email-masked]>
Phone: +33 (0)4 92 94 43 49 ● Mobile: +33 (0)6 76 73 60 99

This email may contain confidential information and is intended for
the use of the addressee only. Any unauthorized use may be unlawful.
If you receive this email by mistake, please advise the sender
immediately by using the reply facility in your email software.
Thank you for your co-operation.

_______________________________________________
Jwt-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jwt-reg-review<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjwt-reg-review&data=02%7C01%7CMichael.Jones%40microsoft.com%7C03430a778f844150de8508d6f3e39738%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964556163154673&sdata=5fKpMwKMDx5lKy60oPas9%2Fyk6s2c0gcMeb7osyEV%2BoA%3D&reserved=0>

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited.  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

---

From: Mike Jones <[email-masked]>
Date: Thu, 25 Jul 2019 21:12:07 +0000

I approve of registration of the "at_use_nbr" JWT claim at https://www.iana.org/assignments/jwt/jwt.xhtml#claims.  (Ideally, this should wait until an updated draft has been sent to us that no longer attempts to register the "scope" claim, which has now been registered by https://tools.ietf.org/html/draft-ietf-oauth-token-exchange-19.)

                                                       -- Mike

From: Miguel Angel Reina Ortega <[email-masked]>
Sent: Tuesday, June 18, 2019 10:49 AM
To: Mike Jones <[email-masked]>; Brian Campbell <[email-masked]>
Cc: PNNS <[email-masked]>; [email-masked]
Subject: RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Dear Mike,

I hope that’s still ok.

Best regards.

ETSI ● www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252284876&sdata=KAuf8TA4v%2FLEXNmL%2F7Vchy3MlwJlFn71fr4bceE%2FMzU%3D&reserved=0> ● [email-masked]<mailto:[email-masked]>

                                                       -- Mike

Dear Mike,

Best regards.

ETSI ● www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252294873&sdata=AdcJngZ%2BW3ufPu3EWFmtrnfoO0cVYWCCFsRZgeIzqbg%3D&reserved=0> ● [email-masked]<mailto:[email-masked]>

I just tried opening the docs inside the .zip file https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252294873&sdata=nBTW5sf1ulDOrR7QlJehFk1l5t6P0OjMrBSqv75ter4%3D&reserved=0> to review the request and there were problems opening both of them.  Is this still the correct doc link?

                                           -- Mike

Dear Brian,

Thanks in advance.

Best regards.

Dear Brian,

On the other hand, I don’t see any of those links you mention, just the following: http://openid.net/specs/openid-connect-core-1_0.html#IDToken<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23IDToken&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252304870&sdata=cPVHeLCY%2B9b1RECwSKSJd6FxIeHOzwr%2FHTDlZ8dQ2xc%3D&reserved=0>. which seems correct to me.

Best regards.

In general I think that the “at_use_nbr” claim can be registered given how it is described in the NFV_SEC022v0-1-0-cb.docx file inside the zip file at the https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252304870&sdata=h%2BbV4TOGWI7OclnjcoVfhxDohoCDS2ZMmP4WkhbPEd8%3D&reserved=0> link provided.

However, there are also links there to https://openid.net/specs/openid-connect-core-1_0.html#StandardClaims<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252314858&sdata=L1aJTNTynU7sITK1GIYZ6T3TGe%2BE%2FAhfKweE8wmXP54%3D&reserved=0> and https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252314858&sdata=OXRk3QxdH%2BaevjV9UqRhO667tzXkCbTBISdhFvMigAc%3D&reserved=0> which are confusing and/or don't seem right.

  *   Specification Document(s): Clause 5.5<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-connect-core-1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252324855&sdata=y%2B5vLXGsFEb7ZvAyWM8F%2BjEHhvDSP6Vk7%2F5TDFLk0wM%3D&reserved=0> of the present ETSI GS NFV-SEC 022<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252324855&sdata=%2BbJya6z9mpjCsFj%2BsOS8Yr6I1LuNK%2BTAHP3jlzag%2FCw%3D&reserved=0> (https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252334848&sdata=Hz8Ruq6%2F80zPTVUZ5Utfl%2FVT6iM0b5tXRra0U1B8Rm0%3D&reserved=0>)

Best regards.

ETSI ● www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252334848&sdata=Tm4r7phfca0Zn50tykuYD%2FgwFg4z5mTFeRDQELgvNBM%3D&reserved=0> ● [email-masked]<mailto:[email-masked]>

_______________________________________________
Jwt-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jwt-reg-review<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjwt-reg-review&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252344842&sdata=Mdyegz6ObTAZWdgJjgHNzFP%2FuUc%2BO%2BoLgM06IuJO3cc%3D&reserved=0>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Mon, 29 Jul 2019 16:32:28 +0000

Hi Mike, all,

Can we register the "at_use_nbr" JWT claim now or should we wait until the document has been updated?  

Thanks,

Sabrina Tanamal
Senior IANA Services Specialist

On Thu Jul 25 21:12:50 2019, [email-masked] wrote:
> I approve of registration of the "at_use_nbr" JWT claim at
> https://www.iana.org/assignments/jwt/jwt.xhtml#claims.  (Ideally, this
> should wait until an updated draft has been sent to us that no longer
> attempts to register the "scope" claim, which has now been registered
> by https://tools.ietf.org/html/draft-ietf-oauth-token-exchange-19.)
> 
> -- Mike
> 
> Then, that’s the right link to use until it gets published. And it
> will be published once different claims are registered. So, discussing
> with Brian, it was agreed to use that temporary link so that you can
> review the specification (which actually is on hold before publication
> until claims are registered) and then update the registry with the
> final link.
> 
> I hope that’s still ok.
> 
> Best regards.
> 
> ETSI ●
> www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252284876&sdata=KAuf8TA4v%2FLEXNmL%2F7Vchy3MlwJlFn71fr4bceE%2FMzU%3D&reserved=0>
> ●
> [email-masked]<mailto:[email-masked]>
> From: Mike Jones
> <[email-masked]<mailto:[email-masked]>>
> Sent: 18 June 2019 15:13
> To: Miguel Angel Reina Ortega
> <[email-masked]<mailto:[email-masked]>>;
> Brian Campbell
> <[email-masked]<mailto:[email-masked]>>
> Cc: PNNS <[email-masked]<mailto:[email-masked]>>; jwt-reg-
> [email-masked]<mailto:[email-masked]>
> Rather than sending it to me, it would be better to place the
> normative doc at a permanent URL from which it can be directly opened.
> The IANA registration will need to refer to this URL anyway.  Any of
> docx, pdf, or txt formats should be fine.
> 
> -- Mike
> 
> <[email-masked]<mailto:[email-masked]>>
> To: Mike Jones
> <[email-masked]<mailto:[email-masked]>>;
> Brian Campbell
> <[email-masked]<mailto:[email-masked]>>
> Cc: PNNS <[email-masked]<mailto:[email-masked]>>; jwt-reg-
> [email-masked]<mailto:[email-masked]>
> ETSI ●
> www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252294873&sdata=AdcJngZ%2BW3ufPu3EWFmtrnfoO0cVYWCCFsRZgeIzqbg%3D&reserved=0>
> ●
> [email-masked]<mailto:[email-masked]>
> From: Mike Jones
> <[email-masked]<mailto:[email-masked]>>
> Sent: 18 June 2019 12:30
> To: Miguel Angel Reina Ortega
> <[email-masked]<mailto:[email-masked]>>;
> Brian Campbell
> <[email-masked]<mailto:[email-masked]>>
> Cc: PNNS <[email-masked]<mailto:[email-masked]>>; jwt-reg-
> [email-masked]<mailto:[email-masked]>
> I just tried opening the docs inside the .zip file
> https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-
> SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-
> SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252294873&sdata=nBTW5sf1ulDOrR7QlJehFk1l5t6P0OjMrBSqv75ter4%3D&reserved=0>
> to review the request and there were problems opening both of them.
> Is this still the correct doc link?
> 
> -- Mike
> 
> From: Jwt-reg-review <[email-masked]<mailto:jwt-reg-
> [email-masked]>> On Behalf Of Miguel Angel Reina Ortega
> To: Brian Campbell
> <[email-masked]<mailto:[email-masked]>>
> Cc: PNNS <[email-masked]<mailto:[email-masked]>>; jwt-reg-
> [email-masked]<mailto:[email-masked]>
> I still don’t see the requested claim appearing on the registry. Is
> there anything that needs to be done on my side?
> 
> Thanks in advance.
> 
> Best regards.
> 
> To: Brian Campbell
> <[email-masked]<mailto:[email-masked]>>
> On the other hand, I don’t see any of those links you mention, just
> the following: http://openid.net/specs/openid-connect-core-
> 1_0.html#IDToken<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-
> connect-core-
> 1_0.html%23IDToken&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252304870&sdata=cPVHeLCY%2B9b1RECwSKSJd6FxIeHOzwr%2FHTDlZ8dQ2xc%3D&reserved=0>.
> which seems correct to me.
> 
> Best regards.
> 
> From: Brian Campbell
> <[email-masked]<mailto:[email-masked]>>
> Sent: 29 May 2019 19:02
> To: Miguel Angel Reina Ortega
> <[email-masked]<mailto:[email-masked]>>
> In general I think that the “at_use_nbr” claim can be registered given
> how it is described in the NFV_SEC022v0-1-0-cb.docx file inside the
> zip file at the
> https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-
> SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-
> SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252304870&sdata=h%2BbV4TOGWI7OclnjcoVfhxDohoCDS2ZMmP4WkhbPEd8%3D&reserved=0>
> link provided.
> 
> However, there are also links there to
> https://openid.net/specs/openid-connect-core-
> 1_0.html#StandardClaims<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-
> connect-core-
> 1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252314858&sdata=L1aJTNTynU7sITK1GIYZ6T3TGe%2BE%2FAhfKweE8wmXP54%3D&reserved=0>
> and
> https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=54060<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252314858&sdata=OXRk3QxdH%2BaevjV9UqRhO667tzXkCbTBISdhFvMigAc%3D&reserved=0>
> which are confusing and/or don't seem right.
> 
> Also the NFV_SEC022v0-1-0-cb.docx document also still has "scope" in
> the JSON Web Token Claims registry which needs to be removed. Because
> ultimately I think IANA works off of the specification document
> itself.
> 
> 
> 
> On Sun, May 26, 2019 at 9:36 PM Miguel Angel Reina Ortega
> <[email-masked]<mailto:[email-masked]>>
> wrote:
> Dear,
> On behalf of ETSI NFV ISG, I would like to submit the following
> registration request for the “JSON Web Token” registry:
> 
> *   Specification Document(s): Clause
> 5.5<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-
> connect-core-
> 1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252324855&sdata=y%2B5vLXGsFEb7ZvAyWM8F%2BjEHhvDSP6Vk7%2F5TDFLk0wM%3D&reserved=0>
> of the present ETSI GS NFV-SEC
> 022<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252324855&sdata=%2BbJya6z9mpjCsFj%2BsOS8Yr6I1LuNK%2BTAHP3jlzag%2FCw%3D&reserved=0>
> (https://docbox.etsi.org/ISG/NFV/Open/Drafts/SEC022_API_Access_Token_Spec/NFV-
> SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_Spec%2FNFV-
> SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252334848&sdata=Hz8Ruq6%2F80zPTVUZ5Utfl%2FVT6iM0b5tXRra0U1B8Rm0%3D&reserved=0>)
> ETSI ●
> www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252334848&sdata=Tm4r7phfca0Zn50tykuYD%2FgwFg4z5mTFeRDQELgvNBM%3D&reserved=0>
> ●
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/jwt-reg-
> review<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjwt-
> reg-
> review&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636964661252344842&sdata=Mdyegz6ObTAZWdgJjgHNzFP%2FuUc%2BO%2BoLgM06IuJO3cc%3D&reserved=0>
> 
> CONFIDENTIALITY NOTICE: This email may contain confidential and
> privileged material for the sole use of the intended recipient(s). Any
> review, use, distribution or disclosure by others is strictly
> prohibited.  If you have received this communication in error, please
> notify the sender immediately by e-mail and delete the message and any
> file attachments from your computer. Thank you.

---

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Tue, 30 Jul 2019 08:20:06 +0000

Hi Sabrina, all, 

Please, find attached the document with the updated information as requested by Mike. 

Best regards. 

ETSI ● www.etsi.org ● [email-masked]

-----Original Message-----
From: Sabrina Tanamal via RT <[email-masked]> 
Sent: 29 July 2019 18:32
To: [email-masked]
Cc: [email-masked]; [email-masked]; Miguel Angel Reina Ortega <[email-masked]>
Subject: [IANA #1147909] RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Hi Mike, all,

Thanks,

Sabrina Tanamal

On Thu Jul 25 21:12:50 2019, [email-masked] wrote:
> ----------------------------------------------------------------------
> -------------------------------------------
> Miguel Angel Reina Ortega – Testing Expert Centre for Testing and 
> Interoperability (CTI) ETSI ● 
> www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%
> 3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7
> C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7
> C1%7C0%7C636964661252284876&sdata=KAuf8TA4v%2FLEXNmL%2F7Vchy3MlwJlFn71
> fr4bceE%2FMzU%3D&reserved=0>
> ●
> ----------------------------------------------------------------------
> -------------------------------------------
> Miguel Angel Reina Ortega – Testing Expert Centre for Testing and 
> Interoperability (CTI) ETSI ● 
> www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%
> 3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7
> C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7
> C1%7C0%7C636964661252294873&sdata=AdcJngZ%2BW3ufPu3EWFmtrnfoO0cVYWCCFs
> RZgeIzqbg%3D&reserved=0>
> ●
> SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=htt
> ps%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Ac
> cess_Token_Spec%2FNFV- 
> SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37
> f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C
> 636964661252294873&sdata=nBTW5sf1ulDOrR7QlJehFk1l5t6P0OjMrBSqv75ter4%3
> D&reserved=0> to review the request and there were problems opening 
> both of them.
> SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=htt
> ps%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Ac
> cess_Token_Spec%2FNFV- 
> SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37
> f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C
> 636964661252304870&sdata=h%2BbV4TOGWI7OclnjcoVfhxDohoCDS2ZMmP4WkhbPEd8
> %3D&reserved=0>
> link provided.
> 
> 1_0.html#StandardClaims<https://nam06.safelinks.protection.outlook.com
> /?url=https%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-
> connect-core-
> 1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com
> %7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47
> %7C1%7C0%7C636964661252314858&sdata=L1aJTNTynU7sITK1GIYZ6T3TGe%2BE%2FA
> hfKweE8wmXP54%3D&reserved=0>
> and
> https://portal.etsi.org/webapp/WorkProgram/Report_WorkItem.asp?WKI_ID=
> 54060<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%
> 2Fportal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_I
> D%3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254
> cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C63696
> 4661252314858&sdata=OXRk3QxdH%2BaevjV9UqRhO667tzXkCbTBISdhFvMigAc%3D&r
> eserved=0> which are confusing and/or don't seem right.
> 
> 1_0.html%23StandardClaims&data=02%7C01%7CMichael.Jones%40microsoft.com
> %7C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47
> %7C1%7C0%7C636964661252324855&sdata=y%2B5vLXGsFEb7ZvAyWM8F%2BjEHhvDSP6
> Vk7%2F5TDFLk0wM%3D&reserved=0>
> 022<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2F
> portal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID%
> 3D54060&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc
> 50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6369646
> 61252324855&sdata=%2BbJya6z9mpjCsFj%2BsOS8Yr6I1LuNK%2BTAHP3jlzag%2FCw%
> 3D&reserved=0>
> SEC022v010.zip<https://nam06.safelinks.protection.outlook.com/?url=htt
> ps%3A%2F%2Fdocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Ac
> cess_Token_Spec%2FNFV-
> SEC022v010.zip&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37
> f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C
> 636964661252334848&sdata=Hz8Ruq6%2F80zPTVUZ5Utfl%2FVT6iM0b5tXRra0U1B8R
> m0%3D&reserved=0>) Please, note that once the specification is 
> approved, the pointer to the specification will be updated.
> 
> Best regards.
> 
> ----------------------------------------------------------------------
> -------------------------------------------
> Miguel Angel Reina Ortega – Testing Expert Centre for Testing and 
> Interoperability (CTI) ETSI ● 
> www.etsi.org<https://nam06.safelinks.protection.outlook.com/?url=http%
> 3A%2F%2Fwww.etsi.org%2F&data=02%7C01%7CMichael.Jones%40microsoft.com%7
> C811b8f37f8254cc50b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7
> C1%7C0%7C636964661252334848&sdata=Tm4r7phfca0Zn50tykuYD%2FgwFg4z5mTFeR
> DQELgvNBM%3D&reserved=0>
> ●
> review<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F
> %2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjwt-
> reg-
> review&data=02%7C01%7CMichael.Jones%40microsoft.com%7C811b8f37f8254cc5
> 0b0c08d6f3fc0f41%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C63696466
> 1252344842&sdata=Mdyegz6ObTAZWdgJjgHNzFP%2FuUc%2BO%2BoLgM06IuJO3cc%3D&
> reserved=0>
>

---

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Wed, 31 Jul 2019 17:21:56 +0000

Hi Mike, all, 

Can you confirm that we can proceed with this registration and list this document as a reference? 

Thanks,
Sabrina

On Tue Jul 30 08:21:55 2019, [email-masked] wrote:
> Cc: [email-masked]; [email-masked]; Miguel Angel
> Reina Ortega <[email-masked]>
> > <[email-masked]<mailto:MiguelAngel.ReinaOrtega@etsi.
> > org>> ;
> > Brian Campbell
> > <[email-masked]<mailto:MiguelAngel.ReinaOrtega@etsi.
> > org>> ;
> > Brian Campbell

---

From: Mike Jones <[email-masked]>
Date: Wed, 31 Jul 2019 19:36:04 +0000

Yes - you can register "at_use_nbr" now.

				-- Mike

-----Original Message-----
From: Sabrina Tanamal via RT <[email-masked]> 
Sent: Wednesday, July 31, 2019 10:22 AM
Cc: Mike Jones <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: [IANA #1147909] RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Hi Mike, all, 

Thanks,
Sabrina

On Tue Jul 30 08:21:55 2019, [email-masked] wrote:
> https://nam06.safelinks.protection.outlook.com/?url=www.etsi.org&amp;d
> ata=02%7C01%7CMichael.Jones%40microsoft.com%7C03ce5bca82154645d27808d7
> 15db9705%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370019058599370
> 39&amp;sdata=%2B0cdNrm93wSi7uT9tZHigH3V3cpFgRCXhMrmGNHjTiM%3D&amp;rese
> rved=0 ● [email-masked]
> > https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fww
> > w.iana.org%2Fassignments%2Fjwt%2Fjwt.xhtml%23claims&amp;data=02%7C01
> > %7CMichael.Jones%40microsoft.com%7C03ce5bca82154645d27808d715db9705%
> > 7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637001905859937039&amp;
> > sdata=WaJgaeaemiF%2B%2Fz6bdnGxV6TC%2FVAZxLqjOCEIqGBGu3U%3D&amp;reser
> > ved=0.  (Ideally, this should wait until an updated draft has been 
> > sent to us that no longer attempts to register the "scope" claim, 
> > which has now been registered by 
> > https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fto
> > ols.ietf.org%2Fhtml%2Fdraft-ietf-oauth-token-exchange-19&amp;data=02
> > %7C01%7CMichael.Jones%40microsoft.com%7C03ce5bca82154645d27808d715db
> > 9705%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637001905859937039
> > &amp;sdata=qpqk6AQ7Gt8%2B0zCDICAQL%2BWDTlWSJVGrU3ZAsri8wjc%3D&amp;re
> > served=0.)
> >
> > -- Mike
> >
> > will be published once different claims are registered. So, 
> > discussing with Brian, it was agreed to use that temporary link so 
> > that you can review the specification (which actually is on hold 
> > before publication until claims are registered) and then update the 
> > registry with the final link.
> >
> > I hope that’s still ok.
> >
> > Best regards.
> >
> > https://nam06.safelinks.protection.outlook.com/?url=www.etsi.org&amp
> > ;data=02%7C01%7CMichael.Jones%40microsoft.com%7C03ce5bca82154645d278
> > 08d715db9705%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370019058
> > 59937039&amp;sdata=%2B0cdNrm93wSi7uT9tZHigH3V3cpFgRCXhMrmGNHjTiM%3D&
> > amp;reserved=0<http%
> > [email-masked]<mailto:miguelangel.reinaortega@etsi
> > .o
> > rg>
> > org>>
> > https://nam06.safelinks.protection.outlook.com/?url=www.etsi.org&amp
> > ;data=02%7C01%7CMichael.Jones%40microsoft.com%7C03ce5bca82154645d278
> > 08d715db9705%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370019058
> > 59937039&amp;sdata=%2B0cdNrm93wSi7uT9tZHigH3V3cpFgRCXhMrmGNHjTiM%3D&
> > amp;reserved=0<http%
> > [email-masked]<mailto:miguelangel.reinaortega@etsi
> > .o
> > rg>
> > https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdo
> > cbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_
> > Sp&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C03ce5bca821546
> > 45d27808d715db9705%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370
> > 01905859937039&amp;sdata=8GXMkydONn0cEqmnWzNo%2F8PYz3qwEmBK%2FVjY7T0
> > s%2FFc%3D&amp;reserved=0
> > ec/NFV-
> > SEC022v010.zip<htt
> > 636964661252294873&sdata=nBTW5sf1ulDOrR7QlJehFk1l5t6P0OjMrBSqv75ter4
> > %3  D&reserved=0> to review the request and there were problems 
> > opening both of them.
> > From: Jwt-reg-review 
> > <[email-masked]<mailto:jwt-reg-
> > the following: 
> > https://nam06.safelinks.protection.outlook.com/?url=http%3A%2F%2Fope
> > nid.net%2Fspecs%2Fopenid-connect-core-&amp;data=02%7C01%7CMichael.Jo
> > nes%40microsoft.com%7C03ce5bca82154645d27808d715db9705%7C72f988bf86f
> > 141af91ab2d7cd011db47%7C1%7C0%7C637001905859937039&amp;sdata=5Ff2qcE
> > LsvtCpAqvv8narSxoFX6gNynkrTORum%2FJqsk%3D&amp;reserved=0
> > 1_0.html#IDToken<h
> > ttp%3A%2F%2Fopenid.net%2Fspecs%2Fopenid-
> > connect-core-
> > org>>
> > In general I think that the “at_use_nbr” claim can be registered 
> > given how it is described in the NFV_SEC022v0-1-0-cb.docx file 
> > inside the zip file at the
> > https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdo
> > cbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token_
> > Sp&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C03ce5bca821546
> > 45d27808d715db9705%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370
> > 01905859947034&amp;sdata=Pq4UB9ge7njY4S6Bf%2FHHbb8fIhCQPc0JfX3jqgRhm
> > tQ%3D&amp;reserved=0
> > ec/NFV-
> > SEC022v010.zip<htt
> > https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fop
> > enid.net%2Fspecs%2Fopenid-connect-core-&amp;data=02%7C01%7CMichael.J
> > ones%40microsoft.com%7C03ce5bca82154645d27808d715db9705%7C72f988bf86
> > f141af91ab2d7cd011db47%7C1%7C0%7C637001905859947034&amp;sdata=M0zRpF
> > zFgM8EnQuyoABtdckcDh%2B5IL0QJXauHSoA07k%3D&amp;reserved=0
> > https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fpo
> > rtal.etsi.org%2Fwebapp%2FWorkProgram%2FReport_WorkItem.asp%3FWKI_ID&
> > amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C03ce5bca82154645d
> > 27808d715db9705%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370019
> > 05859947034&amp;sdata=5a4ItLjnDwXrxjrRUtWQACELH7WbVY5D4iyxW%2Fik7Ks%
> > 3D&amp;reserved=0=
> > 54060<https:/%
> > 4661252314858&sdata=OXRk3QxdH%2BaevjV9UqRhO667tzXkCbTBISdhFvMigAc%3D
> > &r eserved=0> which are confusing and/or don't seem right.
> >
> > the JSON Web Token Claims registry which needs to be removed. 
> > Because ultimately I think IANA works off of the specification 
> > document itself.
> >
> >
> >
> > org>>
> > 5.5<https://
> > openid.net%2Fspecs%2Fopenid-
> > connect-core-
> > 022<https://
> > (https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fd
> > ocbox.etsi.org%2FISG%2FNFV%2FOpen%2FDrafts%2FSEC022_API_Access_Token
> > _S&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7C03ce5bca821546
> > 45d27808d715db9705%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370
> > 01905859947034&amp;sdata=0Z9Er4JAhHq4axkeXIm5MNsI9lhxdvieeAoE%2BheWo
> > K0%3D&amp;reserved=0
> > pec/NFV-
> > SEC022v010.zip<htt
> > https://nam06.safelinks.protection.outlook.com/?url=www.etsi.org&amp
> > ;data=02%7C01%7CMichael.Jones%40microsoft.com%7C03ce5bca82154645d278
> > 08d715db9705%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370019058
> > 59947034&amp;sdata=nedUcqbW%2FPSMmLctEfvIbKHaRuD6uatprK4gxMvwXbg%3D&
> > amp;reserved=0<http%
> > [email-masked]<mailto:miguelangel.reinaortega@etsi
> > .o
> > rg>
> > https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fww
> > w.ietf.org%2Fmailman%2Flistinfo%2Fjwt-reg-&amp;data=02%7C01%7CMichae
> > l.Jones%40microsoft.com%7C03ce5bca82154645d27808d715db9705%7C72f988b
> > f86f141af91ab2d7cd011db47%7C1%7C0%7C637001905859947034&amp;sdata=D%2
> > Fs2RzSYARgpbhe7hqQV%2FnLVVZ9hvob6NLDsujtOSYU%3D&amp;reserved=0
> > review<https:/
> > prohibited.  If you have received this communication in error, 
> > please notify the sender immediately by e-mail and delete the 
> > message and any file attachments from your computer. Thank you.
>

---

From: Mike Jones <[email-masked]>
Date: Wed, 31 Jul 2019 19:55:57 +0000

Actually, I take that back.  Please wait to register this value and reference the document until all the IANA actions requested by the document provided are consistent.  The document provided does not yet address the issue discussed in IANA #1146172 - that the needed nfv_token_encryption_enc_values_supported value is not yet defined.

				Thanks again,
				-- Mike

-----Original Message-----
From: Jwt-reg-review <[email-masked]> On Behalf Of Mike Jones
Sent: Wednesday, July 31, 2019 12:36 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Jwt-reg-review] [IANA #1147909] RE: Request to register claim: "at_use_nbr"

				-- Mike

-----Original Message-----
From: Sabrina Tanamal via RT <[email-masked]>
Sent: Wednesday, July 31, 2019 10:22 AM
Cc: Mike Jones <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: [IANA #1147909] RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Hi Mike, all, 

Thanks,
Sabrina

On Tue Jul 30 08:21:55 2019, [email-masked] wrote:
> Interoperability (CTI) ETSI ● www.etsi.org
> > https://ww
> > which has now been registered by https://to
> > Interoperability (CTI) ETSI ● www.etsi.org
> > Interoperability (CTI) ETSI ● www.etsi.org
> > I just tried opening the docs inside the .zip file https://do 
> > http://ope
> > inside the zip file at the https://do 
> > However, there are also links there to https://op 
> > 1_0.html#StandardClaims<https://nam06.safelinks.protection.outlook.c
> > om/?url=https%3A%2F%2Fnam06.safelinks.protection.outlook.c&amp;data=
> > 02%7C01%7CMichael.Jones%40microsoft.com%7Ca1b2a4c6acf043185d9f08d715
> > ee5ac5%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C6370019857972991
> > 91&amp;sdata=LaFhyQadqmdEBuPLIvuhVJwqK2Wriw%2FqxQFXG4Ovic4%3D&amp;re
> > served=0
> > om
> > https://po
> > (https://d
> > Interoperability (CTI) ETSI ● www.etsi.org
> > https://ww

_______________________________________________
Jwt-reg-review mailing list
[email-masked]
https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjwt-reg-review&amp;data=02%7C01%7CMichael.Jones%40microsoft.com%7Ca1b2a4c6acf043185d9f08d715ee5ac5%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637001985797299191&amp;sdata=u34t%2BO8%2F7VwUzo6sx97upBZBPZCOLd5wfGhUezyWdoo%3D&amp;reserved=0

---

From: Miguel Angel Reina Ortega <[email-masked]>
Date: Wed, 31 Jul 2019 20:27:51 +0000

Hi Mike, 

I would like to kindly ask you to separate these two registration requests and thus to accept this one as this one is already well defined in the provided document. 

The request IANA #1146172 is being handled by some ETSI members and I will get back to you with an answer soon. 

I hope this is ok with you. 

@Sabrina, as we agreed, once the document is published I will provide you with a permanent link to update the corresponding registered claims. 

Best regards.

-----Original Message-----
From: Mike Jones <[email-masked]> 
Sent: 31 July 2019 21:56
To: [email-masked]
Cc: Miguel Angel Reina Ortega <[email-masked]>; [email-masked]; [email-masked]; [email-masked] <[email-masked]>
Subject: RE: [Jwt-reg-review] [IANA #1147909] RE: Request to register claim: "at_use_nbr"

				Thanks again,
				-- Mike

-----Original Message-----
From: Jwt-reg-review <[email-masked]> On Behalf Of Mike Jones
Sent: Wednesday, July 31, 2019 12:36 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Jwt-reg-review] [IANA #1147909] RE: Request to register claim: "at_use_nbr"

				-- Mike

-----Original Message-----
From: Sabrina Tanamal via RT <[email-masked]>
Sent: Wednesday, July 31, 2019 10:22 AM
Cc: Mike Jones <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: [IANA #1147909] RE: [Jwt-reg-review] Request to register claim: "at_use_nbr"

Hi Mike, all, 

Thanks,
Sabrina