Subject: Re: [Jwt-reg-review] JWT claim registration review request: draft-ietf-stir-passport-divert-05

From: Brian Campbell <[email-masked]>
Date: Tue, 3 Dec 2019 15:33:49 -0700

The good folks at IANA recently reminded the DEs that this request hadn't
been responded to. I'm not sure how that happened but apologies for the
oversight.

In general I think these registrations are okay but there are a few things
that could be tightened up or clarified. And a couple minor things I
happened to notice while reading the draft to try and evaluate the
registration request.

Sec 6
https://tools.ietf.org/html/draft-ietf-stir-passport-divert-07#section-6 :
I think it'd be helpful if there was an explanation of what "opt" stood for
or why those three letters were chosen. Is it original passport token
maybe? That was my best guess.

I don't believe the text '"opt" MUST contain a quoted base64 encoded
full-form PASSporT...' is quite right and I think it could potentially be
misinterpreted in different ways (like it sorta suggests that the JWT is
again base64 encoded). From looking at the example and other content my
guess is that it should say something more like, 'The value of the "opt"
claim is a JSON string containing a full-form PASSporT...'.

typo "identifiier" in sec 3
https://tools.ietf.org/html/draft-ietf-stir-passport-divert-07#section-3

The  claims set example in sec 5
https://tools.ietf.org/html/draft-ietf-stir-passport-divert-07#section-5
has one too many closing "}" so isn't valid JSON.

On Fri, Apr 12, 2019 at 1:08 PM Robert Sparks <[email-masked]> wrote:

> Please review the JWT claim registration requests in sections 10.1 and
> 10.2 of
>
> <https://datatracker.ietf.org/doc/draft-ietf-stir-passport-divert>
>
> Robert Sparks - STIR WG co-chair
>
> _______________________________________________
> Jwt-reg-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jwt-reg-review
>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Mike Jones <[email-masked]>
Date: Wed, 4 Dec 2019 00:29:50 +0000

I agree that these issues should be addressed before the registrations are made.

                                                                -- Mike

From: Jwt-reg-review <[email-masked]> On Behalf Of Brian Campbell
Sent: Tuesday, December 3, 2019 2:34 PM
To: Robert Sparks <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [EXTERNAL] Re: [Jwt-reg-review] JWT claim registration review request: draft-ietf-stir-passport-divert-05

The good folks at IANA recently reminded the DEs that this request hadn't been responded to. I'm not sure how that happened but apologies for the oversight.

In general I think these registrations are okay but there are a few things that could be tightened up or clarified. And a couple minor things I happened to notice while reading the draft to try and evaluate the registration request.

Sec 6 https://tools.ietf.org/html/draft-ietf-stir-passport-divert-07#section-6<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-stir-passport-divert-07%23section-6&data=02%7C01%7CMichael.Jones%40microsoft.com%7Cc0eacfee74dd4b8f6ff008d77840f233%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637110092653793369&sdata=bdek%2B0XgqBvWFaaudamqOomTluwY6kZcJVuzs4pLZyI%3D&reserved=0> :
I think it'd be helpful if there was an explanation of what "opt" stood for or why those three letters were chosen. Is it original passport token maybe? That was my best guess.

I don't believe the text '"opt" MUST contain a quoted base64 encoded full-form PASSporT...' is quite right and I think it could potentially be misinterpreted in different ways (like it sorta suggests that the JWT is again base64 encoded). From looking at the example and other content my guess is that it should say something more like, 'The value of the "opt" claim is a JSON string containing a full-form PASSporT...'.

typo "identifiier" in sec 3 https://tools.ietf.org/html/draft-ietf-stir-passport-divert-07#section-3<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-stir-passport-divert-07%23section-3&data=02%7C01%7CMichael.Jones%40microsoft.com%7Cc0eacfee74dd4b8f6ff008d77840f233%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637110092653798362&sdata=Qntcs7mfLuzNrGeaHsZTW6XpAsgylYuVwWDWRrQBb7s%3D&reserved=0>

The  claims set example in sec 5 https://tools.ietf.org/html/draft-ietf-stir-passport-divert-07#section-5<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-stir-passport-divert-07%23section-5&data=02%7C01%7CMichael.Jones%40microsoft.com%7Cc0eacfee74dd4b8f6ff008d77840f233%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637110092653808365&sdata=r3HszWuYwfv9QSaTWZEBYmY5ZUrvw1K9BMJgFSgDeBc%3D&reserved=0> has one too many closing "}" so isn't valid JSON.

On Fri, Apr 12, 2019 at 1:08 PM Robert Sparks <[email-masked]<mailto:[email-masked]>> wrote:
Please review the JWT claim registration requests in sections 10.1 and
10.2 of

<https://datatracker.ietf.org/doc/draft-ietf-stir-passport-divert<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-stir-passport-divert&data=02%7C01%7CMichael.Jones%40microsoft.com%7Cc0eacfee74dd4b8f6ff008d77840f233%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637110092653813362&sdata=JZ5u5C%2FOR%2BKfnPDXcuSLtRzsNc7703NoPoPaIkuMtZw%3D&reserved=0>>

_______________________________________________
Jwt-reg-review mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jwt-reg-review<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjwt-reg-review&data=02%7C01%7CMichael.Jones%40microsoft.com%7Cc0eacfee74dd4b8f6ff008d77840f233%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637110092653818358&sdata=3AoMXxdSwDRKxTEffUgU00P%2BzUYZ4IdF95Xr7a2L4ls%3D&reserved=0>

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited..  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.