Subject: [karp] possible agenda item: starting proto design teams

From: Gregory Lebovitz <[email-masked]>
Date: Mon, 22 Mar 2010 10:46:59 -0700

KARPies,
Currently the KARP WG agenda for Tue morning covers three things, the review
of each of the "guidance" documents, -design-guide, framework, and
threats-reqs. While these are all good and important in governing the work,
the real work of the WG is to actually review and update the routing
protocols' auth mechanisms themselves. To that end, should we have some
discussion in the WG about spinning up design teams for at least one or two
of the routing protocol(s) (families)? Sure, the governing documents aren't
finalized yet, but they are 80% (in some cases far more) core content
complete, and certainly we could get going on at least forming the design
teams for a few protocols (or proto families), no?

Gregory

-- 
----
IETF related email from
Gregory M. Lebovitz
Juniper Networks

---

From: Vishwas Manral <[email-masked]>
Date: Mon, 22 Mar 2010 11:18:28 -0700

Hi Greg,

I agree we can figure out what more needs to be done to the
authentication mechanisms.

In my view the first step would be to define gaps in the current way
things are done. We can then look at how the gaps need to be filled.
In that respect we have:

http://tools.ietf.org/html/draft-ietf-opsec-routing-protocols-crypto-issues-03

The draft (with the IESG) already mentions the gaps in protocols and
there has been work done to fill in the gaps. It would be great to see
any new gaps identified and then work on what needs to be done in the
protocols.

I agree however that protocols like PCE/ LMP have not yet been identified.

Thanks,
Vishwas

---

From: Gregory Lebovitz <[email-masked]>
Date: Mon, 22 Mar 2010 13:46:20 -0700

To Vishwas & Chairs -
Should we consider adding a presentation on Vishwas' document, or at least a
presentation on the section(s) that relate directly to the gaps in whatever
we want to be the first set of protocol design teams to kick-off?

Gregory.

-- 
----
IETF related email from
Gregory M. Lebovitz
Juniper Networks

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Tue, 23 Mar 2010 07:32:10 +0530

Hi Gregory,

If you look at the requirements that i had sent, you would find that most of them have been picked up based on the gaps that we found in draft-ietf-opsec-routing-protocols-crypto-issues document. As Vishwas says, there has been work done to fill some of the gaps that have been identified there, but there are still some that remain unaddressed.

We could start with fixing the issues that still remain open.

Cheers, Manav

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Gregory Lebovitz
Sent: Tuesday, March 23, 2010 2.16 AM
To: Vishwas Manral
Cc: [email-masked]
Subject: Re: [karp] possible agenda item: starting proto design teams

To Vishwas & Chairs -
Should we consider adding a presentation on Vishwas' document, or at least a presentation on the section(s) that relate directly to the gaps in whatever we want to be the first set of protocol design teams to kick-off?

Gregory.

On Mon, Mar 22, 2010 at 11:18 AM, Vishwas Manral <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

Thanks,
Vishwas

--
----
IETF related email from
Gregory M. Lebovitz
Juniper Networks