Subject: [karp] KeyStore documents contents into karp-framework?

From: Gregory Lebovitz <[email-masked]>
Date: Thu, 25 Mar 2010 13:23:13 -0700

Russ/Tim/KARPies -

I was just looking at the WG page for KARP, and realized that the key table
documents from Russ and TIm are not there, and rightly so because they are
not wg items.

I'm wondering if we should put them into the -framework document? I think a
very thorough BUT INFORMATIVE (read: NOT NORMATIVE) description about the
types of things that go into the KeyStore, and it's structure, is necessary
in the framework document. Should we consider putting the text from these
documents into the -framework document?

Gregory

-- 
----
IETF related email from
Gregory M. Lebovitz
Juniper Networks

---

From: "Polk, William T." <[email-masked]>
Date: Thu, 25 Mar 2010 16:40:33 -0400

I would like to see the working group adopt these two documents as standalones, but that is of course up to the wg.

Tim

On 3/25/10 1:23 PM, "Gregory M. Lebovitz" <[email-masked]> wrote:

Russ/Tim/KARPies -

I was just looking at the WG page for KARP, and realized that the key table documents from Russ and TIm are not there, and rightly so because they are not wg items.

I'm wondering if we should put them into the -framework document? I think a very thorough BUT INFORMATIVE (read: NOT NORMATIVE) description about the types of things that go into the KeyStore, and it's structure, is necessary in the framework document. Should we consider putting the text from these documents into the -framework document?

Gregory

---

From: Gregory Lebovitz <[email-masked]>
Date: Thu, 25 Mar 2010 14:39:16 -0700

On Thu, Mar 25, 2010 at 1:40 PM, Polk, William T. <[email-masked]>wrote:

>  I would like to see the working group adopt these two documents as
> standalones,
>

Well, if we did, then at least people looking at the WG page would see them
as part of the solution space. That's a step in the right direction. We
could decide later if we wanted their text integrated for read-ability. For
now, we could work on them separately, and reference.

Gregory.

> but that is of course up to the wg.
>
> Tim
>
>

-- 
----
IETF related email from
Gregory M. Lebovitz
Juniper Networks

---

From: Bill Atwood <[email-masked]>
Date: Thu, 25 Mar 2010 17:57:47 -0400

I support the idea of adopting the two documents as WG documents.

Since I (from my admittedly limited perspective) see the keystore as
being something that can be implemented in a variety of ways, I suspect
that the framework document will eventually say something such as:

"The KeyStore implementation is independent of this document; for a
possible description of how it could be done, see [draft-polk] and
[draft-housley]."

Or words to that effect :-)

  Bill

Gregory Lebovitz wrote:
>
>
> On Thu, Mar 25, 2010 at 1:40 PM, Polk, William T.
> <[email-masked] <mailto:[email-masked]>> wrote:
>
> Well, if we did, then at least people looking at the WG page would see
> them as part of the solution space. That's a step in the right
> direction. We could decide later if we wanted their text integrated
> for read-ability. For now, we could work on them separately, and
> reference.
>
> Gregory.
>
>  
>
>     On 3/25/10 1:23 PM, "Gregory M. Lebovitz" <[email-masked]
>     <http://[email-masked]>> wrote:
>
>         Russ/Tim/KARPies -
>
>         I was just looking at the WG page for KARP, and realized that
>         the key table documents from Russ and TIm are not there, and
>         rightly so because they are not wg items. 
>
>         I'm wondering if we should put them into the -framework
>         document? I think a very thorough BUT INFORMATIVE (read: NOT
>         NORMATIVE) description about the types of things that go into
>         the KeyStore, and it's structure, is necessary in the
>         framework document. Should we consider putting the text from
>         these documents into the -framework document?
>
>         Gregory
>
>
>
>
> -- 
> ----
> IETF related email from
> Gregory M. Lebovitz
> Juniper Networks
> ------------------------------------------------------------------------
>
> _______________________________________________
> karp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/karp
>   

-- 

Dr. J.W. Atwood, Eng.             tel:   +1 (514) 848-2424 x3046
Distinguished Professor Emeritus  fax:   +1 (514) 848-2830
Department of Computer Science
   and Software Engineering
Concordia University EV 3.185     email: [email-masked]
1455 de Maisonneuve Blvd. West    http: //users.encs.concordia.ca/~bill
Montreal, Quebec Canada H3G 1M8

---

From: Vishwas Manral <[email-masked]>
Date: Thu, 25 Mar 2010 15:37:46 -0700

Hi Greg,

I agree the draft seem to hold good value.

In my view we should first try to spin a version of the draft based on
the comments received on the list and elsewhere.

If we want we could still add the drafts to show on the working group
pages so people can look at it. One more thing I have in mind is that
we need to probably have some converging document between the drafts
and the way routing protocols currently use Keys (Key chains etc).

Thanks,
Vishwas

On Thu, Mar 25, 2010 at 2:39 PM, Gregory Lebovitz
<[email-masked]> wrote:
>> I was just looking at the WG page for KARP, and realized that the key
>> table documents from Russ and TIm are not there, and rightly so because they
>> are not wg items.
>>
>> I'm wondering if we should put them into the -framework document? I think
>> a very thorough BUT INFORMATIVE (read: NOT NORMATIVE) description about the

---

From: Russ Housley <[email-masked]>
Date: Thu, 25 Mar 2010 18:36:03 -0400

I'm fine to proceed in either manner.  If the KARP WG wants them to be
part of the WG effort, that is fine with me.  I'm not going to be upset
if the KARP WG would prefer for them to be individual documents.

Russ

On 3/25/2010 4:23 PM, Gregory Lebovitz wrote:
> table documents from Russ and TIm are not there, and rightly so because
> they are not wg items. 
> 
> I'm wondering if we should put them into the -framework document? I
> think a very thorough BUT INFORMATIVE (read: NOT NORMATIVE) description
> about the types of things that go into the KeyStore, and it's structure,
> is necessary in the framework document. Should we consider putting the
> text from these documents into the -framework document?
> 
> Gregory
> 
> -- 
> ----
> IETF related email from
> Gregory M. Lebovitz
> Juniper Networks