Subject: Re: [karp] I-D Action: draft-ietf-karp-routing-tcp-analysis-00.txt

From: Joe Touch <[email-masked]>
Date: Tue, 05 Jul 2011 10:41:56 -0700

FWIW, this doc needs a bit of revision around the TCP MD5 vs. TCP-AO 
issue, at least.

It's simply deficient throughout on this issue, as well as on the 
details of TCP-AO (e.g., connectionless resets, key rollover, and even 
the fact that AO doesn't use per-session manual keys).

I look forward to a revision that addresses this, as well as more 
general interactions between transport protocols and routing protocols 
in this doc.

Joe

On 6/27/2011 11:16 PM, [email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Keying and Authentication for Routing Protocols Working Group of the IETF.
>
> 	Title           : Analysis of BGP, LDP, PCEP, and MSDP Security According to KARP Design Guide
> 	Author(s)       : Mahesh Jethanandani
>                            Keyur Patel
>                            Lianshu Zheng
> 	Filename        : draft-ietf-karp-routing-tcp-analysis-00.txt
> 	Pages           : 16
> 	Date            : 2011-06-27
>
>     This document analyzes BGP, LDP, PCEP and MSDP according to
>     guidelines set forth in section 4.2 of
>     [draft-ietf-karp-design-guide].
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-karp-routing-tcp-analysis-00.txt
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-ietf-karp-routing-tcp-analysis-00.txt
> _______________________________________________
> karp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/karp

---

From: "Anantha Ramaiah (ananth)" <[email-masked]>
Date: Tue, 5 Jul 2011 12:02:06 -0700

Hi Joe,

<removed internet-drafts and id-announce mailing lists as I don't want
to clutter in-boxes of many users who may not be interested in this
topic]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Joe Touch
> Sent: Tuesday, July 05, 2011 10:42 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [karp] I-D Action: draft-ietf-karp-routing-tcp-analysis-
> 00.txt
> 

I agree that there would be some scope for some making some elaborate
descriptions on each of the above items and spelling out the issues.

> general interactions between transport protocols and routing protocols

Can you paraphrase a bit on what you mean by "general interactions"? For
instance : API's, event's, state machine changes can all be construed as
"interactions" (direct or in-direct) which I think is out of place for
this document.

-Anantha
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Keying and
Authentication
> for Routing Protocols Working Group of the IETF.
> >

---

From: Joe Touch <[email-masked]>
Date: Tue, 05 Jul 2011 13:04:36 -0700

> "interactions" (direct or in-direct) which I think is out of place for

Some routing protocols expect connections to be protected (i.e., they do 
something when a connection goes down, more than either reestablish the 
connection or ignore it).

Joe