Subject: [karp] draft-ietf-karp-bfd-analysis-00 comments

From: Jeffrey Haas <[email-masked]>
Date: Wed, 8 May 2013 13:54:10 -0400

I've just read the current version of draft-ietf-karp-bfd-analysis.  I have
one comment and one question:

The draft correctly identifies the potential security implications of
predictable BFD session discriminator values.  The following text in 
RFC 5880 attempts to cover this issue:

   bfd.LocalDiscr

      The local discriminator for this BFD session, used to uniquely
      identify it.  It MUST be unique across all BFD sessions on this
      system, and nonzero.  It SHOULD be set to a random (but still
      unique) value to improve security.  The value is otherwise outside
      the scope of this specification.

Obviously implementations may make choices that are problematic from a
replay standpoint, but I don't believe there is anything to really cover in
a new BFD document.  Do the authors believe otherwise, or is this primarily
pointing out "you know better, don't do that!"

It should also be noted that we have two I-Ds as WG documents that cover the
other issues noted in this draft: draft-ietf-bfd-hmac-sha and
draft-ietf-bfd-generic-crypto-auth.

Presuming my analysis of the above is correct (an admonition to do the right
thing), this document appears of reasonable quality.  Is there an intent to
last call it sometime soon?

-- Jeff

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Thu, 9 May 2013 00:25:31 +0000

Hi Jeff,

Your analysis is correct - the gap analysis doc in the KARP lists the gaps that exists today when using manual keying. The two IDs that you've mentioned are still WG documents, and not yet standards and have been mentioned here in the gap analysis document. Additionally, I think we should also cover any new security considerations introduced by BFD over LAGs when using manual keying. I haven't thought much over this.

Cheers, Manav

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jeffrey Haas
> Sent: Wednesday, May 08, 2013 11:24 PM
> To: [email-masked]
> Subject: [karp] draft-ietf-karp-bfd-analysis-00 comments
> 
> I've just read the current version of 
> draft-ietf-karp-bfd-analysis.  I have one comment and one question:
> 
> The draft correctly identifies the potential security 
> implications of predictable BFD session discriminator values. 
>  The following text in RFC 5880 attempts to cover this issue:
> 
> 
>    bfd.LocalDiscr
> 
> _______________________________________________
> karp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/karp
>

---

From: Jeffrey Haas <[email-masked]>
Date: Fri, 10 May 2013 12:24:11 -0400

Manav,

On Thu, May 09, 2013 at 12:25:31AM +0000, Bhatia, Manav (Manav) wrote:
> Additionally, I think we should also cover any new security considerations
> introduced by BFD over LAGs when using manual keying. I haven't thought
> much over this.

Given that the use case for BFD over LAG is directly connected links without
even an underyling switch, I suspect the existing single-hop analysis is
probably applicable. 

-- Jeff