Subject: [karp] Time to wind up KARP

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 May 2014 08:26:19 +0100

Hi KARP working group,

With RFC 7210 now published and draft-ietf-karp-ops-model having completed
Auth48, the WG can justifiably claim to have delivered on significant parts of
the charter.

The "next big thing" for the working group has been constant for a long time:
AKM. However, as you know, there has been no movement on this despite a couple
of I-Ds on the topic. In London there was a suggestion that there might be a
"management plane" solution to AKM spanning multiple routing protocols, but when
squeezed, there were not many people offering to do work on this, and no I-Ds or
even emails have popped out in the 8 weeks since then.

The WG also has just two more drafts in hand.
 - draft-ietf-karp-isis-analysis is pretty close to cooked
 - draft-ietf-karp-bfd-analysis has expired, but is also close to cooked.

Of course, there are a number of active individual drafts in the pipe as well.

After discussion with the chairs and with Alia, and unless persuaded otherwise,
I will close the KARP working group on 29th May.

We would handle remaining work as follows:

- There will not be a meeting in Toronto.
- The KARP mailing list will remain open as a place to contact people about
KARP-related work.
- The two remaining WG drafts will be completed as "AD Sponsored" with
cross-checks to the ISIS and BFD working groups.
- Any new protocol analysis I-Ds will be taken to the appropriate
protocol-owning working groups.
     - The work mapping TCP-AO state to key tables can move to IDR
     - A home for management of KeyTables can also be found (e.g., NETMod)
- If a group of people want to work on a management solution for AKM for routing
protocols (or for any protocol) then the OPS, SEC, and RTG ADs will find a place
for the work. (Write a draft, get some support, and talk to us.)
- If a charterable body of work comes along (such as AKM within routing
protocols) then we will charter or home the work as necessary.

Please think about this and comment to the list.

Thanks,
Adrian

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Wed, 21 May 2014 07:29:52 +0000

Hi Adrian,

draft-ietf-karp-bfd-analysis has finished the WG LC (this I think has been discussed in the BFD WG as well) and we're waiting for Brian to prepare a writeup. We can push it to the IESG as soon as the writeup is done.

Cheers, Manav

> -----Original Message-----
> From: karp [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Wednesday, May 21, 2014 12:56 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: [karp] Time to wind up KARP
> 
> Hi KARP working group,
> 
> _______________________________________________
> karp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/karp

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 21 May 2014 10:21:44 +0100

Hi,

Can you start the process by refreshing the I-D?

Thanks,
Adrian

> From: Bhatia, Manav (Manav) [mailto:[email-masked]]
> Sent: 21 May 2014 08:30
> To: [email-masked]; [email-masked]
> Subject: RE: [karp] Time to wind up KARP
> 
> Hi Adrian,
> 
> draft-ietf-karp-bfd-analysis has finished the WG LC (this I think has been
> discussed in the BFD WG as well) and we're waiting for Brian to prepare a
> writeup. We can push it to the IESG as soon as the writeup is done.
> 
> Cheers, Manav
>

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 21 May 2014 07:45:54 -0400

> draft-ietf-karp-bfd-analysis has finished the WG LC (this I think has been discussed in the BFD WG as well) and we're waiting for Brian to prepare a writeup. We can push it to the IESG as soon as t…

I also reviewed the BFD karp analysis draft and considered it of good
quality.  

-- Jeff

---

From: Sam Hartman <[email-masked]>
Date: Thu, 22 May 2014 08:52:15 -0400

Dacheng Zhang, Margaret wasserman and I are happy to work on a
management plane solution to  AKM.
We'd be happy to get a draft by the next IETF, although the first draft
probably wouldn't be complete.

Is there enough interest that this work could be reviewed if we did it?
Is it valuable enough for us to go work on an initial draft?

---

From: "Bhatia, Manav (Manav)" <[email-masked]>
Date: Fri, 23 May 2014 05:56:08 +0000

Hi Adrian,

Its done.

The new version is here:
http://www.ietf.org/internet-drafts/draft-ietf-karp-bfd-analysis-02.txt

Cheers, Manav

> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Wednesday, May 21, 2014 2:52 PM
> To: Bhatia, Manav (Manav)
> Cc: [email-masked]
> > > Auth48, the WG can justifiably claim to have delivered on
> significant
> > > parts of
> > > the charter.
> > >
> > > The "next big thing" for the working group has been constant for a
> long
> > > time:
> > > AKM. However, as you know, there has been no movement on this
> despite a
> > > couple
> > > of I-Ds on the topic. In London there was a suggestion that there
> might
> > > be a
> > > "management plane" solution to AKM spanning multiple routing
> protocols,
> > > but when
> > > squeezed, there were not many people offering to do work on this,
> and
> > > no I-Ds or
> > > Of course, there are a number of active individual drafts in the
> pipe
> > > as well.
> > >
> > > After discussion with the chairs and with Alia, and unless
> persuaded
> > > otherwise,
> > > - The KARP mailing list will remain open as a place to contact
> people
> > > about
> > > KARP-related work.
> > > - If a group of people want to work on a management solution for
> AKM
> > > for routing

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 27 May 2014 23:30:38 +0000

Dear Adrian & Alia,

Please see comments in-line [Uma]:

--
Uma C.

-----Original Message-----
From: karp [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Wednesday, May 21, 2014 12:26 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [karp] Time to wind up KARP

Hi KARP working group,

With RFC 7210 now published and draft-ietf-karp-ops-model having completed Auth48, the WG can justifiably claim to have delivered on significant parts of the charter.

The "next big thing" for the working group has been constant for a long time:
AKM. However, as you know, there has been no movement on this despite a couple of I-Ds on the topic. In London there was a suggestion that there might be a "management plane" solution to AKM spanning multiple routing protocols, but when squeezed, there were not many people offering to do work on this, and no I-Ds or even emails have popped out in the 8 weeks since then.

After discussion with the chairs and with Alia, and unless persuaded otherwise, I will close the KARP working group on 29th May.

- There will not be a meeting in Toronto.
- The KARP mailing list will remain open as a place to contact people about KARP-related work.

[Uma]: I guess, security work for relatively  new WGs in routing area (for e.g., NVO3, I2RS, SFC etc..) ought to be discussed in this mailing list.
              This will enable security experts in this group, who don't follow routing work groups regularly.
 
- The two remaining WG drafts will be completed as "AD Sponsored" with cross-checks to the ISIS and BFD working groups.

[Uma]: Thanks.  I co-author IS-IS draft and any further suggestion/action item for us in this regard will be helpful.

- Any new protocol analysis I-Ds will be taken to the appropriate protocol-owning working groups.
     - The work mapping TCP-AO state to key tables can move to IDR

[Uma]: Could you please specify which particular draft you were talking about.

[Uma]: Could you please specify which particular draft you were talking about.
I have posted a new version for this  ID, http://datatracker.ietf.org/doc/draft-chunduri-karp-kmp-router-fingerprints/   and I feel this is very useful for KMP centric solution for AKM.
If you can specify the ID you were talking about, it would be useful.

- If a group of people want to work on a management solution for AKM for routing protocols (or for any protocol) then the OPS, SEC, and RTG ADs will find a place for the work. (Write a draft, get some support, and talk to us.)
- If a charterable body of work comes along (such as AKM within routing
protocols) then we will charter or home the work as necessary.

Thanks,
Adrian