Subject: [keyassure] Hopefully finishing up the charter

From: Paul Hoffman <[email-masked]>
Date: Wed, 15 Sep 2010 17:56:00 -0700

Greetings again. I have updated the propsed charter at <http://trac.tools.ietf.org/area/sec/trac/wiki/Keyassure> to cover the two issues that were discussed earlier on the mailing list: the troublesome sentence about updating application protocols, and the lack of proposed deliverables.

The deliverables I made up for this proposal are:
Nov 2010   First WG draft of protocol for using DNS to associate hosts with keys for TLS and DTLS
Jan 2011   First WG draft of protocols for using DNS to associate hosts with non-TLS security protocols
Jun 2011   Protocol for using DNS to associate hosts with keys for TLS and DTLS to IESG
Aug 2011   Protocols for using DNS to associate hosts with non-TLS security protocols
Aug 2011   Recharter

The first one could be any of the three drafts recently discussed on the list. The second could be similar to the first, but applying to protocols such as IPsec and so on. If the WG wants, we don't actually have to have a second document; that milestone could just be part of the one main document. I put the "recharter" at the end because we might have thought of other things we want to do and can ask the IESG if we can do them as a WG.

People said that they thought that we should attempt to become a WG as soon as we can, and in order to do that, we need a defensible but not perfect charter. There will be a call for comments in the IETF for whatever charter we pass to the IESG, so changes can be made after that discussion. As long as we hit the points that are generally agreed to here, we are probably doing fine.

Thoughts?

--Paul Hoffman, Director
--VPN Consortium

---

From: "Richard L. Barnes" <[email-masked]>
Date: Wed, 15 Sep 2010 21:03:06 -0400

This is a good start.  The [D]TLS milestones look good to me.  I'm  
concerned that the other two are still too vague, the moral equivalent  
of the "update application
protocols sentence".  Would it induce too much serialism to say that  
we'll look at other protocols (== recharter) once the [D]TLS document  
is in WGLC?
--Richard

On Sep 15, 2010, at 8:56 PM, Paul Hoffman wrote:

> Greetings again. I have updated the propsed charter at <http://trac.tools.ietf.org/area/sec/trac/wiki/Keyassure 
> > to cover the two issues that were discussed earlier on the mailing  
> list: the troublesome sentence about updating application protocols,  
> and the lack of proposed deliverables.
>
> The first one could be any of the three drafts recently discussed on  
> the list. The second could be similar to the first, but applying to  
> protocols such as IPsec and so on. If the WG wants, we don't  
> actually have to have a second document; that milestone could just  
> be part of the one main document. I put the "recharter" at the end  
> because we might have thought of other things we want to do and can  
> ask the IESG if we can do them as a WG.
>
> People said that they thought that we should attempt to become a WG  
> as soon as we can, and in order to do that, we need a defensible but  
> not perfect charter. There will be a call for comments in the IETF  
> for whatever charter we pass to the IESG, so changes can be made  
> after that discussion. As long as we hit the points that are  
> generally agreed to here, we are probably doing fine.
>
> Thoughts?
>
> --Paul Hoffman, Director
> --VPN Consortium
> _______________________________________________
> keyassure mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/keyassure

---

From: Sean Turner <[email-masked]>
Date: Thu, 16 Sep 2010 09:26:49 -0400

To help the non-Security ADs can you add something like: Possible 
starting points for these deliverables include: draft a, draft b, 
draft c, etc.?  That way they won't have to dig through this very 
active mailing list.

> Jun 2011   Protocol for using DNS to associate hosts with keys for TLS and DTLS to IESG

nit: add standards-track to above and below deliverables (for clarity)

> Aug 2011   Protocols for using DNS to associate hosts with non-TLS security protocols

nit: add "to the IESG" above

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 16 Sep 2010 08:09:03 -0700

At 9:26 AM -0400 9/16/10, Sean Turner wrote:
>To help the non-Security ADs can you add something like: Possible starting points for these deliverables include: draft a, draft b, draft c, etc.?  That way they won't have to dig through this very active mailing list.

Done. FWIW, I put the list in alphabetical order.

>nit: add standards-track to above and below deliverables (for clarity)

Done.

>nit: add "to the IESG" above

Done.

--Paul Hoffman, Director
--VPN Consortium

---

From: Warren Kumari <[email-masked]>
Date: Thu, 16 Sep 2010 16:12:15 -0400

>> nit: add "to the IESG" above

Thank you Paul, Phillip, Richard, Tim, Sean and everyone else who contributed to getting this charter, etc looking good...

W