Subject: Re: [keyassure] draft-hoffman-keys-linkage-from-dns-02 security considerations

From: "Jeffrey A. Williams" <[email-masked]>
Date: Thu, 23 Sep 2010 14:29:06 -0500 (GMT-05:00)

Carl and all,

Very much agreed!

-----Original Message-----
>From: Carl Wallace <[email-masked]>
>Sent: Sep 23, 2010 1:45 PM
>To: Tony Finch <[email-masked]>, [email-masked]
>Subject: Re: [keyassure] draft-hoffman-keys-linkage-from-dns-02 security	considerations
>
>> This looks to me like a lot of words to say not very much. 
>
>Just ten additional words.  
>
>> There's no way the protocol can help a server admin protect themselves against a rogue DNS admin.
>
>The text is referring to the relying party, who can be protected against a rogue server appearing as authorized if it manages its trust anchor store well and performs path validation.  Adding something about the server admin would be good too.
>
>_______________________________________________
>keyassure mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/keyassure

Regards,
Jeffrey A. Williams
Spokesman for INEGroup LLA. - (Over 300k members/stakeholders and growing, strong!)
"Obedience of the law is the greatest freedom" -
   Abraham Lincoln

"Credit should go with the performance of duty and not with what is very
often the accident of glory" - Theodore Roosevelt

"If the probability be called P; the injury, L; and the burden, B; liability
depends upon whether B is less than L multiplied by
P: i.e., whether B is less than PL."
United States v. Carroll Towing  (159 F.2d 169 [2d Cir. 1947]
===============================================================
Updated 1/26/04
CSO/DIR. Internet Network Eng. SR. Eng. Network data security IDNS. div. of
Information Network Eng.  INEG. INC.
ABA member in good standing member ID 01257402 E-Mail [email-masked]
Phone: 214-244-4827

---

From: "Jeffrey A. Williams" <[email-masked]>
Date: Fri, 24 Sep 2010 13:35:42 -0500 (GMT-05:00)

Tony and all,

-----Original Message-----
From: Tony Finch
Sent: Sep 23, 2010 6:14 PM
To: Carl Wallace
Cc: ""
Subject: Re: [keyassure] draft-hoffman-keys-linkage-from-dns-02 security considerations

On 23 Sep 2010, at 19:45, "Carl Wallace" <[email-masked]> wrote:

It's practically impossible to manage a TLS trust anchor store. The only alternative is leap-of-faith (or rather jump-through-several-hoops-of-faith) for each of dozens of websites, and do it again every year or two when the certs expire.

I agree.  It is also impossible to manage of know at any given point in time if andy Trust Anchor can continue to be

trusted.

What do you mean by "path validation"?

Tony.
--

f.anthony.n.finch  <[email-masked]>  http://dotat.at/

Regards,
Jeffrey A. Williams