Subject: Re: [keyassure] Updated Charter (after Beijing)

From: "Jeffrey A. Williams" <[email-masked]>
Date: Tue, 23 Nov 2010 09:31:51 -0600 (GMT-06:00)

Phillip and all,

I remember and I could not agree more with you here.

-----Original Message-----
From: Phillip Hallam-Baker
Sent: Nov 23, 2010 7:09 AM
To: Stephen Farrell
Cc: [email-masked]
Subject: Re: [keyassure] Updated Charter (after Beijing)

I agree with Stephen on the goals.

Unrealistic goals slow things down. They don't make anything happen faster.

What I have seen happen repeatedly in standards processes is groups have adopted goals they can't possibly meet and then the impossible goals become the reason not to look at the real issues.

We would have started deployment of DNSSEC in 2002 only some people thought there was no time to consider real world deployment issues. Then when the EU privacy thing came up wit literally spent three years arguing over whether there was time to consider an issue that took 2 months to fix once we were allowed to consider it.

And don't get me started on SDMI or OpenID.

This particular problem cuts across layers 5, 7 and 8. It is a security problem.

On Tue, Nov 23, 2010 at 6:46 AM, Stephen Farrell <[email-masked]> wrote:

One hopefully minor nit and one question.

The nit: I assume that "and thus shown to be authentically from the
domain operator" doesn't require e.g. an additional signature other
than that provided by DNSSEC - the "from the domain operator" could
be read to imply that it does require an additional signature. Not
sure how best to re-word that but maybe something like "providing
strong evidence that the public key record has not been tampered
with since being inserted in the DNS" or something. (I'd have no
problem if an additional signature were allowed, e.g. if the record
contained an X.509 cert, but I didn't think we wanted to insist
on that always, at least not in the charter.)

The possibly more substantive question: the charter says that "last
hop" security is needed, but its not clear to me whether this WG will
specify ways to do that for an implementer that doesn't already
know how. (The "or by other means" phrase is pretty vague.) Am I
right in thinking that one of the drafts listed will include that
(by reference is fine if good references exist). If the answer is
yes, then it might be worth saying so, (and maybe get rid of the
"or by other means" phrase). If the answer is no, then I think
that'd be a problem since I'd bet it'd lead to implementers making
the frequently bad assumption that someone else has looked after
the "last hop."

Oh - and I bet a beer the September milestones slip:-)

Ta,
Stephen.

On 23/11/10 08:29, Ondřej Surý wrote:
> Hi there,
>
> We believe we have managed to integrate all the comments, suggestions,
> the latest spin at the charter is:
> http://trac.tools.ietf.org/area/sec/trac/wiki/Keyassure
>
> Diffs are:
> http://trac.tools.ietf.org/area/sec/trac/wiki/Keyassure?action=diff&version=12
>
>
> We added:
> - note about need for DNSSEC
> - note about general policy being out of scope
> - moved milestones so we have more time to discuss
>
> All was done with cooperation with ADs.  Many thanks to them.
>
> Ondrej & Warren

_______________________________________________
keyassure mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyassure

--
Website: http://hallambaker.com/

Regards,
Jeffrey A. Williams
"Obedience of the law is the greatest freedom" -
Abraham Lincoln

"Credit should go with the performance of duty and not with what is very
often the accident of glory" - Theodore Roosevelt

"If the probability be called P; the injury, L; and the burden, B; liability
depends upon whether B is less than L multiplied by
P: i.e., whether B is less than PL."
United States v. Carroll Towing  (159 F.2d 169 [2d Cir. 1947]
===============================================================
Updated 1/26/04
Network Eng. SR. Eng. Network data security
ABA member in good standing member ID 01257402
E-Mail [email-masked]
Phone: 214-244-4827

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 23 Nov 2010 22:02:45 +0200

Hi,

we had a long discussion before Beijing on the missing problem 
statement. I would expect some of it to find its way into the charter.

Thanks,
	Yaron
>
> Message: 1
> Date: Tue, 23 Nov 2010 09:29:59 +0100
> From: Ond?ej Sur?<[email-masked]>
> Subject: [keyassure] Updated Charter (after Beijing)
> To: [email-masked]
> Message-ID:<[email-masked]>
> Content-Type: text/plain; charset=UTF-8; format=flowed
>
> Hi there,
>
> Ondrej&  Warren