Subject: [keyassure] The draft and subj alt names

From: "Olle E. Johansson" <[email-masked]>
Date: Thu, 31 Mar 2011 12:05:48 +0200

I have read the draft and reacted to one thing. Sorry if this already have been discussed on the list.

The draft -06 says
"The end entity certificate from TLS, regardless of whether it was
   matched with a TLSA type 1 certificate or chained to a TLSA type 2 CA
   certificate, must have at least one identifier in the subject or
   subjectAltName field of the matched certificates matches the expected
   identifier for the TLS server. "

The new RFC 6125 tells us that we should:
"Move toward including and checking even more specific
      subjectAlternativeName extensions where appropriate for using the
      protocol (e.g., uniformResourceIdentifier and the otherName form
      SRVName)."

I feel we need to be more specific in the draft.  What type of subjectAltName should we match with?
dnsName?

And if we're using SIP, and have URI's in the certificate - should that be part of this draft
or should we open for protocol-specific specifications for other types of subject Alt Names?

/O

---

From: "Richard L. Barnes" <[email-masked]>
Date: Thu, 31 Mar 2011 13:12:32 +0200

As I've said in other threads, this WG should be silent on requirements for certificate names, since different applications use TLS certificate names in different ways.  See for example the difference between RFC 2818 and RFC 6125.  The text you reference in the draft is technically harmless ("must" not "MUST"), but should probably be deleted anyway.

--Richard

On Mar 31, 2011, at 12:05 PM, Olle E. Johansson wrote:

> _______________________________________________
> keyassure mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/keyassure

---

From: Jay Daley <[email-masked]>
Date: Fri, 1 Apr 2011 09:41:24 +1300

> As I've said in other threads, this WG should be silent on requirements for certificate names, since different applications use TLS certificate names in different ways.  See for example the differe…

There are two separate issues here:
a) whether we think name matching is still needed with DANE
b) what the draft should say about that

On a) I would make the case that name matching is should not be done because
- DNSSEC provides sufficient trust
- name matching forces certain operational decisions onto end user (e.g. multiple certs, cert reuse) that are unreasonable

On b) There are six options for the draft:

1.  State that name matching must be done
2.  State that name matching must not be done
3.  Leave it to applications with a recommendation to match
4.  Leave it to applications with a recommendation not to match
5.  Leave it to applications with no recommendation
6.  Add a flag into TLSA that specifies whether name matching is to be done or not

My choice, in order of preference would be 2, 6, 4.  

Jay

-- 
Jay Daley
Chief Executive
.nz Registry Services (New Zealand Domain Name Registry Limited)
desk: +64 4 931 6977
mobile: +64 21 678840

---

From: "Richard L. Barnes" <[email-masked]>
Date: Fri, 1 Apr 2011 04:06:45 +0200

The only choice that avoids updating several RFCs is 5.  Just leave it alone!
--Richard

---

From: Jay Daley <[email-masked]>
Date: Fri, 1 Apr 2011 16:15:22 +1300

On 1/04/2011, at 3:06 PM, Richard L. Barnes wrote:

> The only choice that avoids updating several RFCs is 5.

Is that your only reason for not wanting to tackle this?  Do you have any view on the nature of trust that DNSSEC provides to applications or not?

>  Just leave it alone!

No.

warmest regards
Jay