Subject: [KEYPROV] Accepting draft-doherty-keyprov-dskpp-01.txt as WG item

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 11 Jul 2007 20:43:17 +0200

KEYPROV working group members!

[Responses to this message are necessary by July 20th]

At IETF#69 the KEYPROV working group was quite satisfied with the 
proposal of merging the two individual solutions. Phillip and myself 
decided to wait until we have a merged draft for the group to look at. 
Now, we have a revised version of the -00 document available for review.

We believe that this document provides a basis for further work.
 
This is a call for input on accepting "Dynamic Symmetric Key 
Provisioning Protocol (DSKPP)" (draft-doherty-keyprov-dskpp-01.txt) as 
WG item. Please provide any input, both positive and negative.

Ciao
Hannes & Phillip

-------- Original Message --------
Subject: 	I-D ACTION:draft-doherty-keyprov-dskpp-01.txt
Date: 	Wed, 11 Jul 2007 14:15:01 -0400
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title		: Dynamic Symmetric Key Provisioning Protocol (DSKPP)
	Author(s)	: M. Nystroem, et al.
	Filename	: draft-doherty-keyprov-dskpp-01.txt
	Pages		: 100
	Date		: 2007-7-11
	
DSKPP is a client-server protocol for initialization (and
   configuration) of symmetric keys to locally and remotely accessible
   cryptographic modules.  The protocol can be run with or without
   private-key capabilities in the cryptographic modules, and with or
   without an established public-key infrastructure.

   Three variations of the protocol support multiple usage scenarios.
   The four-pass (i.e., two round-trip) variant enables key generation
   in near real-time.  With the four-pass variant, keys are mutually
   generated by the provisioning server and cryptographic module;
   provisioned keys are not transferred over-the-wire or over-the-air.
   Two- and one-pass variants enable secure and efficient download and
   installation of symmetric keys to a cryptographic module in
   environments where near real-time communication may not be possible.

   This document builds on information contained in [RFC4758], adding
   specific enhancements in response to implementation experience and
   liaison requests.  It is intended, therefore, that this document or a
   successor version thereto will become the basis for subsequent
   progression of a symmetric key provisioning protocol specification on
   the standards track.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-doherty-keyprov-dskpp-01.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-doherty-keyprov-dskpp-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-doherty-keyprov-dskpp-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/keyprov

---

From: "Doherty, Andrea" <[email-masked]>
Date: Tue, 17 Jul 2007 16:37:34 -0400

Hannes,
I recommend (and accept) "Dynamic Symmetric Key Provisioning Protocol
(DSKPP)" (draft-doherty-keyprov-dskpp-01.txt) as a KEYPROV WG item.
This draft protocol proposal is within the scope of the WG charter, esp.
"for delivery of a protocol definition for provisioning of symmetric
cryptographic keys and associated attributes".  Furthermore, this
proposal incorporates the plan for a converged protocol that was agreed
upon at the KEYPROV WG meeting at IETF-68 Prague.
Andrea 

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: Wednesday, July 11, 2007 2:43 PM
To: [email-masked]
Subject: [KEYPROV] Accepting draft-doherty-keyprov-dskpp-01.txt as WG
item

 

Ciao
Hannes & Phillip

-------- Original Message --------
Subject: 	I-D ACTION:draft-doherty-keyprov-dskpp-01.txt
Date: 	Wed, 11 Jul 2007 14:15:01 -0400
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]

	Title		: Dynamic Symmetric Key Provisioning Protocol
(DSKPP)
	Author(s)	: M. Nystroem, et al.
	Filename	: draft-doherty-keyprov-dskpp-01.txt
	Pages		: 100
	Date		: 2007-7-11

Send a message to:
	[email-masked].
In the body type:
	
	a MIME-compliant mail reader.  Different MIME-compliant mail
readers

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 17 Jul 2007 22:44:03 +0200

Please state your opinion.

Hannes Tschofenig wrote:
> the message. You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce to change your 
> subscription settings.
>
> logging in, type "cd internet-drafts" and then "get 
> draft-doherty-keyprov-dskpp-01.txt".
>
> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: "Pei, Mingliang" <[email-masked]>
Date: Tue, 17 Jul 2007 15:26:24 -0700

I would also like to recommend the revised DSKPP as KEYPROV WG item.

- Ming 

-----Original Message-----
From: Doherty, Andrea [mailto:[email-masked]] 
Sent: Tuesday, July 17, 2007 1:38 PM
To: Hannes Tschofenig; [email-masked]
Subject: RE: [KEYPROV] Accepting draft-doherty-keyprov-dskpp-01.txt as
WG item

Hannes,

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]]
Sent: Wednesday, July 11, 2007 2:43 PM
To: [email-masked]
Subject: [KEYPROV] Accepting draft-doherty-keyprov-dskpp-01.txt as WG
item

 

Ciao
Hannes & Phillip

-------- Original Message --------
Subject: 	I-D ACTION:draft-doherty-keyprov-dskpp-01.txt
Date: 	Wed, 11 Jul 2007 14:15:01 -0400
From: 	[email-masked]
Reply-To: 	[email-masked]
To: 	[email-masked]

	

Send a message to:
	[email-masked].
In the body type:

---

From: Magnus Nyström <[email-masked]>
Date: Wed, 18 Jul 2007 08:04:43 +0200 (W. Europe Daylight Time)

I support adopting this draft as a working group item.

-- Magnus

On Tue, 17 Jul 2007, Hannes Tschofenig wrote:

>> At IETF#69 the KEYPROV working group was quite satisfied with the proposal 
>> of merging the two individual solutions. Phillip and myself decided to wait 
>> until we have a merged draft for the group to look at. Now, we have a 
>> revised version of the -00 document available for review.
>> 
>> This is a call for input on accepting "Dynamic Symmetric Key Provisioning 
>> Protocol (DSKPP)" (draft-doherty-keyprov-dskpp-01.txt) as WG item. Please 
>> provide any input, both positive and negative.
>> 
>> Ciao
>> Hannes & Phillip
>> 
>> [email-masked] with the word unsubscribe in the body of the 
>> message. You can also visit 
>> username "anonymous" and a password of your e-mail address. After logging 
>> in, type "cd internet-drafts" and then "get

---

From: "Meyer, Ulrike" <[email-masked]>
Date: Wed, 18 Jul 2007 10:28:25 +0200

Hi all,

I also support accepting draft-doherty-keyprov-dskpp-01 as working group item!

Br,
Uli

---

From: "Philip Hoyer" <[email-masked]>
Date: Wed, 18 Jul 2007 14:53:49 +0200

Philip

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: 17 July 2007 21:44
To: [email-masked]
Subject: [KEYPROV] REMINDER --- Accepting
draft-doherty-keyprov-dskpp-01.txtas WG item

readers

---

From: "Salah Machani" <[email-masked]>
Date: Wed, 18 Jul 2007 09:23:09 -0400

I support accepting the draft as WG item.

Salah

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: Tuesday, July 17, 2007 4:44 PM
To: [email-masked]
Subject: [KEYPROV] REMINDER --- Accepting

readers

Notice to Recipient:  The information in this message is meant only for the intended recipient of the transmission and may contain confidential or privileged information. 
Any copying, retransmittal, taking of action in reliance on, or other use of the information in this communication by persons other than the addressees is prohibited.  
If you received this email in error, please immediately notify us and please delete or destroy all copies of this message.
This message may have been altered without your or our knowledge and the sender does not accept any liability for any errors.  Thank you.

---

From: "CHANG Shuh" <[email-masked]>
Date: Wed, 18 Jul 2007 16:54:28 +0200

Yes, I'd endorse accepting "Dynamic Symmetric Key Provisioning Protocol
(DSKPP)" (draft-doherty-keyprov-dskpp-01.txt) as WG item.

Thanks.
Regards,
Shuh

> Sent: Tuesday, July 17, 2007 3:44 PM
> To: [email-masked]

---

From: "Sharon Boeyen" <[email-masked]>
Date: Wed, 18 Jul 2007 14:43:14 -0400

I also support accepting DSKPP as a WG item. 

-----Original Message-----
From: Hannes Tschofenig [mailto:[email-masked]] 
Sent: Tuesday, July 17, 2007 4:44 PM
To: [email-masked]
Subject: [KEYPROV] REMINDER --- Accepting

readers

---

From: "Stuart Vaeth" <[email-masked]>
Date: Thu, 19 Jul 2007 09:50:28 -0400

I support accepting DSKPP as a WG item.
Stu Vaeth

---

From: "Turner, Sean P." <[email-masked]>
Date: Wed, 25 Jul 2007 09:17:29 -0500

I missed the deadline but for what it's worth this is a good draft to accept
in the WG.

spt