Subject: [KEYPROV] FW: Internet Draft submission

From: "Doherty, Andrea" <[email-masked]>
Date: Mon, 9 Jul 2007 04:08:26 -0400

Please find attached submission for which I just received an auto-response from the IETF Submission Manager.
Andrea

________________________________

From: Doherty, Andrea
Sent: Mon 7/9/2007 3:44 AM
To: [email-masked]
Subject: Internet Draft submission

To the IETF Secretariat: 
Attached please find the -01 version of Internet-Draft submission entitled "Dynamic Symmetric Key Provisioning Protocol (DSKPP)". Please direct any questions or comments you may have to me.

Thank you, 
Andrea Doherty 

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/keyprov

---

From: "Pei, Mingliang" <[email-masked]>
Date: Mon, 9 Jul 2007 01:28:12 -0700

Andrea,

Thanks. Just notice that PSKC has also made type changes from
<SecretType> to <KeyType>, SecretId to KeyId, SecretAlgorithm to
KeyAlgorithm when making SecretContainerType to KeyContainerType. 
DSKPP samples don't reflect these yet, and we can update in next
revision. 

- Ming 

-----Original Message-----
From: Doherty, Andrea [mailto:[email-masked]] 
Sent: Monday, July 09, 2007 1:08 AM
To: [email-masked]
Subject: [KEYPROV] FW: Internet Draft submission

Please find attached submission for which I just received an
auto-response from the IETF Submission Manager.
Andrea

From: Doherty, Andrea

To the IETF Secretariat: 
Attached please find the -01 version of Internet-Draft submission
entitled "Dynamic Symmetric Key Provisioning Protocol (DSKPP)". Please
direct any questions or comments you may have to me.

Thank you,
Andrea Doherty

---

From: "Pei, Mingliang" <[email-masked]>
Date: Mon, 9 Jul 2007 01:37:29 -0700

Please see these updated sample messages.

- Ming 

-----Original Message-----
From: Doherty, Andrea [mailto:[email-masked]] 
Sent: Monday, July 09, 2007 1:08 AM
To: [email-masked]
Subject: [KEYPROV] FW: Internet Draft submission

From: Doherty, Andrea

To the IETF Secretariat: 

Thank you,
Andrea Doherty

---

From: "CHANG Shuh" <[email-masked]>
Date: Mon, 9 Jul 2007 19:22:02 +0200

Hi Ming & Andrea,

Sorry for missing the PSKC conf calls last week. I was on vacation last
week.

I saw that you sent out the lastest PSKC XSD schema files
(keyprov_pskc_schema_v1.1.xsd and keyprov_logotype_v1.0.xsd) and the
sample XML file
(draft-hoyer-keyprov-portable-symmetric-key-container-01.xml). You also
sent out the sample XML files for DSKPP (serverfinished.xml,
serverfinished2.xml, serverfinished3.xml, serverfinished4.xml). 

Do you also have the latest XSD schema file for the DSKPP? The latest
one that I have is from the May version, KEYPROV Draft 05-23-2007.xsd.
Is this still the valid schema file for DSKPP? Thanks.

Regards,
Shuh

> From: Pei, Mingliang [mailto:[email-masked]] 
> Sent: Monday, July 09, 2007 3:37 AM
> To: Doherty, Andrea; [email-masked]
> Subject: RE: [KEYPROV] FW: Internet Draft submission
> 
> 
> Attached please find the -01 version of Internet-Draft 
> submission entitled "Dynamic Symmetric Key Provisioning 
> Protocol (DSKPP)". Please direct any questions or comments 
> you may have to me.
> 
> Thank you,
> Andrea Doherty 
> 
> 
>

---

From: "Pei, Mingliang" <[email-masked]>
Date: Mon, 9 Jul 2007 12:13:03 -0700

Shuh,

DSKPP v1.1 schema file will be sent soon later. I sent PSKC schema file
v1.1, and a minor update v1.2 by Philip will be sent later too.

- Ming 

-----Original Message-----
From: CHANG Shuh [mailto:[email-masked]] 
Sent: Monday, July 09, 2007 10:22 AM
To: Pei, Mingliang; Doherty, Andrea; [email-masked]
Subject: RE: [KEYPROV] FW: Internet Draft submission

Hi Ming & Andrea,

Regards,
Shuh

---

From: "Doherty, Andrea" <[email-masked]>
Date: Mon, 9 Jul 2007 15:36:05 -0400

Shuh,
There is not an updated .xsd, however, the schema was slightly modified,
and can be found in the .txt file that was submitted to the IETF.  Note
that the sample files that you refer to below probably differ from what
was submitted.
Andrea 

-----Original Message-----
From: CHANG Shuh [mailto:[email-masked]] 
Sent: Monday, July 09, 2007 1:22 PM
To: Pei, Mingliang; Doherty, Andrea; [email-masked]
Subject: RE: [KEYPROV] FW: Internet Draft submission

Hi Ming & Andrea,

Regards,
Shuh

---

From: "CHANG Shuh" <[email-masked]>
Date: Mon, 9 Jul 2007 22:23:10 +0200

Doherty, Andrea wrote:
> Note that the sample files that you
> refer to below probably differ from what was submitted.

Hi Andrea,

I did notice that the sample XML files that Ming sent out are different
from the ones that you sent out back in May. I have not had a chance to
review the new sample set yet. I'd assume that these new XML sample
files are for different use cases than the ones that you sent out in
May. Correct? [I'll take a closer look at them when I have a chance.]
Thanks.

Ming,

Based on what you indicated, you will be sending out the following
updated XSD schema files:

DSKPP V1.1 XSD
PSKC V1.2 XSD

as the "equivalent" of the latest IETF submission. Correct? [I'd like to
make sure to have the schema files that reflect (in synch. with) what
are stated in the IETF I-D submission.]

Regards,
Shuh

> Sent: Monday, July 09, 2007 2:36 PM
> To: CHANG Shuh; Pei, Mingliang; [email-masked]
> There is not an updated .xsd, however, the schema was 
> slightly modified, and can be found in the .txt file that was 
> submitted to the IETF.  Note that the sample files that you 
> refer to below probably differ from what was submitted.
> Andrea 
> 
> Sorry for missing the PSKC conf calls last week. I was on 
> vacation last week.
> 
> (keyprov_pskc_schema_v1.1.xsd and keyprov_logotype_v1.0.xsd) 
> and the sample XML file 
> (draft-hoyer-keyprov-portable-symmetric-key-container-01.xml).
>  You also sent out the sample XML files for DSKPP 
> (serverfinished.xml, serverfinished2.xml, 
> serverfinished3.xml, serverfinished4.xml). 
> 
> Do you also have the latest XSD schema file for the DSKPP? 
> The latest one that I have is from the May version, KEYPROV 
> Draft 05-23-2007.xsd.

---

From: "Pei, Mingliang" <[email-masked]>
Date: Mon, 9 Jul 2007 13:31:10 -0700

Shuh,

Yes, I will get .xsd file to be up to date for publishing. Meanwhile,
please refer to the I-D themselves which contains the latest schema.

We want to figure out a place to host these schema files. For PSKC, it
used to be in OATH web site. This is an issue to be discussed later
under keyprov.

- Ming 

-----Original Message-----
From: CHANG Shuh [mailto:[email-masked]] 
Sent: Monday, July 09, 2007 1:23 PM
To: Doherty, Andrea; Pei, Mingliang; [email-masked]
Subject: RE: [KEYPROV] FW: Internet Draft submission

Hi Andrea,

Ming,

DSKPP V1.1 XSD
PSKC V1.2 XSD

Regards,
Shuh

> There is not an updated .xsd, however, the schema was slightly 
> modified, and can be found in the .txt file that was submitted to the 
> IETF.  Note that the sample files that you refer to below probably 
> differ from what was submitted.
> Andrea
> 
> Sorry for missing the PSKC conf calls last week. I was on vacation 
> last week.
> 
>  You also sent out the sample XML files for DSKPP (serverfinished.xml,

> The latest one that I have is from the May version, KEYPROV Draft 
> 05-23-2007.xsd.