Subject: Re: [KEYPROV] PSKC

From: "Philip Hoyer" <[email-masked]>
Date: Thu, 20 Mar 2008 21:35:07 +0100

Ladies and Gentlemen,

Please note the main issues are the ones on the last slide of the presentation given at IETF that was sent around.

Can we try to split up the work as following please:

Ming
- Could you please look at generating a proper asymmetric example and add the example to section 6.2.
- change URI xxx/pskc#valuecompare to xxx/pskc#pin in section 6.3. #valuecompare is not a good name for type of credential (PIN).
- Clean up reference section (some reference may not be "Normative" such as OATHRefArch )

Salah
- Review the security considerations section based on the new spec
- Review and comment on following proposal for the schema that has a key template concept.
I was thinking we have a sequence of key objects in the KeyContainer Element with the name KeyTemplates. The KeyId would then be the unique Id of the template. We will then extend the Key entity with an attribute called KeyTemplate Id. If this attribute is set the default values for that key are taken out of that key template. If a value is present in the key instance itself it will override the template value.
- Generally review the spec

Hannes and Philip Hallam-Baker
- I need your help for the IANA section. Could you write the content for the IANA consideration section please. We agreed that we would ask IANA to create 2 registers one for algorithms URIs and one for the key-metadata semantics.

After we have the IANA section I can clean up the issue for:
-Clean up references to OTP algorithm URI in Section 6.3.1.2
Reference Eastlake informational RFC 
Specify some locally (RSA SecurID, ActivIdentity,others)?

I will do the rest:
- More clarification of ValueMac for specific transport security options (eg asymmetric, kw- algos not all HSMs)
- TODO: Extend definition of userId for user device binding, current proposal is DN style (OU=Engineering, CN=James...)
- TODO: Add definition of type in DerivedKey

We also need to discuss if we want to move to String for the plainparameter instead of base64binary, I am in favour of it.

Thanks for your help,
Philip

-----Original Message-----
From: Pei, Mingliang [mailto:[email-masked]] 
Sent: Tuesday, March 18, 2008 5:58 PM
To: Hannes Tschofenig; [email-masked]
Cc: Philip Hoyer
Subject: RE: PSKC

I am pretty busy this week as I am preparing two conferences next week
when I travel to Dulles from Monday to Thursday. I will try to work on
some issues though.

Can we have a quick meeting by this Thursday to go over list of open
issues, and see how we distribute the work? For some issues that I sent
to Philip before the IETF meeting, several are straight updates, and I
know where they are to change and I can changes in the draft before next
Tuesday.

- Ming

> -----Original Message-----
> From: Hannes Tschofenig [mailto:[email-masked]] 
> Sent: Tuesday, March 18, 2008 3:15 PM
> To: [email-masked]; Pei, Mingliang
> Cc: [email-masked]
> Subject: PSKC
> 
> Hi Salah,
> Hi Ming,
> 
> I met Philip last week in Philly. I told him that our SecAD 
> wants to see the work moving forward a bit faster.
> Hence, it would be great to see a draft update early next week.
> 
> Who of you has time to work through some open issues?
> 
> Ciao
> Hannes
> 
> 

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: "Pei, Mingliang" <[email-masked]>
Date: Thu, 20 Mar 2008 21:57:18 -0700

Hi Philip,

Sure. I will get the three items resolved. 

- Ming 

-----Original Message-----
From: Philip Hoyer [mailto:[email-masked]] 
Sent: Thursday, March 20, 2008 1:35 PM
To: Pei, Mingliang; Hannes Tschofenig; [email-masked]; Hallam-Baker, Phillip
Cc: [email-masked]; [email-masked]
Subject: RE: PSKC

Ladies and Gentlemen,

Ming

Salah

After we have the IANA section I can clean up the issue for:
-Clean up references to OTP algorithm URI in Section 6.3.1.2 Reference Eastlake informational RFC Specify some locally (RSA SecurID, ActivIdentity,others)?

I will do the rest:

Thanks for your help,
Philip

-----Original Message-----
From: Pei, Mingliang [mailto:[email-masked]] 
Sent: Tuesday, March 18, 2008 5:58 PM
To: Hannes Tschofenig; [email-masked]
Cc: Philip Hoyer
Subject: RE: PSKC

- Ming