Subject: Re: [KEYPROV] PSKC's use of default values

From: "Philip Hoyer" <[email-masked]>
Date: Mon, 10 Nov 2008 22:11:58 +0100

Anders,
Do you suggest we do not use defaults or do you suggest that everywhere we used it in the schema we add a text alerting to the fact that if the Keycontainer is signed the defaults MUST be explicitely written?
Philip

----- Original Message -----
From: [email-masked] <[email-masked]>
To: KEYPROV <[email-masked]>
Sent: Mon Nov 10 20:55:19 2008
Subject: [KEYPROV] PSKC's use of default values

I believe I have mentioned this before but I didn't get any response so I try again.

There is a cool feature in XML Schemas that allows you to specify default values.
The not so cool side-effect is that signatures tend to break when you use this feature.

Why?

When you generate XML you usually do not use a schema, you just write.
The signature generation part do not know the schema either which means that defaults are not 
emitted (well, that was I guess the whole point with defaults anyway).

When you parse XML under the control of a schema you get the defaults filled in.  If you verify 
signatures on the DOM tree that may be the result of the read operation it will fail.

That is, if you want to keep defaults you should probably add a paragraph telling the "signer" to 
always fill in the right ("canonicalized") data and not depend on the defaults otherwise the 
"verifier" will be in trouble.

Other reference:
http://lists.w3.org/Archives/Public/w3c-ietf-xmldsig/2005OctDec/0017.html

Anders

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: "Anders Rundgren" <[email-masked]>
Date: Tue, 11 Nov 2008 16:30:13 +0100

Hi Philip,

What workaround to use is mostly a matter of taste since all of the following solutions work:
- dropping defaults from the schema and putting them in the description
- adding a note as you suggested
- declaring attributes as "required"

My, in no way universal preference would be the first alternative since this makes the entire
KEYPROV suite independent of schema validation.  I.e. defaults would be left to program code to
cater for regardless if you use validation or not.

Regards
Anders
----- Original Message ----- 
From: Philip Hoyer
To: [email-masked] ; [email-masked]
Sent: Monday, November 10, 2008 22:11
Subject: Re: [KEYPROV] PSKC's use of default values

Anders,
Do you suggest we do not use defaults or do you suggest that everywhere we used it in the schema we
add a text alerting to the fact that if the Keycontainer is signed the defaults MUST be explicitely
written?
Philip

----- Original Message -----
From: [email-masked] <[email-masked]>
To: KEYPROV <[email-masked]>
Sent: Mon Nov 10 20:55:19 2008
Subject: [KEYPROV] PSKC's use of default values

Why?

Other reference:

Anders