Subject: [KEYPROV] FW: [P1619-3] New Key Management Effort: OASIS KMIP

From: "Hannes Tschofenig" <[email-masked]>
Date: Thu, 12 Feb 2009 19:19:29 +0200

FYI

________________________________

	From: Matt Ball [mailto:[email-masked]] 
	Sent: 12 February, 2009 17:57
	To: [email-masked]
	Subject: [P1619-3] New Key Management Effort: OASIS KMIP

	This is big news:
	
	OASIS just announced the creation of a new key management standards
effort called KMIP (Key Management Interoperability Protocol.  See new
stories below:

	*
http://www.infoworld.com/article/09/02/12/HP_IBM_push_new_KMIP_encryption_ke
y_standard_1.html 
	*
http://www.centredaily.com/business/technology/story/1115505.html

	You can download the draft standard and FAQs from here:
	
	http://xml.coverpages.org/KMIP/
	
	Matt Ball, IEEE P1619.x SISWG Chair
	Sun Microsystems, Inc.
	Cell: 303-717-2717
	http://www.linkedin.com/in/matthewvball
	http://www.mavaball.net/

---

From: "Philip Hoyer" <[email-masked]>
Date: Thu, 12 Feb 2009 18:52:23 +0100

Hannes,
They label us a mobile centric standard in their FAQ maybe something we
need to address.

Philip

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Hannes Tschofenig
Sent: Thursday, February 12, 2009 5:19 PM
To: [email-masked]
Subject: [KEYPROV] FW: [P1619-3] New Key Management Effort: OASIS KMIP

FYI

	This is big news:
	
	OASIS just announced the creation of a new key management
standards
effort called KMIP (Key Management Interoperability Protocol.  See new
stories below:

	*
http://www.infoworld.com/article/09/02/12/HP_IBM_push_new_KMIP_encryptio
n_ke
y_standard_1.html 
	*
http://www.centredaily.com/business/technology/story/1115505.html

	

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: "Anders Rundgren" <[email-masked]>
Date: Thu, 12 Feb 2009 23:22:04 +0100

It's a crowd these days :-)

http://keycenter.webpki.org
http://webpki.org/papers/keygen2/keygen2-fips140-2.pdf

What does KeyGen2 and KMIP have in common?
Extremely little as far as I can see.
  a.. KMIP appears to be a client->server protocol
  b.. KeyGen2 is rather a web-centric server->client protocol
The main difference between these schemes is that they build on diametrically opposed security models which I believe is just fine because they do not [at all] address the same application space in spite of the fact that they indeed both deal with Key Managent of Asymmetric and Symmetric Keys as well as other Objects.

The closest description of what KMIP seems to be is a remote version of a cryptographic API.

KeyGen2 is more like a replacement for WebKit's <keygen>  (used by Nokia, Google, and Apple), which was recently cast out from HTML5 as well as to Microsoft's CertEnroll which has never been suggested as a standard.

Anders Rundgren

This is big news:

*

---

From: <[email-masked]>
Date: Fri, 13 Feb 2009 16:05:37 -0500

I've put in a request to clarify this in the FAQ.

Rob Philpott 
RSA, the Security Division of EMC
Senior Technologist | e-Mail: [email-masked] | Office: (781)
515-7115 | Mobile: (617) 510-0893

> From: [email-masked] [mailto:[email-masked]] On
Behalf Of
> Philip Hoyer
> Sent: Thursday, February 12, 2009 12:52 PM
> To: Hannes Tschofenig; [email-masked]
> Subject: Re: [KEYPROV] FW: [P1619-3] New Key Management Effort: OASIS
KMIP