Subject: [KEYPROV] Overlap between KMIP and KEYPROV = None

From: "Anders Rundgren" <[email-masked]>
Date: Sun, 15 Feb 2009 08:37:34 +0100

Statement of purpose:
The KMIP Technical Committee will develop specification(s) for the interoperability of key management services with key management clients.

That's a very restricted scope since key-management clients is something completely different to key-using clients.

If you look a bit closer into the public-key functions this gets even more clear since the KMIP "push" model doesn't apply to end-users, or has at least not made any impact compared to the "pull" model currently used by Microsoft, Apple and others.  The latter schemes are not mentioned in the KMIP charter either.

Anders

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Mon, 16 Feb 2009 11:30:45 +0200

Hi Anders, 
 
this is also the impression I got when I participated in the IEEE
P1619.3 group. I believe that KMIP was heavily influenced by the
discussions in that group. 

KMIP does not appear to be something end devices would be using (not
even speaking about the complexity).
 
Ciao
Hannes

________________________________

	From: [email-masked] [mailto:[email-masked]]
On Behalf Of ext Anders Rundgren
	Sent: 15 February, 2009 09:38
	To: KEYPROV
	Subject: [KEYPROV] Overlap between KMIP and KEYPROV = None

	Statement of purpose:
	The KMIP Technical Committee will develop specification(s) for
the interoperability of key management services with key management
clients.
	 
	That's a very restricted scope since key-management clients is
something completely different to key-using clients.
	 
	If you look a bit closer into the public-key functions this gets
even more clear since the KMIP "push" model doesn't apply to end-users,
or has at least not made any impact compared to the "pull" model
currently used by Microsoft, Apple and others.  The latter schemes are
not mentioned in the KMIP charter either.
	 
	Anders

---

From: Anthony Nadalin <[email-masked]>
Date: Mon, 16 Feb 2009 14:21:03 -0600

So P1619.3 was not an influencing factor at all in our development of KMIP.
KMIP was designed to have endpoint devices talk, of course there are simple
and complex messaging models depending on your endpoint

Anthony Nadalin | Work 512.838.0085 | Cell 512.289.4122

  From:       "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>                                          
                                                                                                                         
  To:         "ext Anders Rundgren" <[email-masked]>, "KEYPROV" <[email-masked]>                            
                                                                                                                         
  Date:       02/16/2009 03:30 AM                                                                                        
                                                                                                                         
  Subject:    Re: [KEYPROV] Overlap between KMIP and KEYPROV = None                                                      

Hi Anders,

Ciao
Hannes

             From: [email-masked] [
mailto:[email-masked]]
On Behalf Of ext Anders Rundgren
             Sent: 15 February, 2009 09:38
             To: KEYPROV
             Subject: [KEYPROV] Overlap between KMIP and KEYPROV = None

             Statement of purpose:

             If you look a bit closer into the public-key functions this
gets

             Anders

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Mon, 16 Feb 2009 23:09:07 +0200

Hi Anthony, 

That's interesting. When I browsed through the document I got the impression
that it captured most of the things that were discussed and documented in
that IEEE group.  

But maybe that was only my impression. 

  KMIP was designed to have endpoint devices talk, of course there are
simple and complex messaging models depending on your endpoint 

When you say "endpoint" do you mean devices like my mobile phone or my
laptop? Or is it more a storage device?

Ciao
Hannes

Inactive hide details for "Tschofenig, Hannes (NSN - FI---02/16/2009
03:30:02 AM---Hi Anders,"Tschofenig, Hannes (NSN - FI---02/16/2009 03:30:02
AM---Hi Anders,

From:	 
"Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>	

To:	 
"ext Anders Rundgren" <[email-masked]>, "KEYPROV"
<[email-masked]>	

Date:	 
02/16/2009 03:30 AM	

Subject:	 
Re: [KEYPROV] Overlap between KMIP and KEYPROV = None	

  _____  

Hi Anders, 

Ciao
Hannes

Statement of purpose:

 
Anders

---

From: "Anders Rundgren" <[email-masked]>
Date: Mon, 16 Feb 2009 22:48:43 +0100

I'm also curious about the meaning of endpoint devices and particularly about what kind of applications KMIP is meant to support on such devices.

But most of all I'm puzzled about how push protocols are applied to phones and desktops.  AFAIK push e-mail isn't actually pushing mail data, but is rather clients relying on outstanding HTTP requests eventually returning with data or without data (=timeout) and then immediately setting up new requests which is rather some kind of "smart pull".  Using a browser things gets even more distant from the push paradigm since it is really the returned data (HTML) that is the request which is responded to with an often user-controlled post.  That's at least how Microsoft's CertEnroll works.

Anders
  ----- Original Message ----- 
  From: Hannes Tschofenig 
  To: 'Anthony Nadalin' ; Tschofenig, Hannes (NSN - FI/Espoo) 
  Cc: [email-masked] ; 'KEYPROV' 
  Sent: Monday, February 16, 2009 22:09
  Subject: Re: [KEYPROV] Overlap between KMIP and KEYPROV = None

  Hi Anthony, 

    That's interesting. When I browsed through the document I got the impression that it captured most of the things that were discussed and documented in that IEEE group.  

      KMIP was designed to have endpoint devices talk, of course there are simple and complex messaging models depending on your endpoint 

    When you say "endpoint" do you mean devices like my mobile phone or my laptop? Or is it more a storage device?

    Ciao
    Hannes

    "Tschofenig, Hannes (NSN - FI---02/16/2009 03:30:02 AM---Hi Anders,

          From: 

          To: 
          "ext Anders Rundgren" <[email-masked]>, "KEYPROV" <[email-masked]> 

          Date: 
          02/16/2009 03:30 AM 

          Subject: 

----------------------------------------------------------------------------

    Hi Anders, 

    Ciao
    Hannes

    Statement of purpose:

     
    Anders

------------------------------------------------------------------------------

---

From: Anthony Nadalin <[email-masked]>
Date: Tue, 17 Feb 2009 12:26:35 -0600

Push is optional and one of its mode is modeled after what you described
below, of course there is just the fire and forget model also, some of the
devices will not be very smart and may use Notify  in various ways

                                                                                                                         
  From:       "Anders Rundgren" <[email-masked]>                                                              
                                                                                                                         
  To:         "Hannes Tschofenig" <[email-masked]>, Anthony Nadalin/Austin/IBM@IBMUS, "Tschofenig, Hannes     
              \(NSN - FI/Espoo\)" <[email-masked]>                                                            
                                                                                                                         
  Cc:         <[email-masked]>, "'KEYPROV'" <[email-masked]>                                                 
                                                                                                                         
  Date:       02/16/2009 03:50 PM                                                                                        

I'm also curious about the meaning of endpoint devices and particularly
about what kind of applications KMIP is meant to support on such devices.

But most of all I'm puzzled about how push protocols are applied to phones
and desktops.  AFAIK push e-mail isn't actually pushing mail data, but is
rather clients relying on outstanding HTTP requests eventually returning
with data or without data (=timeout) and then immediately setting up new
requests which is rather some kind of "smart pull".  Using a browser things
gets even more distant from the push paradigm since it is really the
returned data (HTML) that is the request which is responded to with an
often user-controlled post.  That's at least how Microsoft's CertEnroll
works.

Anders
 ----- Original Message -----
 From: Hannes Tschofenig
 To: 'Anthony Nadalin' ; Tschofenig, Hannes (NSN - FI/Espoo)
 Cc: [email-masked] ; 'KEYPROV'
 Sent: Monday, February 16, 2009 22:09
 Subject: Re: [KEYPROV] Overlap between KMIP and KEYPROV = None

 Hi Anthony,

 So P1619.3 was not an influencing factor at all in our development of
 KMIP.

 That's interesting. When I browsed through the document I got the
 impression that it captured most of the things that were discussed and
 documented in that IEEE group.

 Ciao
 Hannes

 Inactive hide details for "Tschofenig, Hannes (NSN - FI---02/16/2009
 03:30:02 AM---Hi Anders,"Tschofenig, Hannes (NSN - FI---02/16/2009
 03:30:02 AM---Hi Anders,

                                                                           
 From:        "Tschofenig, Hannes (NSN - FI/Espoo)"                        
              <[email-masked]>                                  

 To:          "ext Anders Rundgren" <[email-masked]>, "KEYPROV" 
              <[email-masked]>                                           

 Hi Anders,

 Ciao
 Hannes

 Statement of purpose:

 Anders

---

From: Anthony Nadalin <[email-masked]>
Date: Tue, 17 Feb 2009 12:27:50 -0600

Our use cases included cell phones, power grid devices, sensors, laptops,
etc

                                                                                                                         
  From:       "Hannes Tschofenig" <[email-masked]>                                                            
                                                                                                                         
  To:         Anthony Nadalin/Austin/IBM@IBMUS, "Tschofenig, Hannes \(NSN - FI/Espoo\)" <[email-masked]>      

  Date:       02/16/2009 03:08 PM                                                                                        
                                                                                                                         
  Subject:    RE: [KEYPROV] Overlap between KMIP and KEYPROV = None                                                      

Hi Anthony,

 Ciao
 Hannes

                                                                           

 Hi Anders,

 Ciao
 Hannes

 Statement of purpose:

 Anders