Subject: [KEYPROV] Use of ECC in 2-pass DSKPP

From: Anders Rundgren <[email-masked]>
Date: Mon, 16 Mar 2009 09:20:13 +0100

Dear list,
Wrapping of downloaded secrets is extremely straightforward using RSA keys.
It doesn't appear to be half as simple using ECC (ECDH?).

Would it be possible to get a minimal extract showing how this is to be 
performed in DSKPP?

Or is it not supported?  This would be a problem since devices like 
routers are now being designed (on specification-level at least) to 
contain embedded ECC device keys.

Anders

---

From: "Philip Hoyer" <[email-masked]>
Date: Tue, 17 Mar 2009 16:15:44 +0100

Anders,
This was discussed but deferred as a future profile or extension.

Since we are also waiting for the work from xmlenc group on the subject.

Do you think this presents a problem?

Philip

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Anders Rundgren
Sent: Monday, March 16, 2009 8:20 AM
To: [email-masked]
Subject: [KEYPROV] Use of ECC in 2-pass DSKPP

Dear list,
Wrapping of downloaded secrets is extremely straightforward using RSA
keys.
It doesn't appear to be half as simple using ECC (ECDH?).

Anders
_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: "Anders Rundgren" <[email-masked]>
Date: Tue, 17 Mar 2009 20:44:56 +0100

Hi Philip,
No, lack of ECC-support is probably not a problem at this stage.

Based on my rather shallow knowledge of ECC it seems that it requires
rather fundamental changes to symmetric-key provisioning protocols.

It is though a bit disturbing that the W3C XML security guys haven't gotten further
with NIST Suite B support.

Anders

----- Original Message ----- 
From: "Philip Hoyer" <[email-masked]>
To: "Anders Rundgren" <[email-masked]>; <[email-masked]>
Sent: Tuesday, March 17, 2009 16:15
Subject: RE: [KEYPROV] Use of ECC in 2-pass DSKPP

Anders,

Philip

-----Original Message-----

Dear list,

Anders