Subject: Re: [KEYPROV] [Editorial Errata Reported] RFC6063 (2999)

From: Sean Turner <[email-masked]>
Date: Sun, 13 Nov 2011 10:13:43 +0800

Trying to clear up the errata.  Should I approve this?

spt

On 10/18/11 12:39 AM, RFC Errata System wrote:
> The following errata report has been submitted for RFC6063,
> "Dynamic Symmetric Key Provisioning Protocol (DSKPP)".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=6063&eid=2999
>
> --------------------------------------
> Type: Editorial
> Reported by: Gareth Richards<[email-masked]>
>
> Section: 4.2.4
>
> Original Text
> -------------
>             DSKPP Client                         DSKPP Server
>
>             ------------                         ------------
>
>             E(K,R_C), AD          --->
>
>
>
> Corrected Text
> --------------
>             DSKPP Client                         DSKPP Server
>
>             ------------                         ------------
>
>             E(K,R_C), [AD]          --->
>
>
>
> Notes
> -----
> The AD is carried in the<KeyProvClientHello>  if sent as a result of a trigger and so is optional in the<ekyProvClientNonce>.
>
> Instructions:
> -------------
> This errata is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party (IESG)
> can log in to change the status and edit the report, if necessary.
>
> --------------------------------------
> RFC6063 (draft-ietf-keyprov-dskpp-14)
> --------------------------------------
> Title               : Dynamic Symmetric Key Provisioning Protocol (DSKPP)
> Publication Date    : December 2010
> Author(s)           : A. Doherty, M. Pei, S. Machani, M. Nystrom
> Category            : PROPOSED STANDARD
> Source              : Provisioning of Symmetric Keys
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
>

---

From: Sean Turner <[email-masked]>
Date: Mon, 14 Nov 2011 07:31:05 +0800

Okay, I can amend the errata to include this.

spt

On 11/14/11 2:06 AM, Magnus Nystrom wrote:
> Gareth appears to be correct; the text in 4.2.4 should probably also be amended to state something like:
> "The AD element MUST be sent unless it was already sent in the KeyProvClientHello message."
>
> -- Magnus
>
>
>> -----Original Message-----
>> From: Sean Turner [mailto:[email-masked]]
>> Sent: Saturday, November 12, 2011 6:14 PM
>> To: [email-masked]; [email-masked]; [email-masked];
>> Magnus Nystrom
>> Cc: [email-masked]; [email-masked];
>> [email-masked]; [email-masked]; [email-masked]
>> Subject: Re: [Editorial Errata Reported] RFC6063 (2999)
>>
>>> The following errata report has been submitted for RFC6063, "Dynamic
>>> Symmetric Key Provisioning Protocol (DSKPP)".
>>>
>>> The AD is carried in the<KeyProvClientHello>   if sent as a result of a trigger and
>> so is optional in the<ekyProvClientNonce>.
>>>
>>> Instructions:
>>> -------------
>>> use "Reply All" to discuss whether it should be verified or rejected.
>>> When a decision is reached, the verifying party (IESG) can log in to
>>> change the status and edit the report, if necessary.
>>>

---

From: Magnus Nystrom <[email-masked]>
Date: Sun, 13 Nov 2011 18:06:24 +0000

-- Magnus