Subject: #16 [*] EPOCH (section 5.1.2)

From: "KAMADA Ken'ichi" <[email-masked]>
Date: Thu, 10 Feb 2005 15:43:48 +0900

> #16 [*] EPOCH (section 5.1.2)
> 
> 	Perhaps you need a description of the time stamp?  I recall there
> 	being such a description in draft-housley-binarytime-xx.
> 	(Sam Hartman)

The current draft specifies it as "the standard posix four octet
time stamp".  Is describing in KINK preferred to referring POSIX?

FWIW, the EPOCH field is only used for DPD and the format of it
is not important, as far as the same value is not reused within a
short period.

-- 
KAMADA Ken'ichi <[email-masked]>

---

From: Sam Hartman <[email-masked]>
Date: Thu, 17 Feb 2005 20:12:11 -0500

>>>>> "KAMADA" == KAMADA Ken'ichi <[email-masked]> writes:

    >> Perhaps you need a description of the time stamp?  I recall
    >> there being such a description in draft-housley-binarytime-xx.
    >> (Sam Hartman)

    KAMADA> The current draft specifies it as "the standard posix four
    KAMADA> octet time stamp".  Is describing in KINK preferred to
    KAMADA> referring POSIX?

Probably.  At least I don't think Russ's draft ended up referring to
Posix.

I actually don't care either wy so long as the format is clearly
specified.  Doing that by reference or by value is fine.

---

From: Kazunori Miyazawa <[email-masked]>
Date: Mon, 21 Feb 2005 15:02:17 +0900

> is not important, as far as the same value is not reused within a

I agree with Kamada-san.

I think it is important for EPOCH to have an implementation determine peer's 
rebooting. DPD is done by detecting the change of a EPOCH in a received message.
Therefore implementation just has to compare a new EPOCHwith old one as a 32bit
binary, so that the format is not important.

Even if we adopt the format which counts up a second from a base time, it is not
useful for a KINK implementation which can reboot in one tenth second.

As Kamda-san said, it is important the value for EPOCH must not reused within a
short period for the purpose.

Anyway I think the formant is not important and it dpends on a system in which a
KINK implementation runs.

I think EPOCH is a value under these conditions.
1. It is 32bit binary.
2. It MUST NOT reused within a short period.

--
Kazunori Miyazawa