Subject: #31 [*] behavior on KINK_ERROR

From: Kazunori Miyazawa <[email-masked]>
Date: Mon, 21 Feb 2005 16:06:16 +0900

Hello,

I agree. We need the behaviors of #31 in the issue list.

But please let me confirm.

Does the first item mean that the initiator which receives a message
with KINK_OK can ignore KINK_ERROR payload when the message includes it?

What are other error codes in the third item? Does it mean the error coeds
except for KINK_OK and KINK_BADQMVERS?

--
Kazunori Miyazawa

---

From: "KAMADA Ken'ichi" <[email-masked]>
Date: Mon, 21 Feb 2005 16:57:12 +0900

At Mon, 21 Feb 2005 16:06:16 +0900,
> with KINK_OK can ignore KINK_ERROR payload when the message includes it?

I meant _the_ KINK_ERROR whose value is KINK_OK.
If another KINK_ERROR were included (I think it is not allowed),
it should not be ignored.
# BTW, KINK_OK should not be allowed to be sent in the first place...

> except for KINK_OK and KINK_BADQMVERS?

Yes.

-- 
KAMADA Ken'ichi <[email-masked]>