Subject: request to progress draft-ietf-kink-kink-10

From: Derek Atkins <[email-masked]>
Date: Tue, 08 Nov 2005 13:14:27 -0500

Sam,

The KINK Working Group has come to consensus and requests
the IESG review draft-ietf-kink-kink-10 for publication as
a proposed standard.  We had a working group last call
which had a few comments which have been updated in the
text.  In my chair review of the document I found two
editorial issues which in my opinion can be addressed
by a note to the RFC Editor.

We are working with IANA to get a port number assigned,
and we are working with the Kerberos Working Group to
get our Key Usage Numbers assigned, but I believe that
the draft is complete and can be reviewed before those
numbers are obtained.

The two editorial issues are listed below.

Thank you,

-derek

ISSUES
----------

3.5.  Reporting Errors

   If the initiator detects an error in a received replay, there is no

should be

   If the initiator detects an error in a received reply, there is no

(replay -> reply)

-----------

5.3.  Identification Payloads

Where is the source of these IDs?

-- 
       Derek Atkins                 617-623-3745
       [email-masked]             www.ihtfp.com
       Computer and Internet Security Consultant

---

From: Shoichi Sakane <[email-masked]>
Date: Wed, 16 Nov 2005 16:27:34 +0900

Hi derek,

> The two editorial issues are listed below.

Should I resubmit the new draft -11 after fixing two issues ?

> ISSUES

The source is [IPDOI].  So it should change into the following text.

	KINK restricts the ID types that are defined by section
	4.6.2.1 of [IPDOI], to the following values:

---

From: Derek Atkins <[email-masked]>
Date: Wed, 16 Nov 2005 14:38:55 -0500

Hi,

I believe that both of these are editorial changes, so we
can apply them as an RFC Editor Note.  So, no, I do not
believe you need to update the draft at this time.  We
just need to remember these changes and make sure they
get inserted.

If we get the draft pushed back to us from the IESG
then we can insert them ourselves, but right now we
are "done".

Thank you,

-derek

---

From: Sam Hartman <[email-masked]>
Date: Wed, 16 Nov 2005 23:42:29 -0500

>>>>> "Derek" == Derek Atkins <[email-masked]> writes:
    Derek> can insert them ourselves, but right now we are "done".

    Derek> Thank you,

No, you're standing by to address IETF last call and IESg comments,
which is not the same as done:-)

P.S. Hope to have time to conduct AD review and issue a last call
tomorrow.  The draft will probably make the December 15 telechat.

---

From: Derek Atkins <[email-masked]>
Date: Thu, 17 Nov 2005 12:34:26 -0500

> which is not the same as done:-)

It's close enough to "done" in the short term.  Certainly we have
nothing to do until we hear back from the IESG...

> tomorrow.  The draft will probably make the December 15 telechat.

Good to hear.

-derek

---

From: Shoichi Sakane <[email-masked]>
Date: Fri, 18 Nov 2005 11:37:52 +0900

O.K.  Tell me if I have to do something.

---

From: Derek Atkins <[email-masked]>
Date: Mon, 21 Nov 2005 10:06:17 -0500

> O.K.  Tell me if I have to do something.

I will.

-derek