Subject: RE: Comments: draft-williams-krb5-gssapi-domain-based-name

From: "Liqiang(Larry) Zhu" <[email-masked]>
Date: Thu, 21 Oct 2004 09:51:14 -0700

Nicolas Williams wrote:
> Or is there something about the SSPI that obviates the need for name
type OIDs?

SSPI does not use OID at the API level.  

-- Larry

-----Original Message-----
From: Nicolas Williams [mailto:[email-masked]] 
Sent: Thursday, October 21, 2004 9:46 AM
To: Liqiang(Larry) Zhu
Cc: [email-masked]; Paul Leach
Subject: Re: Comments: draft-williams-krb5-gssapi-domain-based-name

On Thu, Oct 21, 2004 at 09:43:57AM -0700, Liqiang(Larry) Zhu wrote:
> Nicolas Williams wrote:
> > Is <DC name> a NetBIOS name?
> 
> No, we do not support ldap/<NETBIOS>/<domain>.
> 
> > And it has the benefit of looking different from hostbased names. 
> > Or, at least, I thought it was a benefit.
> 
> I would rather design domain-based-service-names as a super-set of 
> host-based-service-names, such that a host-based service is just a 
> domain based service with the domain name being the default value, 
> this way you can use the existing service@host names at the place 
> where server@host@domain is needed.  This provides backward 
> compatibility (as it is an incremental change).

The application still requires changing though, to use the new name type
OID.  Or is there something about the SSPI that obviates the need for
name type OIDs?

Anyways, I don't feel strongly about this one way or the other.

Nico
-- 

_______________________________________________
Kitten mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/kitten

---

From: Nicolas Williams <[email-masked]>
Date: Thu, 21 Oct 2004 11:53:59 -0500

> SSPI does not use OID at the API level.  

Does it use generic GSS name syntax?