Subject: RE: Comments: draft-williams-krb5-gssapi-domain-based-name

From: "Paul Leach" <[email-masked]>
Date: Thu, 21 Oct 2004 12:33:53 -0700

As the kerb clarifications says (sec 5.2.2), IIRC unchanged from 1510:

name-type
      This field specifies the type of name that follows. Pre-defined
      values for this field are specified in section 6.2. The name-type
      SHOULD be treated as a hint. Ignoring the name type, no two names
      can be the same (i.e. at least one of the components, or the
      realm, must be different).

As far as I can tell, that means that a new name type isn't needed.

In our implementation, the name->key database entries is keyed (in the
database sense) by (e.g.) "host/foo.example.com" for host-based
services, and "ldap/dc.example.com/example.com" for an ldap server for
the "example.com" domain running on "dc.example.com".

> -----Original Message-----
> From: Nicolas Williams [mailto:[email-masked]]
> Sent: Thursday, October 21, 2004 12:46 PM
> To: Liqiang(Larry) Zhu
> Cc: [email-masked]; Paul Leach
> 
> The application still requires changing though, to use the new name
type
> OID.  Or is there something about the SSPI that obviates the need for
> name type OIDs?
> 
> Anyways, I don't feel strongly about this one way or the other.
> 
> Nico
> --

_______________________________________________
Kitten mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/kitten

---

From: Nicolas Williams <[email-masked]>
Date: Thu, 21 Oct 2004 14:36:03 -0500

> As far as I can tell, that means that a new name type isn't needed.

Correct.