Subject: [kitten] GSS_GetMIC and iovs

From: "Matt W. Benjamin" <[email-masked]>
Date: Wed, 28 Aug 2013 15:31:57 -0400 (EDT)

Hi,

Apologies in advance if I'm sending to the wrong list.  This seemed like the right place to reach
the appropriate folks.

I'm interested in making use of the iov interfaces now provided in the MIT and Heimdal GSSAPIs.
The client code is implementing RPCSEC_GSS.

>From what I can make out, the gss_wrap_iov calls provide the acceptable behavior for my intended replacement of
gss_wrap, but there don't seem to be equivalent/finished/exposed iov implementations of gss_getmic.  Naturally, I
have basically the same input buffer requirements in producing checksums as for wrapped data.

Suggestions?

Matt

-- 
Matt Benjamin
The Linux Box
206 South Fifth Ave. Suite 150
Ann Arbor, MI  48104

http://linuxbox.com

tel.  734-761-4689 
fax.  734-769-8938 
cel.  734-216-5309

---

From: Luke Howard <[email-masked]>
Date: Thu, 29 Aug 2013 08:03:17 +1000

Unfortunately this interface doesn't exist.

I suppose it could be hacked on (obviously the implementation would need to be upgraded) without introducing a new API, by adding a flag to the trailer buffer (e.g. GSS_IOV_BUFFER_FLAG_MIC_TOKEN). But maybe a new API would be cleaner.

-- Luke

On 29/08/2013, at 5:31 AM, Matt W. Benjamin <[email-masked]> wrote:

> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten

--
Luke Howard / [email-masked]
www.padl.com / www.lukehoward.com