Subject: Re: [kitten] WGLC of draft-ietf-kitten-gss-loop-01

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 2 Dec 2014 21:57:10 -0500 (EST)

Please note that there are only a few days remaining in this WGLC.
It would be very good to hear from more WG participants.

-Ben

On Fri, 21 Nov 2014, ⌘ Matt Miller wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA512
>
> This message begins the second Working Group Last Call (WGLC) of
> "Structure of the GSS Negotiation Loop" <
> draft-ietf-kitten-gss-loop-01 >.  WGLC will end in two weeks, on
> December 5.  The draft is available at:
>
> http://tools.ietf.org/html/draft-ietf-kitten-gss-loop-01
>
> Because the changes between -00 and -01 are substantial, the Chairs
> decided to issue a second last call.
>
> Please review the document and send comments to the Working Group
> mailing list < kitten at itef.org > or the co-chairs < kitten-chairs
> at tools.ietf.org > before the end of the WGLC.  Any and all comments
> on the document are sought in order to access the strength of
> consensus.  Even if you have read and commented on this or earlier
> versions of the draft, please feel free to comment again.  This is
> particularly important if you found issues with the previous version.
>
> As a reminder, comments can be anything from "this looks fine" to
> "this is a horrible idea"; they can include suggestions for minor
> editorial corrections to significant editorial changes.
>
>
> - - Your Kitten Chairs
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.22 (Darwin)
> Comment: GPGTools - https://gpgtools.org
>
> iQEcBAEBCgAGBQJUb148AAoJEDWi+S0W7cO1MCAH/RoRKAhl1rdDuAbpI7OWoomY
> chsxeJ5xY/Cymjpws5uZQmq1pSgsz0hv2kw9Gv6Y/4hJKi1fH3xAHAZMrIBNdG10
> WiUqOC7+kzphgjveo/jpMusFtrcHSKc3r5Dj413xOOpqfNUfSo2XUBBT4fea7iZF
> vALaGdH/9u78rwFAo3cSIojUgj/rJoU7uI1/oat+tek/v04wOIxpmY5QNphXbsBW
> YAIdunilGkVTjEqZqhawgEZF8nLQHmHTKsyN5NqJk0jpPC3ljc5gXwAzMaJCne1V
> 9g/Ng5RFYWMNM7EgSel3prenY3QYw5uTydi42YksOFIHtTq3qpTVYS71sCHh62Q=
> =/6Sj
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten
>

---

From: Greg Hudson <[email-masked]>
Date: Thu, 04 Dec 2014 14:45:45 -0500

I found one minor substantive concern:

* In the example code, check_authz should operate on a gss_name_t, not
a pointer to a gss_name_t.

I also found some editorial nits:

* intiator -> initiator (twice, in sections 3.3 and 4.3)

* GSS_Accpet_sec_context -> GSS_Accept_sec_context (section 4.1)

* token, for new... -> token for new... (section 4.3)

* while(!acceptor_established) -> while (!acceptor_established)
  (also in the comment at the end of that loop)

* In section 6, "An application using the GSS-API requests that
certain features (...), but" is either missing a clause or contains an
extra "that".

* In section 6, "In many cases it is convenient for GSS acceptors to
accept security context..." should either use an article or pluralize
"context".

---

From: ⌘ Matt Miller <[email-masked]>
Date: Fri, 5 Dec 2014 10:44:18 -0700

A reminder that today is the last day of the Working Group Last Call
on draft-ietf-kitten-gss-loop-01.  So far we have heard from Nico,
Greg, and the author.  If you have any comments, now is your last chance!

Thanks,

- - Your Kitten Chairs

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 5 Dec 2014 18:13:57 -0500 (EST)

Hi Greg,

Thanks for the review.  I agree with all the changes/comments, and will
address them in the next version.

-Ben

---

From: ⌘ Matt Miller <[email-masked]>
Date: Thu, 18 Dec 2014 15:09:28 -0700

Hello all,

The Working Group Last Call of draft-ietf-kitten-gss-loop-01 completed
on Friday, 12 December.  The Chairs and Editor believe all comments have
been addressed in the latest version < draft-ietf-kitten-gss-loop-02
> .  The Chairs will be requesting IESG publication soon.

Thanks to all for the feedback.

- - Your kitten chairs