Subject: Re: [kitten] draft-ietf-krb-wg-pkinit-alg-agility-07 Re: now that I've volunteered....

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 1 Apr 2015 12:30:34 -0400 (EDT)

On Tue, 31 Mar 2015, Tom Yu wrote:

> Here are the KDF OID related changes that I think should happen to the
> algorithm agility draft.
>
> Change the Appendix A ASN.1 module IMPORTS subclause that mentions
> PK-INIT-SPEC from
>
>       PKAuthenticator, DHNonce
>           FROM KerberosV5-PK-INIT-SPEC {
>             iso(1) identified-organization(3) dod(6) internet(1)
>             security(5) kerberosV5(2) modules(4) pkinit(5) };
>             -- as defined in RFC 4556.
>
> to
>
>       PKAuthenticator, DHNonce, id-pkinit
>           FROM KerberosV5-PK-INIT-SPEC {
>             iso(1) identified-organization(3) dod(6) internet(1)
>             security(5) kerberosV5(2) modules(4) pkinit(5) };
>             -- as defined in RFC 4556.
>
> (This adds id-pkinit to the imports).
>
> Change the OID list in Section 6 from
>
>    id-pkinit-kdf OBJECT IDENTIFIER           ::= { id-pkinit 6 }
>        -- PKINIT KDFs
>    id-pkinit-kdf-ah-sha1 OBJECT IDENTIFIER   ::= { id-pkinit-kdf 1 }
>        -- SP800 56A ASN.1 structured hash based KDF using SHA-1
>    id-pkinit-kdf-ah-sha256 OBJECT IDENTIFIER ::= { id-pkinit-kdf 2 }
>        -- SP800 56A ASN.1 structured hash based KDF using SHA-256
>    id-pkinit-kdf-ah-sha512 OBJECT IDENTIFIER ::= { id-pkinit-kdf 3 }
>        -- SP800 56A ASN.1 structured hash based KDF using SHA-512
>    id-pkinit-kdf-ah-sha384 OBJECT IDENTIFIER ::= { id-pkinit-kdf 4 }
>        -- SP800 56A ASN.1 structured hash based KDF using SHA-384
>
> to
>
>    id-pkinit-kdf OBJECT IDENTIFIER      ::= { id-pkinit kdf(6) }
>         -- PKINIT KDFs
>
>    id-pkinit-kdf-ah-sha1 OBJECT IDENTIFIER
>         ::= { id-pkinit-kdf sha1(1) }
>         -- SP800-56A ASN.1 structured hash based KDF using SHA-1
>
>    id-pkinit-kdf-ah-sha256 OBJECT IDENTIFIER
>         ::= { id-pkinit-kdf sha256(2) }
>         -- SP800-56A ASN.1 structured hash based KDF using SHA-256
>
>    id-pkinit-kdf-ah-sha512 OBJECT IDENTIFIER
>         ::= { id-pkinit-kdf sha512(3) }
>         -- SP800-56A ASN.1 structured hash based KDF using SHA-512
>
>    id-pkinit-kdf-ah-sha384 OBJECT IDENTIFIER
>         ::= { id-pkinit-kdf sha384(4) }
>         -- SP800-56A ASN.1 structured hash based KDF using SHA-384
>
> and also duplicate that in the Appendix A ASN.1 module.  Inserting it
> right after the IMPORTS clause might be a good place.
>
> We can debate whether the component identifiers for the KDF OIDs should
> be just <hashname> or ah-<hashname>.
>
> We might also want to duplicate the id-pkinit definition from RFC 4556
> in Section 6 (but not the Appendix A ASN.1 module), to make the full OID
> easier for a casual reader to derive.
>
> Any comments?

These look generally good.

I don't presently have an opinion on <hashname> vs. ah-<hashname>, and
would support the duplication of id-pkinit in section 6 (but not Appendix
A).

Thanks for putting this together.

-Ben

---

From: Nico Williams <[email-masked]>
Date: Wed, 1 Apr 2015 11:43:00 -0500

On Tue, Mar 31, 2015 at 5:07 PM, Tom Yu <[email-masked]> wrote:
> Nico Williams <[email-masked]> writes:
>> On Tue, Mar 31, 2015 at 4:36 PM, Tom Yu <[email-masked]> wrote:
>> I don't think that would be a breaking change, though in general OID
>> naming changes could be.  The safe way to do this would be to leave
>> compatibility values behind:
>>
>> id-pkinit-kdf-sha384 OBJECT IDENTIFIER ::= id-pkinit-kdf-ah-sha384
>>
>> But I don't care.
>
> I was intending to indicate, e.g., { id-pkinit-kdf sha384(4) } vs
> { id-pkinit-kdf ah-sha384(4) } , not the reference identifiers for the
> entire OIDs (id-pkinit-kdf-ah-sha384 vs id-pkinit-kdf-sha384).

What's the difference?  But I don't care anyways.  It's just a
non-breaking symbol change.

---

From: Bill Mills <[email-masked]>
Date: Wed, 1 Apr 2015 22:19:04 +0000 (UTC)

Suggested changes updated to https://github.com/sweetums/idrafts
Still one open question on "I don't presently have an opinion on <hashname> vs. ah-<hashname>..." 

     On Wednesday, April 1, 2015 9:43 AM, Nico Williams <[email-masked]> wrote:

---

From: Nico Williams <[email-masked]>
Date: Wed, 1 Apr 2015 17:47:44 -0500

> Still one open question on "I don't presently have an opinion on <hashname>

You may flip a coin as to that one.  It doesn't matter.  If in doubt,
leave it as in the original.

Nico
--

---

From: Bill Mills <[email-masked]>
Date: Thu, 2 Apr 2015 00:31:07 +0000 (UTC)

inertia wins.... 

     On Wednesday, April 1, 2015 3:47 PM, Nico Williams <[email-masked]> wrote:

Nico
--

---

From: Bill Mills <[email-masked]>
Date: Thu, 2 Apr 2015 04:27:58 +0000 (UTC)

Any reason not to publish -08 on this? 

     On Wednesday, April 1, 2015 5:31 PM, Bill Mills <[email-masked]> wrote:

 inertia wins.... 

Nico
--

_______________________________________________
Kitten mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/kitten

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 2 Apr 2015 11:25:17 -0400 (EDT)

> Still one open question on "I don't presently have an opinion on <hashname> vs. ah-<hashname>..." 

Please go ahead and submit, as draft-ietf-kitten-pkinit-alg-agility-00 --
we have been requested to move documents into the kitten namespace which
we are pulling in from the krb-wg.

Thanks,

Ben