Subject: [kitten] Review of draft-ietf-kitten-tls-channel-bindings-for-tls13-01

From: Nico Williams <[email-masked]>
Date: Fri, 26 Feb 2021 15:04:02 -0600

I have reviewed draft-ietf-kitten-tls-channel-bindings-for-tls13-01.

My only comment, besides a thank you, is this:

 - Section 1, first sentence
   
   | The channel binding types defined in [RFC5929] were found to be
   | vulnerable to the "triple handshake vulnerability" ...

   I believe that's specifically about tls-unique and
   tls-unique-for-telnet, but not tls-server-end-point.

   A slight rephrasing would be useful, as there is no need to give the
   wrong impression about tls-server-end-point.

Thanks,

Nico
--

---

From: "Sam Whited" <[email-masked]>
Date: Fri, 26 Feb 2021 16:15:00 -0500

Thank you; would something as simple as "Some of the channel binding
types defined in…" work for you?

—Sam

On Fri, Feb 26, 2021, at 16:04, Nico Williams wrote:
>    I believe that's specifically about tls-unique and tls-unique-for-
>    telnet, but not tls-server-end-point.
>
>    A slight rephrasing would be useful, as there is no need to give
>    the wrong impression about tls-server-end-point.
>
> Thanks,
>
> Nico
> --
>
> _______________________________________________
> Kitten mailing list [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten
>

-- 
Sam Whited

---

From: "Sam Whited" <[email-masked]>
Date: Fri, 26 Feb 2021 16:16:35 -0500

Or possibly "The 'unique' channel binding types…"

—Sam