Subject: [kitten] Comments on draft-ietf-kitten-password-storage-03

From: [email-masked]
Date: Thu, 11 Mar 2021 10:57:49 -0600 (CST)

For the output lengths, pick a number between 16 and 32 bytes and stick with that. I'd suggest 16, 24, or 32 but it doesn't really matter.

** Argon2 and scrypt **
Just say "[pick a number] Bytes or default" with [pick a number] being what ever you picked.

** bcrypt **
bcrypt is not a KDF. So you can't pick an output length. Thus "Output length: x (internal hash function output length)" should be removed as it does not make sense.

** PBKDF2 **
PBKDF2 should never output more than "hLen (length of the chosen hash)" for password hashing. So this should be "Which ever is smaller [pick a number] Bytes or hLen (length of the chosen hash)" with [pick a number] being what ever you picked.

---

From: "Sam Whited" <[email-masked]>
Date: Fri, 12 Mar 2021 14:11:38 -0500

Sorry, I think you brought this up before and I must have left it out of
the changes. I've made these changes and will fix it the next time I
upload a revision.

—Sam

On Thu, Mar 11, 2021, at 11:57, [email-masked] wrote:
> For the output lengths, pick a number between 16 and 32 bytes
> and stick with that. I'd suggest 16, 24, or 32 but it doesn't
> really matter.
>
> ** Argon2 and scrypt ** Just say "[pick a number] Bytes or default"
> with [pick a number] being what ever you picked.
>
> ** bcrypt ** bcrypt is not a KDF. So you can't pick an output length.
> Thus "Output length: x (internal hash function output length)" should
> be removed as it does not make sense.
>
> ** PBKDF2 ** PBKDF2 should never output more than "hLen (length of the
> chosen hash)" for password hashing. So this should be "Which ever is
> smaller [pick a number] Bytes or hLen (length of the chosen hash)"
> with [pick a number] being what ever you picked.
>
> _______________________________________________
> Kitten mailing list [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten
>

-- 
Sam Whited