Subject: [kitten] Internet Draft: Realm Crossover for SASL

From: Rick van Rein <[email-masked]>
Date: Tue, 1 Feb 2022 08:50:04 +0000

Hello Kitten,

I would like to ask your feedback on this specification:

 - Represent SASL in AVPs for Diameter
 - Construct end-to-end encryption tunnels in SASL
 - Combine this to use a client IdP to login on a foreign server
 - Foreign server do not need accounts to authenticate a client

The use of Channel Binding is uncommon, but AFAIK it is secure.

I am least certain about the formulation of the GSS-API mapping.

I plan to propose this as Independent proposal, unless you think
it could be a WG document.

FYI, we will soon be offering a SASL embedding into HTTP.

Your feedback is welcome!

Thanks,

Rick van Rein
Henri Manson

----- Forwarded message from [email-masked] -----

Date: Fri, 28 Jan 2022 11:43:38 -0800
From: [email-masked]
Subject: New Version Notification for draft-vanrein-diameter-sasl-06.txt

A new version of I-D, draft-vanrein-diameter-sasl-06.txt
has been successfully submitted by Rick van Rein and posted to the
IETF repository.

Name:		draft-vanrein-diameter-sasl
Revision:	06
Title:		Realm Crossover for SASL and GSS-API via Diameter
Document date:	2022-01-28
Group:		Individual Submission
Pages:		23
URL:            https://www.ietf.org/archive/id/draft-vanrein-diameter-sasl-06.txt
Status:         https://datatracker.ietf.org/doc/draft-vanrein-diameter-sasl/
Htmlized:       https://datatracker.ietf.org/doc/html/draft-vanrein-diameter-sasl
Diff:           https://www.ietf.org/rfcdiff?url2=draft-vanrein-diameter-sasl-06

Abstract:
   SASL and GSS-API are used for authentication in many application
   protocols.  This specification extends them to allow credentials of
   an identity domain to be used against external services.  To this
   end, it introduces end-to-end encryption for SASL that is safe to
   relay through a foreign server.

The IETF Secretariat

----- End forwarded message -----

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 1 Feb 2022 09:45:53 +0000

Hi Rick/Henri,

> it could be a WG document.

Pretty much all documents start as independent (non WG) drafts. It is 
much easier to discuss an idea if it has a detailed description in the 
form of a draft. If your draft gets enough interest at a later date, it 
can be adopted by the WG.

I am sure you will get feedback on the mailing list about GSS-API mapping.

Best Regards,

Alexey

> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten