Subject: RE: UTF-8, ASN.1, and our past sins

From: "Paul Leach" <[email-masked]>
Date: Mon, 19 Nov 2001 16:53:04 -0800

As far as I understand it, the tools are still usable, but with care --
is that not the case? I was thinking of putting that in my "proposed
wording", but was afraid that might be too far from being correct, and I
didn't want too many incorrectnesses from getting in the way of the
basic idea.

> -----Original Message-----
> From: Clifford Neuman [mailto:[email-masked]] 
> Sent: Monday, November 19, 2001 4:46 PM
> To: Paul Leach
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Subject: Re: UTF-8, ASN.1, and our past sins
> 
> 
> I like the idea, but want to hear what Tom has to say.  One 
> of the issues with ASN.1 compatability is to simplify life 
> for those that are using ASN.1 development tools and this 
> might not address that problem.  But the points that you make 
> are correct.  
> 
> Cliff
>

---

From: "Paul Leach" <[email-masked]>
Date: Tue, 20 Nov 2001 09:52:34 -0800

> From: Martin Rex [mailto:[email-masked]] 
> Sent: Tuesday, November 20, 2001 9:26 AM
> To: Paul Leach
> Cc: [email-masked]
> I can't believe what I read here...
> 
> When I complained about the extensive and unnecessary use of ASN.1
> in Microsofts various protocol proposals (password change, IAKERB,
> requiring SPNEGO for HTTP-with GSS-API authentication) you always
> pointed to commercially available ASN.1 parsers.
> 
> Now you suggest to use custom ASN.1 just to legalize your own
> abuse of ASN.1...

None of what I suggested would have any affect on the ability to use a
commercial ASN.1 parser. Nor did I intend that it would.

Paul