Subject: Re: INTEGER

From: Simon Josefsson <[email-masked]>
Date: Fri, 12 Sep 2003 19:36:26 +0200

Could these two INTEGER be replaced by Int32 and UInt32, respectively?
Then an implementation need not worry about bignum.

>    TYPED-DATA      ::= SEQUENCE SIZE (1..MAX) OF SEQUENCE {
>            data-type       [0] INTEGER,
>            data-value      [1] OCTET STRING OPTIONAL
>    }
>
>    AD-AND-OR               ::= SEQUENCE {
>            condition-count [0] INTEGER,
>            elements        [1] AuthorizationData
>    }

---

From: Nicolas Williams <[email-masked]>
Date: Fri, 12 Sep 2003 10:52:38 -0700

These could be fixed in the author's 48 hours period.  But this should
be fixed.

---

From: Tom Yu <[email-masked]>
Date: Fri, 12 Sep 2003 16:24:02 -0400

>>>>> "Nico" == Nicolas Williams <[email-masked]> writes:

>> Then an implementation need not worry about bignum.

[...]

Nico> These could be fixed in the author's 48 hours period.  But this should
Nico> be fixed.

Agreed, especially after we went to some effort to avoid unconstrained
INTEGER types.