Subject: WG last call summary of comments and changes to gssapi-cfx-04.txt

From: "Liqiang(Larry) Zhu" <[email-masked]>
Date: Tue, 16 Dec 2003 21:05:19 -0800

For
http://www.ietf.org/internet-drafts/draft-ietf-krb-wg-gssapi-cfx-04.txt,
the last call started on 11/26/2003 and ended on 12/15/2003.

Comments received:
   
   11/27/2003 section 4.1.1.1 - Simon Josefsson [[email-masked]]  
        
        Should additional context flag values allowed to be set: 
        GSS_C_ANON_FLAG, GSS_C_PROT_READY_FLAG, GSS_C_TRANS_FLAG 
        
        Editorial issues and IANA considerations.

   12/1/2003 section 5.1.1 - Wyllys Ingersoll [[email-masked]]
  
        Nit on _KRB5_ naming

   12/2/2003 section 4.2 - Sam Hartman [[email-masked]]
      
       Adding text to describe the case when channel bindings are not
used 
       by the acceptor

   12/2/2003 section 4.2.6.1 - Sam Hartman [[email-masked]]
 
       MIC token checksum operation needs clarification

   12/2/2003 section 7 - Sam Hartman [[email-masked]]

       Comments on the security consideration section

   12/2/2003 section 4.1.1 - Douglas E. Engert [[email-masked]]
   
       The Dlgth field in the checksum is only two bytes long

   12/2/2003 section 9 - Ken Raeburn [[email-masked]]
    
       Moving [AES-KRB5] to informative references

   12/2/2003 section 5.2 - Douglas E. Engert [[email-masked]]

       16k buffer size, the GSS-API does not impose any restriction on
the 
       length
   
   12/2/2003 section 4.1.1 - Douglas E. Engert [[email-masked]]

        Can buffer size information be negotiated? How negotiation is
done

   12/2/2003 Section 4.2.4 - Ken Raeburn [[email-masked]]

        Trailing octets produced by the encrypt/decrypt sequence

   12/2/2003 section 7  - Nicolas Williams [[email-masked]]

        Channels binding in security considerations

   12/3/2003 section 7 - Sam Hartman [[email-masked]]

        Do we want to require that the minimal padding be used?

   12/3/2003 section 5.2 - Martin Rex [[email-masked]]

        must support 16 KB, should support 64 KB and may support larger

        sizes

   12/3/2003 section 4.2.5 - Sam Hartman [[email-masked]]
  
        Adding "including rotation counts greater than the length of the

        token." for RRC field

   12/4/2003 section 5.2 - Martin Rex [[email-masked]]
  
        gss_wrap_size_limit() is a local decision (regarding to non

        deterministic cfx padding)

   12/15/2003 section 4.2.5 - Sam Hartman [[email-masked]]
   
        Extensibility and GSSAPI-CFX

   12/15/2003 section 4.1.1 - Nicolas Williams
[[email-masked]]

        Extensions field and reserve one flag bit for future extensions

   12/15/2003 section 4.1 - Nicolas Williams [[email-masked]]
      
        Remove the last paragraph of section 4.1

   12/16/2003 section 4.1.1 - Nicolas Williams
[[email-masked]]
      
       Reserve flags for the DCE style and anything else that is MS-
       specific.

Changes:

  Section  What is changed
  -----------------------------------
  4.1.1.1  checksum flags field, changed to reserve bit 12 through 19 
           Inclusive, to cover the DCE_STYLE flag, etc

  4.1.1.2  added the channel binding paragraph Sam posted on 12/2/2003 
  
  4.2.4    added clarification for "crypto garages" and removed "next"
size
  
  4.2.5    added "including rotation counts greater than the length of
the 
           token."

  4.2.6.1  changed to checksum the header last for MIC tokens
 
  5.2      buffer size support: "16k MUST, 64k SHOULD, larger MAY"

  7        added security consideration for channel bindings (new text 
           posted to the list)
  
  9        moved AES-KRB5 into informative references

Additional notes: 
 
  We are discussing with the chairs if we should add "extensions" to
checksum 0x8003 without delaying this draft. If we do add the extensions
field, we will drop the last paragraph of section 4.1.

Thx, Larry

-----Original Message-----
From: Douglas E. Engert [mailto:[email-masked]] 
Sent: Tuesday, December 16, 2003 7:07 AM
To: Liqiang(Larry) Zhu
Cc: Nicolas Williams; Sam Hartman; Kerberos WG; JK Jaganathan
Subject: Re: gssapi-cfx-04.txt section 4.1.1 question

"Liqiang(Larry) Zhu" wrote:
> 
> Doug, where do you stand now for having the upper limit of 64k for the
> delegation credential message?

If you feel that this length is adequate for the near term, i.e. till
and extended CFX is available, then a 64K limit is OK with me. Its your
company that is creating the very large tickets. 
 
I do like Nico's suggestion of reserving a bit in the flags specifically

for future extensions. This would appear to not require any code
changes,
just reserve it now.  

> 
> Larry
> 
> -----Original Message-----
> From: Nicolas Williams [mailto:[email-masked]]
> Sent: Monday, December 15, 2003 9:01 PM
> To: Sam Hartman
> Cc: Liqiang(Larry) Zhu; Douglas E. Engert; Kerberos WG; JK Jaganathan
> Subject: Re: gssapi-cfx-04.txt section 4.1.1 question
> 
> On Mon, Dec 15, 2003 at 02:08:42PM -0500, Sam Hartman wrote:
> > >>>>> "Liqiang(Larry)" == Liqiang(Larry) Zhu
> <[email-masked]> writes:
> >
> >     Liqiang(Larry)> Is the consensus to use 4 bytes to encode Dlgth,
> >     Liqiang(Larry)> but do we need to change the checksum type, say
> >     Liqiang(Larry)> change it to 0x8004, in that case? It does make
> >     Liqiang(Larry)> sense to me if we end up changing the encoding
> >     Liqiang(Larry)> and/or the content of the GSS authenticator
> >     Liqiang(Larry)> checksum.
> >
> > I thought you objected to changing the initial context tokens
because
> that prevents you from negotiating up.
> 
> If Larry's objection to changing the initial context tokens stands
then
> we should go back to a two-octet delegated credential field.
> 
> Nico
> --

-- 

 Douglas E. Engert  <[email-masked]>
 Argonne National Laboratory
 9700 South Cass Avenue
 Argonne, Illinois  60439 
 (630) 252-5444

---

From: "Douglas E. Engert" <[email-masked]>
Date: Wed, 17 Dec 2003 09:34:21 -0600

Larry, looks good, but needs the comments from the 4.1.1 notes that 
you and Nico worked out. Please add and send again. At that time
I will forward it on to the list, (as there are still some sites that 
have the hop-count set to low, and don't get your posts.) 

For the members of the list, please look at the changes Larry has listed 
and see if you disagree with any of these.

--

---

From: Sam Hartman <[email-masked]>
Date: Wed, 17 Dec 2003 13:51:33 -0500

I'd just like to speak up in favor of adding the extensions stuff
Nico, Ken and Larry worked out; it improves the protocol
significantly.  I'd like to see this added without another last call.

I specifically do not object to the draft going forward with the older
extensions language based on token_id unknown errors but prefer the
new mechanism.

---

From: "Douglas E. Engert" <[email-masked]>
Date: Wed, 17 Dec 2003 16:01:30 -0600

> significantly.  I'd like to see this added without another last call.

That is OK with me. I would like to hear if any WG members have any 
negative comments. 

--