Subject: pkinit + oid ?

From: Love <[email-masked]>
Date: Wed, 21 Apr 2004 15:58:37 +0200

Why is there is list of enctypes mapping in kinit. Why is just a field in
the pa-data req with SEQ of oids added ?

Its current out of sync, and only lists des3, what if I want to use AES ? I
should have to go though iana (in the future) to register a number that
maps to a oid that is already reserved ?

Love

---

From: Sam Hartman <[email-masked]>
Date: Wed, 21 Apr 2004 18:44:35 -0400

>>>>> "Love" == Love  <[email-masked]> writes:

    Love> Why is there is list of enctypes mapping in kinit. Why is just a field in
    Love> the pa-data req with SEQ of oids added ?

I thought we were adding a field to the choice for new enctypes but
were accepting the des3 enctypes for interoperability with deployed
implementations.

Am I confused about our decision?