Subject: RE: pk-init22 part 1

From: "Liqiang(Larry) Zhu" <[email-masked]>
Date: Mon, 24 Jan 2005 10:23:47 -0800

I agree with Love too. PKIX type Name should be wrapped.
SubjectPublicKeyInfo and AlgorithmIdentifier do not have to be.

-- larry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Nicolas
Williams
Sent: Sunday, January 23, 2005 9:23 PM
To: Jeffrey Hutzelman
Cc: Love; [email-masked]
Subject: Re: pk-init22 part 1

On Sun, Jan 23, 2005 at 08:46:48PM -0500, Jeffrey Hutzelman wrote:
> On Sat, 8 Jan 2005, Love wrote:
> 
> > SubjectPublicKeyInfo and AlgorithmIdentifier is quite simple types 
> > and might/will be processed by the pkinit implementation itself. So 
> > I think they don't need to be wrapped.
> 
> I've seen two comments in favor of this position, and none opposed.
> So unless there is more, these will be left unchanged.
> 
> 
> > Name on the other hand is quite a complex type, and will need to be 
> > processed by the CMS/X509 library, so it would probably be good if 
> > it was not parsed directly in the by the pk-init decoder.
> 
> Anyone care to comment on this?  We need to make a decision before 
> this document can progress.

I think Love's right -- Name is sufficiently complex that re-encoding
could be a big pain.

---

From: Brian Tung <[email-masked]>
Date: Mon, 24 Jan 2005 11:10:48 -0800

> SubjectPublicKeyInfo and AlgorithmIdentifier do not have to be.

Me too. :-o

Brian Tung <[email-masked]>

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Mon, 24 Jan 2005 15:26:19 -0500

>> SubjectPublicKeyInfo and AlgorithmIdentifier do not have to be.

OK; that's easy then.