Subject: other implementation of gss_pseudo_random

From: Love Hörnquist Åstrand <[email-masked]>
Date: Sat, 9 Jun 2007 20:48:24 -0400

Hello,

Since gss_pseudo_random for Kerberos V (rfc4402) lacks test vectors  
are there other
implemetations of it that I can do interrop testing with ?

Heimdal have the code living in svn trunk (see htto://www.h5l.se/).

Love

---

From: Sam Hartman <[email-masked]>
Date: Fri, 15 Jun 2007 20:35:03 -0400

>>>>> "Love" == Love Hörnquist Åstrand <[email-masked]> writes:

    Love> Hello,
    Love> Since gss_pseudo_random for Kerberos V (rfc4402) lacks test vectors
    Love> are there other
    Love> implemetations of it that I can do interrop testing with ?

MIT has the 3961 PRF, but not currently the gss parts.

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Sat, 16 Jun 2007 15:37:46 -0700

> MIT has the 3961 PRF, but not currently the gss parts.

That doesn't help me, does it ? rfc3961 have test vectors, rfc4402  
doesn't.

Love

---

From: Love Hörnquist Åstrand <[email-masked]>
Date: Mon, 18 Jun 2007 18:07:51 +0200

>     Love> That doesn't help me, does it ? rfc3961 have test vectors,
>
> 3961 doesn't have test vectors either.

You are correct, I tested with MIT implementation.

Love