Subject: [Ietf-krb-wg] Pin-required and pin-not-required OTP flag names

From: <[email-masked]>
Date: Thu, 27 Jan 2011 10:46:52 -0500

I was discussing the OTP PIN prompt issue off list and the names of the "pin-required" and "pin-not-required" flags were found to be very confusing and I was asked to pass on a request that the names be changed.

These flags control whether or not the Kerberos client should collect the PIN not whether a PIN is required to generate the OTP value.  For example, pin-pad tokens require a PIN for the OTP generation but it is collected by the token itself, not by the Kerberos client.

The suggested new names were "collect-pin" and "do-not-collect-pin"

--Gareth
_______________________________________________
ietf-krb-wg mailing list
[email-masked]
https://lists.anl.gov/mailman/listinfo/ietf-krb-wg

---

From: Simon Josefsson <[email-masked]>
Date: Thu, 27 Jan 2011 16:56:03 +0100

> The suggested new names were "collect-pin" and "do-not-collect-pin"

+1

/Simon