Subject: [L1vpn] BGP Traffic Engineering attribute

From: Yakov Rekhter <[email-masked]>
Date: Tue, 18 Jul 2006 06:48:16 -0700

Folks,

As I promised at the L1VPN WG meeting last week, here is the Internet
Draft that defines a BGP attribute that could be used to carry
(G)MPLS Traffic Engineering information. One possible application
of this attribute is L1VPN.

Comments/review are appreciated (as usual).

Yakov.
------- Forwarded Message

Date:    Mon, 17 Jul 2006 15:50:01 -0400
From:    [email-masked]
To:      [email-masked]
cc:      
Subject: I-D ACTION:draft-fedyk-bgp-te-attribute-00.txt 

- --NextPart

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title		: Traffic Engineering Attribute
	Author(s)	: D. Fedyk, et al.
	Filename	: draft-fedyk-bgp-te-attribute-00.txt
	Pages		: 
	Date		: 2006-7-17
	
   This document defines a new BGP attribute, Traffic Engineering
   attribute, than enables BGP to carry Traffic Engineering information

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-fedyk-bgp-te-attribute-00.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the mess
age.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-fedyk-bgp-te-attribute-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-fedyk-bgp-te-attribute-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

- --NextPart
Content-Type: Multipart/Alternative; Boundary="OtherAccess"

- --OtherAccess
Content-Type: Message/External-body; access-type="mail-server";
	server="[email-masked]"

Content-Type: text/plain
Content-ID: <[email-masked]>

ENCODING mime
FILE /internet-drafts/draft-fedyk-bgp-te-attribute-00.txt

- --OtherAccess
Content-Type: Message/External-body;
	name="draft-fedyk-bgp-te-attribute-00.txt"; site="ftp.ietf.org";
	access-type="anon-ftp"; directory="internet-drafts"

Content-Type: text/plain
Content-ID: <[email-masked]>

- --OtherAccess--

- --NextPart
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/i-d-announce

- --NextPart--

------- End of Forwarded Message

_______________________________________________
L1vpn mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l1vpn

---

From: "Igor Bryskin" <[email-masked]>
Date: Tue, 18 Jul 2006 10:12:48 -0400

Yakov,

I have a couple of questions.

1. Why do you believe that advertising of just ISCD attribute is sufficient?
How about other TE Link TLV attributes like link protection capability,
SRLGs, colors, TE metric, etc.? Do you think that there is no benefit to
account such attributes of CE-PE links in L1VPN service path computation?

2. What will happen if a new TE Link sub-TLV is introduced (like for
example, Interface Termination/Adaptation Capability Descriptor (ITACD),
which is necessary in multi-layer environments with unified (say, GMPLS)
control plane? Will your draft track all these changes and adjust the BGP TE
advertisings accordingly?

Thanks,
Igor