Subject: [L1vpn] Your Discusses and Comments on draft-ietf-l1vpn-bgp-auto-discovery-04.txt

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 14 May 2008 19:17:17 +0100

Hi,

The editor has made a new version of this draft based on your issues and the 
subsequent email exchanges.

> http://www.ietf.org/internet-drafts/draft-ietf-l1vpn-bgp-auto-discovery-05.txt

We hope that the changes (summarised below alongside your coments) address 
your points and you can clear your Discusses.

Thanks,
Adrian

===
> Pasi Eronen:
>
> Discuss [2008-05-05]:
> Process comment: Sandy Murphy's SecDir review needs a response.
>
> As noted in Sandy Murphy's SecDir review, this document seems to
> expand the L1VPN concept significantly beyond the scope of RFC 4847
> and draft-ietf-l1vpn-applicability-basic-mode, both of which
> explicitly rule out inter-as/inter-provider L1VPNs.  Expanding the
> scope of inter-AS/inter-provider VPNs makes the assumption about
> transitive trust of all BGP speakers rather dubious.

The I-D has been updated to make clear that inter-AS/inter-provider are out 
of scope. The following paragraph has been added to the end of Section 2.

   Although multi-AS L1VPNs are currently out of scope for the Basic
   Mode, the mechanisms defined in this document appear to be easily
   applicable to a multi-AS scenario should such a need arise in the
   future. At that time additional work may be required to examine
   various aspects including security.

===
> Pasi Eronen:
>
> Comment [2008-05-05]:
> Sandy's SecDir review also identified a number of places that would
> benefit from some clarification of the text, and provided editorial
> comments that should be taken into acccount.

We believe these have been picked up, discussed with Sandy as necessary, and 
fixed in the new I-D.

===
> Tim Polk:
>
> Comment [2008-05-08]:
> Sandy Murphy has asked what happens if the basic security assumption
> does not hold.
>
> Given the importance of the basic trust assumption - all the participants
> are trustworthy, and trust is transitive - it would also be nice if the
> security considerations noted *why* the wg feels this is a reasonable
> assumption.  (I assume it is based on the fact that all the peers are
> members of the same provider network?)

This is fixed by a simple addition right at the end of Section 6. This 
points out that the restriction of the technique to a single provider 
network means that the trust model is much more applicable.

_______________________________________________
L1vpn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l1vpn

---

From: <[email-masked]>
Date: Fri, 16 May 2008 09:36:24 +0300

Hi Adrian,

I've cleared my discuss.

Best regards,
Pasi 

> -----Original Message-----
> From: ext Adrian Farrel [mailto:[email-masked]] 
> Sent: 14 May, 2008 21:17
> To: [email-masked]; Eronen Pasi (Nokia-NRC/Helsinki); 
> [email-masked]
> Cc: Hamid Ould-Brahim; [email-masked]; [email-masked]
> Subject: Your Discusses and Comments on 
> draft-ietf-l1vpn-bgp-auto-discovery-04.txt
> 
> Hi,
>