Subject: [L2sm] [Editorial Errata Reported] RFC8466 (6555)

From: RFC Errata System <[email-masked]>
Date: Thu, 22 Apr 2021 23:29:11 -0700 (PDT)

The following errata report has been submitted for RFC8466,
"A YANG Data Model for Layer 2 Virtual Private Network (L2VPN) Service Delivery".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6555

--------------------------------------
Type: Editorial
Reported by: Mohamed Boucadair <[email-masked]>

Section: 8

Original Text
-------------
                container vxlan {
                  when "derived-from-or-self(../type, "
                     + "'l2vpn-svc:vxlan')" {
                    description
                      "Only applies when the type of the tagged
                       interface is 'vxlan'.";
                  }
                  if-feature "vxlan";
                  leaf vni-id {
                    type uint32;
                    mandatory true;
                    description
                      "VXLAN Network Identifier (VNI).";
                  }
                  leaf peer-mode {
                    type identityref {
                      base vxlan-peer-mode;
                    }
                    default "static-mode";
                    description
                      "Specifies the VXLAN access mode.  By default,
                       the peer mode is set to 'static-mode'.";
                  }
                  list peer-list {
                    key "peer-ip";
                    leaf peer-ip {
                      type inet:ip-address;
                      description
                        "Peer IP.";
                    }
                    description
                      "List of peer IP addresses.";
                  }
                  description
                    "QinQ.";
                }

Corrected Text
--------------
                container vxlan {
                  when "derived-from-or-self(../type, "
                     + "'l2vpn-svc:vxlan')" {
                    description
                      "Only applies when the type of the tagged
                       interface is 'vxlan'.";
                  }
                  if-feature "vxlan";
                  leaf vni-id {
                    type uint32;
                    mandatory true;
                    description
                      "VXLAN Network Identifier (VNI).";
                  }
                  leaf peer-mode {
                    type identityref {
                      base vxlan-peer-mode;
                    }
                    default "static-mode";
                    description
                      "Specifies the VXLAN access mode.  By default,
                       the peer mode is set to 'static-mode'.";
                  }
                  list peer-list {
                    key "peer-ip";
                    leaf peer-ip {
                      type inet:ip-address;
                      description
                        "Peer IP.";
                    }
                    description
                      "List of peer IP addresses.";
                  }
                  description
                    "Container for VXLAN.";
                }

Notes
-----
The description should refer to VXLAN not QinQ.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8466 (draft-ietf-l2sm-l2vpn-service-model-10)
--------------------------------------
Title               : A YANG Data Model for Layer 2 Virtual Private Network (L2VPN) Service Delivery
Publication Date    : October 2018
Author(s)           : B. Wen, G. Fioccola, Ed., C. Xie, L. Jalil
Category            : PROPOSED STANDARD
Source              : L2VPN Service Model
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 23 Apr 2021 09:33:37 +0100

ADs...

This report is correct.

Best,
Adrian

-----Original Message-----
From: RFC Errata System <[email-masked]> 
Sent: 23 April 2021 07:29
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [Editorial Errata Reported] RFC8466 (6555)

Section: 8

Original Text
-------------
                container vxlan {

Corrected Text
--------------
                container vxlan {

Notes
-----

Instructions:
-------------