Subject: Re[2]: Couple of questions

From: Rohit Verma <[email-masked]>
Date: 24 Mar 2000 00:01:15 -0600

A clarification to Part 2 if the received packet sequence number is 
     less than the highest received sequence number then you ack otherwise 
     you discard it.

     Ns=1 Action=Ack
     Ns=2 Action=Ack
     Ns=4 Action=Ignore
     Ns=3 Action=Ack
     Ns=2 Action=Ack
     
     If u ack Ns=4 then the peer will think that you have acked pkt 3 as 
     well.
     
     Hope this helps
     
     Regards
     Rohit Verma

______________________________ Reply Separator _________________________________
Subject: Re: Couple of questions
Author:  [email-masked] at Internet-USA
Date:    3/23/00 10:18 PM

Greetings,
     
Sabrina Minshall wrote:
>
> 1. When a control packet is received with a bad hdr options but with correct 
>    nr and ns, do we need update our local state?
>
>    I assume we just drop it (even without sending and zlb)? 
>
     
I generally think of the control packet as two layers : delivery & data. 
If it's in the delivery window, I schedule a ZLB and pass it up to the 
data layer. So, yes, update the local state.
     
> 2. When a control packet received is that's within the current window 
>    but is not the next packet in seq (that the FSM is expecting),
>    should a ZLB be sent?
>
     
Yes. Assume that the last ZLB was lost & the host is retransmitting. If 
you don't acknowlege it, you'll never sync back up.

>    Thanks.
>    Sabrina
     
--
Kyle A. York
Subordinate Grunt
CLOB

---

From: Sabrina Minshall <[email-masked]>
Date: Fri, 24 Mar 2000 07:32:26 -0800 (PST)

Thanks for those replies.

  Yet another question.

  A                         B
  SCCRQ        ->           
		(lost) <-           SCCRP

  StopCCN      ->           

  Now the StopCCN, had a tunnel/session id of 0/0. If the AVP's
  in the StopCCN is hidden (Assigned Tunnel Id), there's no way
  B can process it. It's also true in the CDN case where and 
  SCRP is lost and A sends a CDN.

  I guess you just let the tunnel/session created by B for A,
  timeout?

  Am I correct?

  Sabrina

---

From: Barney Wolff <[email-masked]>
Date: Fri, 24 Mar 2000 12:51 EST

No, you know which peer sent you the StopCCN (for example with l2tp/udp
by the IP address of the sender) so you know what the shared secret
is, so you can decode the hidden avp.  Hidden or not, you need a way
to look up the tunnel/session by the peer's id rather than your own,
because you need to handle a retransmitted SCCRQ as well as the StopCCN.
Without that, you're likely to set up two tunnels, and things will
not go well.

The table is a little unusual because you do 1 add and 1 delete per
tunnel/session, but rarely do a lookup.

Barney Wolff  <[email-masked]>

> From: Sabrina Minshall <[email-masked]>
> Date: Fri, 24 Mar 2000 07:32:26 -0800 (PST)
> 
>   A                         B
>   SCCRQ        ->           
> 		(lost) <-           SCCRP
> 
>   StopCCN      ->           
> 
>

---

From: Rohit Verma <[email-masked]>
Date: 24 Mar 2000 13:25:36 -0600

Technically there should be retransmissions because the Control 
     Channel is reliable. If the SCCRP still does not make it then it will 
     hit the max retransmissions limit and timeout.
     
     Regards
     Rohit Verma 

______________________________ Reply Separator _________________________________
Subject: Re: Re[2]: Couple of questions
Author:  [email-masked] at Internet-USA
Date:    3/24/00 11:42 AM

  Yet another question.
     
  A                         B
  SCCRQ        ->
          (lost) <-           SCCRP
     
  StopCCN      ->

     
  Am I correct?

  Sabrina

---

From: Rohit Verma <[email-masked]>
Date: 24 Mar 2000 14:52:19 -0600

Hi Sabrina
        I always like to talk in terms of Call Id and the Tunnel Id. And 
     yes you are right that the Call Id must be 0 in the ZLB.
      A good implementation in my personal opinion should not be too fussy 
     about it.
     
     Regards
     Rohit Verma

______________________________ Reply Separator _________________________________
Subject: Re: Re[4]: Couple of questions
Author:  [email-masked] at Internet-USA
Date:    3/24/00 2:12 PM

Hi Rohit,
     
   Thanks. Should the session id on an ZLB be 0 always?

   Thanks,

   Sabrina