Subject: L2F/L2TP emulators

From: John Narron <[email-masked]>
Date: Wed, 29 Nov 2000 12:09:08 -0600 (CST)

Is there any software (preferrably freeware) available to emulate
LACs and LNSs?  I'd figure there would be to help troubleshoot
tunnels, but I'm not having an easy time finding them.  Any help
would be appreciated.  Thanks.

   - John

---

From: Motonori Shindo <[email-masked]>
Date: Thu, 30 Nov 2000 10:28:39 +0900 (JST)

John,

From: John Narron <[email-masked]>
Subject: L2F/L2TP emulators
Date: Wed, 29 Nov 2000 12:09:08 -0600 (CST)
Message-ID: <[email-masked]>

> would be appreciated.  Thanks.

There's an L2TP (LAC & LNS) implementation available that can be
retrieved via anonymous CVS as follows:

export CVSROOT=:pserver:[email-masked]:/usr/share/cvsroot    (for bash)
cvs login                       (password is anoncvs)
cvs co l2tpd                    (checks out a copy of the l2tpd cvs tree)
cvs update                      (be in the l2tpd directory, updates your
                                 tree)

It hasn't been updated for a long time and there are some bugs but it
works anyway:-) I am not aware of any L2F implementation. Sorry.

Regards,

=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=
 +----+----+     
 |.. .|    |     Motonori Shindo
 |_~__|    |     
 | .. |~~_~|     Sr. Systems Engineer
 | .  |    |     CoSine Communications Inc.
 +----+----+     
 C o S i n e     e-mail:  [email-masked] 
Communications
=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=