Subject: RE: l2TP with dynamic routing.

From: Skip Booth <[email-masked]>
Date: Tue, 21 Nov 2000 11:53:45 -0500 (EST)

On Tue, 21 Nov 2000, Ahmed, Hany wrote:

>
> You are right about using demand-dialing over the tunnel.
>
> The reason I was asking about a new AVP is to determine
> the possibility of the LNS to use RIP/OSPF with the client
> once it finds out about this capability.
>
> If the client doesn't support it, it can be disabled on
> the link all together and save any bandwidth you may use
> for that purpose.

If this is your intention, it would be better to negotiate this within IPCP than
L2TP.  This really shouldn't have anything to do with L2TP.  Especially in
compulsory tunneling where the LAC may not have any knowledge of what options
the client supports.

>
> There was also the indication that with SPAP you can request
> routing as well, I guess SPAP is not that bad after all!

Funny place to put IP parameters if you ask me.

-Skip

>
>
> Thanks,
>
> Hany A. Ahmed
> Software Engineer
> Intel of Canada, Ltd.
> 2 Eva road , suite 220
> Toronto, ON
> 416-622-8930
> [email-masked]
>
>
>
> > -----Original Message-----
> > From: James Carlson [mailto:[email-masked]]
> > Sent: Tuesday, November 21, 2000 11:15 AM
> > To: Ahmed, Hany
> > Cc: [email-masked]
> > Subject: Re: l2TP with dynamic routing.
> >
> >
> > Ahmed, Hany writes:
> > > I was just wondering about the possibilty of using dynamic
> > routing protocols
> > > (RIP/OSPF etc..) through the L2TP  tunnel to exchange
> > network topology
> > > information between the remote client and the LNS,
> >
> > If you're running IP over that PPP link then, yes, you can run routing
> > protocols.
> >
> > >  is there any related
> > > draft to address any problems or concerns.
> >
> > Such as what?  Is this different from a routing protocol over any
> > other kind of point-to-point link?
> >
> > On-demand and bandwidth-limited links have special problems; those are
> > addressed in the many RFCs dealing with such situations, such as
> > Triggered RIP (RFC 2091).
> >
> > > Is there also any new AVP that indicates the ability of the
> > remote end to
> > > accept
> > > certain routing protocols ?
> >
> > I don't see why you'd want that.  If you had just PPP over a direct
> > serial link, how would you detect that the peer supports a routing
> > protocol?  Doesn't that same method work here?
> >
> > --
> > James Carlson, Internet Engineering
> > <[email-masked]>
> > SUN Microsystems / 1 Network Drive         71.234W   Vox +1
> > 781 442 2084
> > MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1
> > 781 442 1677
> > Second Edition now available -
> > http://people.ne.mediaone.net/carlson/ppp
> >
>
>

---

From: "Ahmed, Hany" <[email-masked]>
Date: Tue, 21 Nov 2000 08:39:18 -0800

Thanks,

Hany A. Ahmed
Software Engineer
Intel of Canada, Ltd.
2 Eva road , suite 220 
Toronto, ON
416-622-8930 
[email-masked]

---

From: James Carlson <[email-masked]>
Date: Tue, 21 Nov 2000 11:51:59 -0500 (EST)

> once it finds out about this capability. 

My point is that if this is a real problem, then L2TP isn't the right
place to solve it.  It's a general problem with links.

> the link all together and save any bandwidth you may use

Are you authenticating the peer at all?  If you are, then you can key
preferences -- such as desired routing protocol, filters, compression
protocols, and other options -- off of the authenticated peer name.
There's no reason to negotiate these.

If you're not authenticating, then you do have to use heuristics.  For
OSPF or IS-IS, it's easy.  Send a few Hellos, and if you don't hear
any back by RouterDeadInterval, then just stop.  For RIP, it's only a
little harder.  Send a few Response messages to make sure that silent
peers get the right data (two or three packets aren't going to hurt
anyone, and there's no compelling need to optimize that).  If you
don't get an ICMP Port Unreachable (telling you immediately that the
peer isn't running RIP), then send a Query to see if the peer is
running RIP.  (I'm not sure I would bother with this on bandwidth
grounds.  One small packet every 30 seconds has no real effect.  I
would do it, though, if it caused inactivity timer problems.)

> routing as well, I guess SPAP is not that bad after all!

If that's true about SPAP (I have no documentation on the protocol),
then that's yet another design flaw.  Link layer authentication
protocols have no business negotiating network layer attributes.

-- 
James Carlson, Internet Engineering       <[email-masked]>
SUN Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677
Second Edition now available - http://people.ne.mediaone.net/carlson/ppp