Subject: question

From: [email-masked]
Date: Thu, 9 Nov 2000 17:01:20 +0800

question 1:In L2tp,whether Proxy Authen Name means remote user or LAC or LNS?

question 2:In L2tp,ppp remote end must first LCP negotiate with LAC,then LAC
create
           L2tp tunnel with LNS,so whether Proxy LCP AVPs are useless?

---

From: Tatsuya Yanagibashi <[email-masked]>
Date: Thu, 09 Nov 2000 21:27:38 +0900

Pan,

ProxyLCP/Auth enables to deliver the information which LAC gather 
during LCP negotiation with remote user to LNS. How LNS treat this 
info depends on the LNS's implementation. This means LNS may use 
this info prevent from renegotiation for LCP and Auth, or may not 
use.

(1)If LNS is willing to use Proxy information from LAC,

User     LAC       LNS
 <------->
  LCP Nego
 <------->
  LCP Auth
          ..........
          --------->
          ICCN(ProxyLCP/Auth)
 <------------------
   Auth-Success or Auth-Fail

(2)If LNS don't want to use those information,

User     LAC       LNS
 <------->
  LCP Nego
 <------->
  LCP Auth
          ..........
          --------->
          ICCN(ProxyLCP/Auth)
 <------------------
     LCP CONFREQ
       ........

Q1: 
ProxyName means username information which LAC get from remote user.

Q2:
PPP itself is terminated at LNS. Therefore remote user and LNS have 
to negotiate PPP baiscally. As you know, most of cases user and LAC 
negotiated LCP before l2tp session establishment. ProxyLCP/Auth helps 
LNS.

I hope this helps you.

Thanks,
Tatsuya Yanagibashi

-- 
/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

 +----+----+                  Tatsuya Yanagibashi     
 |.. .|    |
 |_~__|    |                   Network Consultant
 | .. |~~_~|               CoSine Communications Inc.
 | .  |    |
 +----+----+            e-mail: [email-masked]
 C o S i n e                 Phone # +81-3-5219-1296
Communications               Fax   # +81-3-5219-1201
   
/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/