Subject: [L2tpext] comments on draft-elwin-ppvpn-vtp-00.txt

From: "Vipin Jain" <[email-masked]>
Date: Mon, 10 Dec 2001 08:22:14 -0800

Some quick reaction on the
http://search.ietf.org/internet-drafts/draft-elwin-ppvpn-vtp-00.txt :

- In General: Control Tunnel being pulse of all VPNs, what if it goes down?
During fail-over? Do we bring down all PerVPN tunnels?

- Section 5.2: Initiator getting StopCCN is a very general statement, either
a CDN codes need to be identified or StopCCN be augmented with an AVP
indicating the same. I'd prefer to keep trying to establish the control
connection even if I receive StopCCN, because that's what configuration
dictates.

- Section 5.3, instead of VPN list, it would be better to have each VPN as
one AVP and include multiple AVPs of type VPN-Identifier AVP. This would
help expand the AVP to include further properties of a VPN.

- Section 6.0 and in general:
	* Can one PerVPN tunnel encapsulate traffic for two VPNs? If no then
how does an endpoint identify, say when it receives an SCCRP to know if a
tunnel was established for which VPN; I'd suggest using VPN Identifier AVP
(as defined above) in SCCRQ and SCCRP to clarify the same. This would help
an endpoint identify if it should accept any further tunnels for a given VPN
or not.
	* On Similar note a question: Can two peers have more than one
PerVPN tunnel? If yes, how do I find out if I am exceeding the limit on
maximum allowed tunnels?

thanks,
-- vipin

---

From: "W. Mark Townsley" <[email-masked]>
Date: Mon, 10 Dec 2001 08:32:54 -0800

> Vipin Jain wrote:

Do you mean draft-elwin-l2tpext-ppvpn-00.txt?

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: Elwin Eliazer <[email-masked]>
Date: Mon, 10 Dec 2001 11:01:03 -0800 (PST)

Hi Vipin,

Thanks for your comments/suggestions.
My responses are inlined below.
I have changed the subject in this thread, so as
to have a correct reference.

cheers,
Elwin.

> Some quick reaction on the
http://search.ietf.org/internet-drafts/draft-elwin-ppvpn-vtp-00.txt
> :

We need to address the failover mechanisms in this,
and the general L2TP failover draft can be a candidate
to solve this as well.

> connection even if I receive StopCCN, because that's

We have kept the PPVPN control connection (or tunnel)
exclusive for the PPVPN purposes, and the regular
L2TP cases are kept separate. This we think gives a
clear distinction and separate control in their
operation.

> help expand the AVP to include further properties of

That is an interesting suggestion. We will consider
this in our next update, if there are no other
implications.

> an endpoint identify if it should accept any further

Each VFI has only one associated VPNs, and hence only
one perVPN tunnel to its remote peers. There can be
multiple such perVPN tunnels, when there are multiple
remote peers.

If you are referring the extranet case, it is outside
this draft's scope as of now.

> PerVPN tunnel? If yes, how do I find out if I am

If you are referring the peers, as PE peers, there
can be multiple perVPN tunnels across the peers, one
for each common-VPN. If you are referring to the VFI
peers, then there is only one tunnel expected between
them.

> -- vipin

=====
-------
Elwin Stelzer Eliazer
Corona Networks
"Let's make the world a little more connected!"
-------

__________________________________________________
Do You Yahoo!?
Send your FREE holiday greetings online!
http://greetings.yahoo.com