Subject: [L2tpext] Re: [PWE3] comments on draft-kamapabhava-fr-pwe3-00.txt

From: "W. Mark Townsley" <[email-masked]>
Date: Tue, 22 Jan 2002 16:50:15 +0100

Luca Martini wrote:
> 
> Sasha,,
> 
> I did not mean to say that this would be the common maintenance
> protocol, but it can certainly be a proposal.
> I think that the maintenance document will address all transport types (
> L2TP, MPLS , IP ) and your maintenance protocol can be a contribution..

Actually, each should leverage their own existing control plane when available.
For instance, MPLS could leverage LDP. L2TP should certainly leverage its own
session maintenance and keepalive facility. From the PW perspective, the
requirements are the same and must be equally met, but from a tunneling protocol
application perspective they are different, each able to leverage different
available mechanisms.

> 
> As the contributions to the encapsulation part of are work are getting
> more solid , it is time to think about the maintenance protocol
> architecture and design.
> 
> I would like to ask for additional contributions to the framework
> document, and specifically for a maintenance protocol architecture.
> 
> Luca
> 
> Sasha Vainshtein wrote:
> >
> > Luca,
> > I have re-read the PWE3 charter following your message
> > (BTW, it seems to be temporarily un
> >
> > The latest available release (30-Oct-01) calls for:
> >
> > <quote>
> > o Common Edge-to-Edge Emulation/Maintenance Protocol
> > o Individual encapsulation and emulation/maintenance document(s) for each of
> > the
> > following transported protocols, as well as applicability statements for
> > each
> > ...
> > <end quote>
> >
> > Can you please explain what do you mean by suggesting to move
> > the FR maintenance protocol to its own I-D? I see two
> > possibilities:
> >
> > 1. Move it to the common maintenance document
> > 2. Move it to the FR-specific maintenance document.
> >
> > The first option seems somewhat problematic to me - mainly because
> > I have not yet heard of anybody having started to work on the common
> > PWE3 maintenance document (not at the SLC meeting and not on the
> > list either).
> >
> > The second option would be probably OK - but I would like to know whether
> > it indirectly implies that PWE3 should produce three documents
> > per transported protocol - one for encapsulation,
> > one for maintenance and one for applicability statement.
> > (Probably it would be four - add  one more for the protocol-specific
> > MIB). Nothing wrong with it, of course - just nice to know.
> >
> > With best regards,
> >                                    Sasha Vainshtein
> > email:     [email-masked] <mailto:[email-masked]>
> > tel:       +972-3-7659993 (office)
> >            +972-8-9254948 (res.)
> >            +972-58-674833 (cell.)
> >
> >
> > > -----Original Message-----
> > > From: Luca Martini [mailto:[email-masked]]
> > > Sent: Tuesday, January 22, 2002 2:51 AM
> > > To: [email-masked]
> > > Subject: [PWE3] comments on draft-kamapabhava-fr-pwe3-00.txt
> > >
> > >
> > > Hello!
> > >
> > > Our pwe3 Charter specifies a maintenance protocol for all all PWs. I
> > > would like to suggest that this draft be edited as follows:
> > >
> > > - Maintenance protocol should be moved to it's own ID.
> > > - Resubmitted draft should be proposed as WG item.
> > >
> > > Thanks.
> > > Luca
> > >
> > >
> > >
> > > --
> > > Just say no to summer. Ski all year !
> > > Luca Martini Senior Network Architect, Level 3 Communications -
> > > Broomfield, CO
> > > [email-masked] | VE2WKR/W0 | Phone 720-888-1225 | pager
> > > [email-masked]
> > >
> > > _______________________________________________
> > > pwe3 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/pwe3
> > >
> 
> --
> Just say no to summer. Ski all year !
> Luca Martini Senior Network Architect, Level 3 Communications -
> Broomfield, CO
> [email-masked] | VE2WKR/W0 | Phone 720-888-1225 | pager
> [email-masked]
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 22 Jan 2002 18:42:56 +0200

David,
Please see a comment inline.

With best regards,
                                   Sasha Vainshtein

> From: David Zelig [mailto:[email-masked]]
> Sent: Tuesday, January 22, 2002 5:56 PM
> To: 'W. Mark Townsley'; Luca Martini
> Cc: Sasha Vainshtein; [email-masked]; [email-masked]
> Subject: RE: [PWE3] comments on draft-kamapabhava-fr-pwe3-00.txt
> 
> 
> 
... snipped...
> > > 
> In addition, while each PSN has it's own control plane the 
> configuration needed for the PW setup (excluding outer tunnel which is PSN

> specific and out of scope) in all PSN types from operation point of view 
> must be the same.
>
I agree with a clarification. Configuration DATA  (abstract) needed for the
PW setup
SHOULD be PSN-independent and described in PSN-independent
terms.
MAPPING of this data to specific setup/teardown protocols will depend upon 
these protocols (e.g., L2TP uses AVP language, LDP in Martini-like approach
uses TLV language and manual configuartion presumably requires a MIB
definition which is a language and a skill per se).

A trivial example: a PW TYPE (FR, CEP, Ethernet etc.) is probably a
mandatory
parameter to be used in the PW setup. It can be descibed as a 8-bit integer 
(unless we intend to produce more than 255 PW types) with values allocated
for each
service type in some general PWE3 document and maintained by IANA.

It can be then incorporated into the Martini FEC, into the PW MIB and into a
dedicated L2TP AVP (AFAIK all these protocol-specific descriptions have
been suggested already).
> David