Subject: RE: [L2tpext] Question about LAC

From: "Jayant Jain" <[email-masked]>
Date: Sun, 12 May 2002 00:58:02 -0700

usually the LAC's PPP  would be doing authentication and thats where the
determination would come which realm to use..Hence in your configuration
you should be having LNS profiles based upon realm (@domain), which you
can tunnel to

jayant jain

-----Original Message-----
From: Yoav Nir [mailto:[email-masked]]
Sent: Sunday, May 12, 2002 1:32 AM
To: [email-masked]
Subject: RE: [L2tpext] Question about LAC

I'm afraid I don't understand what the "@domain method" mentioned in the
RFC
is.

Suppose an LAC is owned by an ISP and suppose further that we don't know
any
phone numbers in advance.  How would the LAC know which LNS to contact?
What information does it have that it can possible base a policy on?

W. Mark Townsley wrote:
>
> Yoav Nir wrote:
> >
> > Hello all,
> >
> > As far as I can tell from RFC 2661, an LAC connects to only
> a single LNS.
> > There is no provision for an LAC to open multiple tunnels
> to multiple LNS
> > and to tunnel each call to the appropriate LNS based either
> on configuration
> > parameters (calling number?) or on client request.
>
> An LAC may open Control Connections to as many LNSs as it would like.
>
> >
> > Is there some extension draft or RFC somewhere for this
> functionality?
>
> Such an RFC is unnecessary. Each Control Connection to a
> separate LNS (or even
> the same LNS) is fully independent of the other, so there is
> no great motivation
> to explicitly point out the interaction between each.
>
> > I
> > imagine this would also require an extension to PPP to
> allow the client to
> > request a specific LNS.
>
> No. Just select your LNS based on your local policy. An
> example is the @domain
> method mentioned in the RFC, calling number as you suggest,
> or a any other
> method based upon your policy. PPP does not need to be
> extended for any of
> these.
>
> >
> > Thanks in advance
> >
> > Yoav Nir

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: "Jayant Jain" <[email-masked]>
Date: Tue, 14 May 2002 13:27:24 -0700

In the ZLB ack of a CDN message , should the session id be present in
the header or should it be set to 0

thanks

jayant jain
-----Original Message-----
From: W. Mark Townsley [mailto:[email-masked]]
Sent: Sunday, May 12, 2002 12:03 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [L2tpext] Question about LAC

Yoav Nir wrote:
> 
> Hello all,
> 
> As far as I can tell from RFC 2661, an LAC connects to only a single
LNS.
> There is no provision for an LAC to open multiple tunnels to multiple
LNS
> and to tunnel each call to the appropriate LNS based either on
configuration

> 
> Is there some extension draft or RFC somewhere for this functionality?

Such an RFC is unnecessary. Each Control Connection to a separate LNS
(or even
the same LNS) is fully independent of the other, so there is no great
motivation
to explicitly point out the interaction between each.

> I
> imagine this would also require an extension to PPP to allow the
client to
> request a specific LNS.

No. Just select your LNS based on your local policy. An example is the
@domain
method mentioned in the RFC, calling number as you suggest, or a any
other
method based upon your policy. PPP does not need to be extended for any
of
these.