Subject: [L2tpext] RE: Last Call: 'Transport of Ethernet Frames over L2TPv3' to Proposed Standard (draft-ietf-l2tpext-pwe3-ethernet)

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Mon, 26 Jun 2006 20:01:05 +0300

I have a few questions related to the use of the terms Ethernet and VLAN
in this I-D: 

1. The I-D speaks about 'Ethernet' but does not provide any reference.
What version of the Ethernet standard is targeted here? The latest
approved version of the Ethernet standard is IEEE Std 802.3-2005, but
the IEEE 802.3 WG also has in works an extension of the frame size as
IEEE 802.3as. One cannot talk about Ethernet PDU and MTU without a
proper reference. 
2. The I-D speaks about 'Ethernet VLAN'. Strictly speaking there is no
such thing, Virtual LANs are being defined by IEEE 802.1 and not only
for Ethernet. However accepting terminology license based on the
de-facto reality that most if not all VLANs run over Ethernet, there
still is a need to specify if the document refers to IEEE 802.1Q VLANs
(one 12-bit tag) or IEEE 802.1ad which accommodate multiple tags and
introduce the concepts of Customer VLAN and Service VLAN. Maybe the
VLANs referred in this I-D are transparent to the type of VLANs that are
being connected, but even so there should be text explaining this. 

Dan

> -----Original Message-----
> From: The IESG [mailto:[email-masked]] 
> Sent: Monday, June 12, 2006 6:07 PM
> To: IETF-Announce
> Cc: [email-masked]
> Subject: Last Call: 'Transport of Ethernet Frames over 
> L2TPv3' to Proposed Standard (draft-ietf-l2tpext-pwe3-ethernet) 
> 
> The IESG has received a request from the Layer Two Tunneling 
> Protocol Extensions WG to consider the following document:
> 
> - 'Transport of Ethernet Frames over L2TPv3 '
>    <draft-ietf-l2tpext-pwe3-ethernet-07.txt> as a Proposed Standard
> 
> The IESG plans to make a decision in the next few weeks, and 
> solicits final comments on this action.  Please send any 
> comments to the [email-masked] or [email-masked] mailing lists 
> by 2006-06-26.
> 
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-l2tpext-pwe3-et
> hernet-07.txt
> 
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf-announce
> 

_______________________________________________
L2tpext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/l2tpext

---

From: Javi <[email-masked]>
Date: Tue, 27 Jun 2006 20:51:34 +0200

I have a question related to transport of HDLC frames over L2TPv3 (RFC 4349):

HDLC identifies a number of timers that may be used by an HDLC link (which is operating in the reliable ABM Mode) to provide reliable data transmission, such as the Acknowledgement Timer (T1).

How are these timers managed in transport of HDLC frames over L2TPv3 and PWEs?. The transport over IP may result in an expiration of the timers.

Javi

---

From: Ignacio Goyret <[email-masked]>
Date: Tue, 27 Jun 2006 15:07:57 -0700

At 20:51 6/27/2006 +0200, Javi wrote:
>HDLC identifies a number of timers that may be used by an HDLC link (which
>is operating in the reliable ABM Mode) to provide reliable data transmission,
>such as the Acknowledgement Timer (T1).
>
>How are these timers managed in transport of HDLC frames over L2TPv3 and PWEs?.
>The transport over IP may result in an expiration of the timers.
>
>Javi 

I would expect the timers to work the same way as they do over a regular
point to point link.

Depending on the quality of the link between the LCCEs, the expiration times
may need tweaking though.

-Ignacio