Subject: [L2tpext] draft-ietf-l2tpext-tdm-05

From: Ignacio Goyret <[email-masked]>
Date: Fri, 01 Aug 2008 12:00:00 -0700

Hi Sasha,
This last rev has been a big improvement. Thanks for your work!

I have just a few more editorial changes:

* Section 2, last paragraph (page 3)

OLD: There are two new AVPs for the Session Connection Messages.
                                            ^^^^^^^^^^ ^
NEW: There are two new AVPs for the Session Management messages.
                                            ^^^^^^^^^^ ^

* Section 2.1, page 4:

OLD:
     a) The specified value MUST be an integer multiple of
        number of DS0 channels in the corresponding attachment
        circuit.
NEW:
     a) The specified value MUST be an integer multiple of the
                                                           ^^^
        number of DS0 channels in the corresponding attachment
        circuit.

* Section 2.2, page 5:
OLD:  PT is the payload type expected in the RTP header.  Value of zero
                                                          ^
NEW:  PT is the payload type expected in the RTP header.  A value of zero
                                                          ^^^

* Section 3, 2nd bullet point under "CESoPSN basic" (page 7):

   s/teh/the/

* IANA Considerations:
  Just to make it clear to everyone involved, you may want to separate
  the lonely return code from the list of return/error codes and make
  two lists: a return code list (one item) and an error code list (with
  the 5 items).

The text looks reasonably solid to me, so I believe we are ready
for WGLC.

Thanks again for the effort that you have put into this work.

Cheers,
-Ignacio

_______________________________________________
L2tpext mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l2tpext

---

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 3 Aug 2008 16:23:53 +0300

Ignacio,
Lots of thanks for a very detailed review.

I agree with you that the document is ready for the WG LC, since most of the comments are editorial and can be done after the LC.

I would appreciate  your advice regarding split of the IANA Considerations section.

Regards,
        Sasha

> -----Original Message-----
> From: Ignacio Goyret [mailto:[email-masked]]
> Sent: Friday, August 01, 2008 10:00 PM
> To: Alexander Vainshtein
> Cc: [email-masked]
> Subject: draft-ietf-l2tpext-tdm-05
>
> Hi Sasha,

---

From: Ignacio Goyret <[email-masked]>
Date: Mon, 04 Aug 2008 10:45:38 -0700

>I would appreciate your advice regarding split of the IANA Considerations section.

Sure. My thought was that instead of this:

   New return codes and error codes:

   1. RC-TBD-1 - return code to indicate connection refused
      because of TDM PW parameters. The exact error code is as
      follows.
   2. EC-TBD-1 - indicate Bit Rate values disagree.
   3. EC-TBD-2 - indicate different trunk types in the case of
      trunk-specific CESoPSN with CAS
   4. EC-TBD-3 - requested payload size too big or too small.
   5. EC-TBD-4 - RTP header cannot be generated.
   6. EC-TBD-5 - requested timestamp clock frequency cannot be
      generated

The table could be split like this:

   New return codes for the CDN message:

   1. RC-TBD-1 - Connection refused because of TDM PW parameters.
      The Error Code indicates the problem.

   New error codes, to be used with RC-TDB-1 return code:

   1. EC-TBD-1 - Bit Rate values disagree (TDM PW AVP).
   2. EC-TBD-2 - Different trunk types (for trunk-specific
                 CESoPSN with CAS).
   3. EC-TBD-3 - Requested payload size too big or too small.
   4. EC-TBD-4 - RTP header cannot be generated.
   5. EC-TBD-5 - Requested timestamp clock frequency cannot be
                 generated.

This format is more in line with IANA's registry.

Makes sense?
-Ignacio

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 5 Aug 2008 07:43:50 +0300

Ignacio,
Lots of thanks, will do that.

Regards,
        Sasha
> Sent: Monday, August 04, 2008 8:46 PM
> To: Alexander Vainshtein
> Cc: Ignacio Goyret; [email-masked]; [email-masked]
> Subject: Re: [L2tpext] draft-ietf-l2tpext-tdm-05
>
>
> >> * IANA Considerations: