Subject: [L2tpext] RFC 4591 and RFC 4349

From: Javi Muñoz <[email-masked]>
Date: Thu, 22 Jul 2010 13:19:51 +0200

Ignacio,

Some yeras ago, you explained me the next working of the HDLCPWs and FRPWs:

===
a) HDLCPWs (port mode):

             C1                            C2
    [ FR A ]----[ LCCE 1 ]------[ LCCE 2 ]----[ FR B ]

<------ L2TP HDLCoPW ---->

<------------- FR traffic ------->

The above set of devices will behave exactly
the same (bit for bit on cables C1 and C2) as if C1 and C2
were the same physical cable, eg:

    [ FR A ]----..........................----[ FR B ]

<------------- FR traffic ------->

where the series of dots above represents the transparent PW
between LCCE 1 and LCCE 2.

b) FRoPW (DLCI mode):

            C1                            C2
   [ FR A ]----[ LCCE 1 ]------[ LCCE 2 ]----[ FR B ]

<------ L2TP FRoPW ---->
<----> <---->
         FR traffic                   FR traffic

where "FR traffic" here means Q933 exchanges. The actual data traffic
for each PVC is obviously transported end to end (ie, FR A to FR B
and viceversa).

DLCIs in this mode have local significance.
In other words, Q933 exchanges happen between "FR A" and "LCCE 1" in
one end and between "FR B" and "LCCE 2" on the other end.

In this mode, the L2TP cloud behaves as if it were a FR switch.

===

If we consider a traditional back-to-back communication between two FR 
terminals, using FR terminology (obviously, Q.933 only for SVCs, no for 
PVCs):

     DTE - DCE <== Data Network ==> DCE - DTE
<Q.933> <Q.933>
<------------- FR VC ------------->
<DLCI_1>  [  DLCI switching  ] <DLCI_2>
               [ DLCI_1 => DLCI_2 ]

Now, if we use PWs in the left "DTE - DCE":

a) HDLCPWs:

     DTE [ - PE <== HDLCPW ==> PE - ] - DCE <== Data Network ==> DCE - DTE
<-------------Q.933--------------> <Q.933>
<------------------------- FR VC ------------------------------->
<------------DLCI_1 (Q.922)------>    [ DLCI switching  ] <DLCI_2>
                                             [ DLCI_1 => DLCI_2]

     So, in this case, DTEs do not notice any difference with the 
tradicional scenario.

b) FRPWs: according with your explanation, I would understand the next one:

                                            ¿ ?
                                             |
                                             |
                                            \ /
     DTE - PE/DCE <== FRPW ==> PE/DCE - ¿¿¿DTE??? <== Data Network ==> 
DCE - DTE
<Q.933> <Q.933> <Q.933>
<-------------------------- FR VC ------------------------------------->
<DLCI_1> [DLCI switching] <DLCI_2>         [ DLCI switching ] <DLCI_3>
               [DLCI_1 => DLCI_2]                  [DLCI_2 => DLCI_3]

     However, it would not be possible, due to the access nodes to the 
data network must be DCEs.

Would you clarify how would be this last scenario?

Regards,

Javi

---

From: Javi Muñoz <[email-masked]>
Date: Thu, 22 Jul 2010 13:35:53 +0200

[I resend the e-mail with the graphics fixed. Sorry the inconvenience]

Ignacio,

===
a) HDLCPWs (port mode):

             C1                            C2

b) FRoPW (DLCI mode):

            C1                            C2

                <------ L2TP FRoPW ---->
          <---->                        <---->
         FR traffic                   FR traffic

===

a) HDLCPWs:

                                            ¿ ?
                                             |
                                             |
                                            \ /
DTE - PE/DCE <== FRPW ==> PE/DCE - ¿DTE? <== Data Network ==> DCE - DTE
   <Q.933>                     <Q.933>                          <Q.933>
   <-------------------------- FR VC -------------------------------->
   <DLCI_1> [DLCI switching] <DLCI_2>     [ DLCI switching ]   <DLCI_3>
            [DLCI_1 => DLCI_2]            [DLCI_2 => DLCI_3]

Regards,

Javi

---

From: Ignacio Goyret <[email-masked]>
Date: Thu, 22 Jul 2010 12:50:32 -0700

At 01:35 PM 7/22/2010 +0200, Javi Muñoz wrote:

>...

>    However, it would not be possible, due to the access nodes to the data network must be DCEs.

I think you are overthinking this.

First, note that my drawings did not include any references to
DCE or DTE on purpose because that is an implementation issue
out of scope for L2TP.

I imagine that if someone wanted to use FR over an L2TP PW,
the LCCEs (or the devices feeding into the LCCEs) would have
to be DCE or DTE as needed. There are many devices out there
that can be configured as either DCE or DTE so this shouldn't
really be a problem.

HTH,
-Ignacio

---

From: Javi Muñoz <[email-masked]>
Date: Fri, 23 Jul 2010 10:59:08 +0200

Hi Ignacio,

>> DTE - PE/DCE<== FRPW ==>  PE/DCE - ¿DTE?<== Data Network ==>  DCE - DTE
>>   <Q.933>                      <Q.933>                           <Q.933>
>>   <DLCI_1>  [DLCI switching]<DLCI_2>      [ DLCI switching ]<DLCI_3>

I need to detail this scenario for an specific application of the FRPWs 
(to ISDNs).

According to the working of the FRPWs, I think that the DTE/DCE 
funcionality of each CEs and PEs would be:

CE1(DTE) - PE1(DCE)<== FRPW(DLCI switching) ==>  PE2(DCE) - CE2(DTE)

However, when I consider a back to back comunication between tww FR 
terminals, that behaviour is not coherent with the classical FR working:

CE1(DTE,FR terminal) - PE1(DCE)<=FRPW=>  PE2(*DCE*) - CE2(*DTE*)<=Data Network=>  DCE - DTE (FR terminal)

 From the point of view of the "Data network", it would be:

CE1(DTE,FR terminal) - PE1(DCE)<=FRPW=>  PE2(*DTE*) - CE2(*DCE*)<=Data Network=>  DCE - DTE (FR terminal)

but it would not coincide with the "DLCI swithing" working of the FRPWs.

Could you help me to assign the DTE or DCE behaviour of each equipment 
in this back-to-back communication?

Thanks,

Javi