Subject: [L2tpext] FW: comments about draft-mkonstan-l2tpext-keyed-ipv6-tunnel

From: "Xialiang (Frank)" <[email-masked]>
Date: Tue, 17 Dec 2013 03:19:05 +0000

Hi authors,
I have sent this email of comments for a period of time, but don't get response.
So I try to send it again and hope for getting your kindly feedback.
Thanks!

B.R.
Frank

From: L2tpext [mailto:[email-masked]] On Behalf Of Xialiang (Frank)
Sent: Friday, December 06, 2013 3:35 PM
To: [email-masked]; Giles Heron (giheron); [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [L2tpext] comments about draft-mkonstan-l2tpext-keyed-ipv6-tunnel

Hi authors,
I have reviewed this draft, and consider it a useful draft for giving a concrete use case of using mature L2TPv3 protocol as a data plane overlay technology. I also have several comments below:

1.       You use a source+des IP pair to identify a L2TP tunnel without tenant id carried on the wire. It increases the complexity when identifying tenant network's traffic using the mapping between tenant network and a large number of source+des IP pairs, especially when tenant network are highly distributed in the real network. While, using tenant id carried on the wire can reduce the complexity largely;

2.       Would you consider more general use cases, e.g., supporting IPv4 underlay network, and different types of services overlaid on it (e.g., Ethernet, PPP, IPv4, IPv6 ,etc)?

3.       I cannot find contents in the draft describing how to implement the multipoint VPN in detail. If you don't use control plane, then data plane flooding or manage plane provision should be supported. Do you follow this way?

B.R.
Frank

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Tue, 17 Dec 2013 06:18:50 +0000

Frank, in-line and sorry for the late reply

From: "Xialiang (Frank)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday 17 December 2013 04:19
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Giles Heron (giheron)" <[email-masked]<mailto:[email-masked]>>, "rainer. schatzmayr" <[email-masked]<mailto:[email-masked]>>, Wim Henderickx <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: FW: comments about draft-mkonstan-l2tpext-keyed-ipv6-tunnel

Hi authors,
I have sent this email of comments for a period of time, but don’t get response.
So I try to send it again and hope for getting your kindly feedback.
Thanks!

B.R.
Frank

From: L2tpext [mailto:[email-masked]] On Behalf Of Xialiang (Frank)
Sent: Friday, December 06, 2013 3:35 PM
To: [email-masked]<mailto:[email-masked]>; Giles Heron (giheron); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [L2tpext] comments about draft-mkonstan-l2tpext-keyed-ipv6-tunnel

Hi authors,

1.       You use a source+des IP pair to identify a L2TP tunnel without tenant id carried on the wire. It increases the complexity when identifying tenant network’s traffic using the mapping between tenant network and a large number of source+des IP pairs, especially when tenant network are highly distributed in the real network. While, using tenant id carried on the wire can reduce the complexity largely;

WH> given that we have enough bits in IPv6 addresses, this draft provides the tenant information based on the IPv6 addressing.

WH> the draft is focussed on IPv6 only, since the assumption on point 1 is no longer valid.

3.       I cannot find contents in the draft describing how to implement the multipoint VPN in detail. If you don’t use control plane, then data plane flooding or manage plane provision should be supported. Do you follow this way?

WH> I am not sure I understand the point but the draft allows to provision the endpoints through a management plane.

B.R.
Frank